locked
Why is Windows 10 file explorer is unaccepably slow? RRS feed

  • Question

  • Why is Windows 10 file explorer is very very slow?  It is unacceptable.  Any suggestions?
    Wednesday, August 19, 2015 1:37 AM

Answers

  • Please run a system file check (SFC) & DISM (if necessary) if you are on win 8 or higher

    All instructions are in our Wiki article below...
    Should you have any questions please ask us.




    Wanikiya and Dyami--Team Zigzag

    Wednesday, August 19, 2015 1:38 AM
    Moderator
  • Hi,

    In addition to what has been mentioned by MVP zigzag, please keep your system up to date for good measure, make sure that the Windows search service is running and set to Automatic. If the issue still persists after system file check, check the startup program under by using clean boot mode.

    https://support.microsoft.com/en-us/kb/929135

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 24, 2015 2:35 AM
    Moderator

All replies

  • Please run a system file check (SFC) & DISM (if necessary) if you are on win 8 or higher

    All instructions are in our Wiki article below...
    Should you have any questions please ask us.




    Wanikiya and Dyami--Team Zigzag

    Wednesday, August 19, 2015 1:38 AM
    Moderator
  • Hi,

    In addition to what has been mentioned by MVP zigzag, please keep your system up to date for good measure, make sure that the Windows search service is running and set to Automatic. If the issue still persists after system file check, check the startup program under by using clean boot mode.

    https://support.microsoft.com/en-us/kb/929135

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 24, 2015 2:35 AM
    Moderator
  • Did you disable Cortana like everyone else who is using Windows 10?  I had the same issue. Funny how enabling it fixed my issue.

    Wednesday, December 2, 2015 10:55 PM
  • sfc returns:

    "Windows Resource Protection could not start the repair service."

    And yes, I ran cmd as an administrator.  Also, Cortana doesn't find anything.  However, VoidTools' Everything utility works fast and great!

    I would like my File Explorer back, though... I've been waiting for it to open for more than 15 minutes now.  It only shows that it is "Working on it..." and scanning Quick Access.


    Saturday, December 26, 2015 2:32 AM
  • I think this is due to the indexing and 'optimizations' happening in the background.  Your folder most probably has large video files and the system scans and stores the video attributes every time you open the folder.

    1.  In File Explorer, right-click on the folder that you want to speed up.  This will open the Folder Properties window.

    2.  In the Folder Properties window, click on the Customize tab.

    3.  In the 'Optimize this folder for:', select 'General items'.  You can tick the 'Also apply this template to all subfolders' if you want.

    4.  Click on the OK button.

    This worked for me.

    Wednesday, December 30, 2015 10:21 AM
  • The folder that's showing me "working on it" for many minutes now is EMPTY. So that's not it. 
    Sunday, January 31, 2016 8:01 AM
  • I can not accept this as an answer.

    Windows 10 quality is just poor with this and other issues, such as crashing Edge. So the user will have to look for fixes and MicroSoft does not have to get their act together?

    Imo Windows 10 is the worst Windows version ever. Far too many performance issues.

    Sunday, January 31, 2016 8:56 PM
  • I agree with you that the approach "sfc /scannow" is poor, it's probably the oldest and never working hint on the internet.

    I disagree with you that Windows 10 is unacceptable slow, my setup is running insanely good even on older hardware.

    Concerning your problem: is your system reacting very slow all together or is it just the Windows Explorer Process?

    This could have many reasons:

    • Do you use any 3rd party anti virus software?
    • is browsing only slow when browsing networked files?
    • are you running a preinstalled Windows 10 or did you set it up on your own?
    • do you have a SSD or a mechanic hard disk drive?

    I need some more information on this to help you out.


    Sunday, January 31, 2016 9:13 PM
  • I have always found slowness in windows 10 file explorer to be due to some item that has ended up in in a pinned list, or quick access list where that item itself has become slow to open or access. Usually it is something like a network folder that is no longer available (another computer turned off, network down or whatever) Also sometimes you can have a a badly behaved app returning file type info, or right click info that is slow.  

    The slowness happens even if you are not actually working with this folder/item in file explorer - Windows 10 pre-empts that you "might" want to access it, and goes to prepares results for you. Unfortunately it is badly programmed in that this pre-fetch is done on the same thread you are using to do "real" work - so if any item delays, all items are delayed.

    You have to have a pretty badly compromised system before there is a problem sfc can detect let alone fix - this is a cop out answer which is how you can tell they have the  MCC/MVP qualification. Sure sfc means a lot of unlikely problems are eliminated from consideration, but it rarely solves common ones because, believe it or not, Microsoft do a pretty good job of keeping their system updates in a way that means failures due to version control are unlikely.




    • Edited by Jeltz191 Saturday, February 13, 2016 2:19 AM
    • Proposed as answer by HGK07 Sunday, May 1, 2016 10:02 PM
    Saturday, February 13, 2016 1:48 AM
  • I have the same issue. It takes about 5 seconds to load. Once loaded, it works fine.

    It does the same thing when opening Control Panel.

    I did find a temporary work around - use [Windows] + [E] to load File Explorer, instead - it loads instantly!

    Monday, February 15, 2016 7:10 PM
  • It might help to reset the windows view to the default settings across all your folders.  If your current view (basically what columns are displayed and how the icons look in each explorer window) requires that each file be opened to access certain information, it will definitely slow it down.  

    It's an easy fix to apply that default view across all your folders at once.  This means that all your folders will have the view settings of a new installation of Windows 10.

    To reset your current file explorer view to default, search for "Folder Options" at the start gem, select "Change search options for files and folders" (it's a control panel widget), and a "Folder Options" dialog will appear. Select the "View" tab, and you'll see "Folder Views" at the top.   Click on the "Reset Folders" button and allow it to apply across all your folders. Then your view will be reset to default across all of your folders.  After applying this, all your folders will appear similarly when you open them.  You may then find that the directories open again with speed.   If you make a change (such as adding a column to show bit rates), and it slows it down, you'll know why.

    Why does this work faster?  Because in the default view, windows doesn't need to open each and every file n the directory to pull up the requested info to show in the view, so it's much faster.



    • Edited by BigJohnnyO Sunday, February 28, 2016 12:35 PM
    • Proposed as answer by HGK07 Sunday, May 1, 2016 10:03 PM
    • Unproposed as answer by HGK07 Sunday, May 1, 2016 10:04 PM
    • Proposed as answer by HGK07 Sunday, May 1, 2016 10:04 PM
    Sunday, February 28, 2016 12:27 PM
  • This worked for me. Once I hit Reset Folders explored opened in a fraction of a second.
    Monday, April 4, 2016 12:41 AM
  • i faced same problem.... it is due to "quick access". I followed the following steps.

    1.open file explorer

    2.right click on "quick access" and select "potions"

    3.in general tab change "open file explorer to this pc"

    4.save the changes...

    • Proposed as answer by Wes Ray Thursday, June 9, 2016 7:44 PM
    Thursday, May 26, 2016 9:13 PM
  • This also worked for me... Thanks.
    Monday, June 6, 2016 4:41 PM
  • Whoa... after all the nonsense both here and on the web, this is the actual fix. Dunno why, but it fixed it. 

    NOW: Here's where Microsoft learns from user expectation and updates the relationship in Explorer so the entire world doesn't have to sleuth their way through the labyrinth of wrong to fix something that should just work as expected.

    Call it a DCR or a bug or whatever, but do fix this.

    Customer satisfaction. Go for that, and we'll consider sticking around.

    Thursday, June 9, 2016 7:48 PM
  • It didn't fix it for me. So this isn't necessarily the answer. 
    Friday, June 10, 2016 3:31 AM
  • Same here. As soon as I upgraded to Windows 10, it has been "Working on it" extremely frequently and I end up having to wait a minute or 2 per click sometimes. Just trying to navigate the tree. And even second and third, etc...times I re-enter the same tree item it again takes forever. It's been "Working on it" so much that I'm thinking it should have accomplished quite a lot by now, whatever the heck it thinks it's doing.
    Tuesday, June 14, 2016 9:11 PM
  • Thank you. Thank you very much.
    Thursday, June 16, 2016 8:14 PM
  • Thanks. After I figured out that potions really meant options, I did that and it works fine now. What mine was doing was continually showing the green "progress" bar in the address window, animating left-to-right, and wouldn't stop. I never got the "working on it" note; it always opened, but with the progress bar animating, I couldn't expand folders in the left pane. I could double-click a folder on the right and it would go there, but sometimes I want to see the tree structure on the left. I can do that now.

    Bob Mathews Director of Training Design Science, Inc. Twitter: @afwings, @MathType www.dessci.com ~ Makers of MathType, MathFlow, MathPlayer, MathDaisy, Equation Editor ~

    Wednesday, July 20, 2016 5:19 PM
  • Windows Search is one reported source of slowness.  https://www.tekrevue.com/tip/how-to-solve-windows-search-issues-index-rebuild/
    • Proposed as answer by thewizardoz Tuesday, October 18, 2016 11:04 PM
    Thursday, July 21, 2016 10:55 AM
  • Just had this issue start after applying the July 2016 Rollup.

    Fixed by:

    opening File Explorer (wait for it...)

    Click on File tab (it's already highlighted by default on launch, but LC anyway)

    Click Change folder and search options

    On General tab:

      -  Change Open File Explorer to: This PC (default is Quick Access)

      -  Uncheck both "Show" check boxes in Privacy area

      -  Click "Clear" button for File Explorer history

    Relaunch File Explorer - all good.

    Wednesday, July 27, 2016 4:36 PM
  • Just had this issue start after applying the July 2016 Rollup.

    Fixed by:

    opening File Explorer (wait for it...)

    Click on File tab (it's already highlighted by default on launch, but LC anyway)

    Click Change folder and search options

    On General tab:

      -  Change Open File Explorer to: This PC (default is Quick Access)

      -  Uncheck both "Show" check boxes in Privacy area

      -  Click "Clear" button for File Explorer history

    Relaunch File Explorer - all good.

    That didn't work for me

    Monday, August 1, 2016 7:53 PM
  • Thank you so much.

    This worked perfectly for me. My directories were full of video files and were taking forever to list.

    Tuesday, August 9, 2016 3:35 PM
  • I am a systems administrator for a non-profit.  We had this problem on several of their PC's.

    Here is a workaround I discovered, I've put it on my Tech blog.

    http://jmiscstuff.blogspot.com/

    Hope this helps someone...

    J

    Sunday, August 21, 2016 5:43 PM
  • I had a bad case of this, and zj741's solution is the one that worked for me.

    Basically, if you start explorer.exe from a command prompt with "explorer /n" it works as it should and does not hang up in the green bar.  In fact adding any switch, such as "/?" seems equally effective.  

    !!!BUG!!! Microsoft?

    zj741 suggests creating a desktop shortcut with target "C:\Windows\explorer.exe /n".  I suggest you also give that shortcut a shortcut key, I chose Ctrl-Alt-E.  

    Wednesday, August 31, 2016 9:03 PM
  • I have tried all of these suggestions and none of them worked.  Possibly I only get the green bar for 1-2 minutes now instead of the 3-4 minutes it used to be (yes, I mean minutes not seconds!).  I still have to open explorer and then go and do something else while it loads the files.

    I have a very old XP machine which loads the files from the same networked directory instantly.  There is something major wrong with explorer on Windows 10.

    Tuesday, September 6, 2016 8:35 AM
  • I have a brand new high end mobile workstation with quad core CPU, SSD, and Windows 10.  I installed *all* available updates to Windows 10 and device drivers.      Still have the aggravating slowness with File Explorer as described above.  Tried the trick of adding "/n".  This worked great everywhere except for "This PC".  All folders open instantly with "/n" on command line.  I even have one folder with over a thousand 3GB videos..  and it opens instantly.  But when I attempt to open "This PC" it first says "Working on it".  Then the SLOW green bar creeps across the screen for minutes before completing.  Very aggravating.

    Wednesday, September 14, 2016 11:33 PM
  • Ok, what is the "start gem"???

    I agree with the other postings that Microsoft by default seems to complicate File Explorer so that it appears to be recaching details on every file every time you touch the view. A horrific waste of time for those of us under production deadlines, coupled with vague help information that simply does not help. Of course this happens when our IT expert is out of town, but this is basic basic basic stuff that should be properly documented and NOT require expert intervention. One would think that Windows 10 should have been contrived to realize that if a folder view is taking more than X (5 seconds? 10 seconds?) then the user should be automatically prompted with a fix. There is a similar legacy screwup in Outlook in which setting a rule can lock Outlook for up to 5 minutes - also totally unacceptable to the customer, but Microsoft appears to be powerless to fix the bugs. 

    Sunday, September 18, 2016 6:56 AM
  • Great answer, because it worked! One thing, when you open the Customize tab if it is already set to General Items you will need to change it to anything else then back for the Apply button to become active. But this solution did seem to solve my problem.

    Thanks.


    • Edited by BLM881 Saturday, September 24, 2016 3:18 PM
    Saturday, September 24, 2016 3:18 PM
  • Hello,

    I understand how frustrating it is but I seem to have found a fix to your problem. This was my problem too. Though it did fix by following the trick of adding "/n" somehow it still felt something was not complete because the My PC icon was still slow. I was able to find a fix from too much googling and found out that the culprit was with the file indexing. It may have somehow stopped working.

    To fix this you need to got to

    control panel>indexing options>advanced>rebuild.

    It somehow rebuilt the files and fixed the issue of My PC taking too long or the file explorer that is taking too long. Prior to this my icons every time the explorer opens are not being showed properly. Some will appear and some won't. I already tried a few stuff but nothing worked except for this final fix.

    Saturday, September 24, 2016 5:47 PM
  • Hello,

    I understand how frustrating it is but I seem to have found a fix to your problem. This was my problem too. Though it did fix by following the trick of adding "/n" somehow it still felt something was not complete because the My PC icon was still slow. I was able to find a fix from too much googling and found out that the culprit was with the file indexing. It may have somehow stopped working.

    To fix this you need to got to

    control panel>indexing options>advanced>rebuild.

    It somehow rebuilt the files and fixed the issue of My PC taking too long or the file explorer that is taking too long. Prior to this my icons every time the explorer opens are not being showed properly. Some will appear and some won't. I already tried a few stuff but nothing worked except for this final fix.

    Saturday, September 24, 2016 5:47 PM
  • Hello,

    I understand how frustrating it is but I seem to have found a fix to your problem. This was my problem too. Though it did fix by following the trick of adding "/n" somehow it still felt something was not complete because the My PC icon was still slow. I was able to find a fix from too much googling and found out that the culprit was with the file indexing. It may have somehow stopped working.

    To fix this you need to got to

    control panel>indexing options>advanced>rebuild.

    It somehow rebuilt the files and fixed the issue of My PC taking too long or the file explorer that is taking too long. Prior to this my icons every time the explorer opens are not being showed properly. Some will appear and some won't. I already tried a few stuff but nothing worked except for this final fix.

    Saturday, September 24, 2016 5:48 PM
  • I had the exact same problem, go to your control panel / upgrade and security and recover the previous version of your windows 10. Microsoft really blew it with this shit update. I used to be a fan but now having seen how easy to use and user friendly (specially with speed) Apple is, I switched to Mac and will sell my windows laptop on Ebay! 
    Tuesday, September 27, 2016 5:40 PM
  • I  had same problem.  I downloaded  Q-Dir to substitute for file explorer.  Problem fixed.   
    Saturday, October 1, 2016 11:30 PM
  • Windows Search is one reported source of slowness.  https://www.tekrevue.com/tip/how-to-solve-windows-search-issues-index-rebuild/

    Awesome! Thanks mate! This sorted out my slow Explorer problems.

    Windows Search service wasn't running and couldn't start, Went to Indexing which showed there was nothing being indexed. So I clicked on Rebuild Indexes and after a short while several folders showed up as being indexed! From there you can decide which folders are and aren't indexed.

    Tuesday, October 18, 2016 11:04 PM
  • I have 5 different computers all running Windows 10,  all experience the same slow delete, copy, properties.  I am currently copying a 2 gig file 30% after 10 hours!  MS, please release a fix.  
    Thursday, October 20, 2016 12:32 PM
  • I have the aforementioned issue with file explorer being painfully slow and hanging. I will try to rebuild the index on my server as it only happens on the network share.

    Issue with Slow copying - Is it copying to or from the Server. I resolved this issue by updating my Network car driver on the server. Worth a try Foot Guy ^^

    Thursday, October 27, 2016 10:39 AM
  • Did not work.
    Monday, November 14, 2016 11:50 AM
  • Did not work.
    Monday, November 14, 2016 11:50 AM
  • I have tried to disable her but she keeps coming back. I hate Cortana. 
    Monday, November 14, 2016 11:51 AM
  • I have done this in previous versions, and it helped. Not so now.
    Monday, November 14, 2016 11:52 AM
  • Me too.
    Monday, November 14, 2016 11:52 AM
  • This works!
    Monday, November 14, 2016 11:53 AM
  • Did not work. Could use some potions, though.
    Monday, November 14, 2016 11:53 AM
  • btw "Options" is greyed out when I attempt this.
    Monday, November 14, 2016 11:54 AM
  • Did not work.

    Monday, November 14, 2016 11:55 AM