none
Enable prioirty queuing and verify this in Exchange 2013

    Question

  • Hello -

    I am trying to enable Exchange priority queuing.  I've gone through this article https://technet.microsoft.com/en-us/library/jj891104(v=exchg.150).aspx and completed the steps without an issue.  #2 in the "How do you know if this worked" section, it says to test out, send an email as high priority that is larger than the max high priority value, which by default is 250KB and it should instead send as a normal email.   Well I did this, and when I receive it on the other end, its still a high priority email.  This leads me to believe that things are not working right.

    Maybe this is normal behavior and the article is wrong?  Can someone help?

    Thanks!

    Wednesday, September 14, 2016 5:25 PM

Answers

  • Hi,

    I configured the setting in my exchange 2013 test environment, unfortunately I got the same results as yours.

    Here are my steps:

    1.    Open EdgeTransport.exe.config on all Exchange servers.
    2.    Configure PriorityQueuingEnabled to true.
    3.    Restart the Microsoft Exchange Transport service on all Mailbox servers.

    I use outlook to create a high priority test message that's larger than the value specified by the MaxHighPriorityMessageSize key, recipient still receive the message with high priority.

    Then I read this document

    https://technet.microsoft.com/en-us/library/bb691107%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396

    At the end of this document, it said: The Set-Mailbox cmdlet has the DowngradeHighPriorityMessagesEnabled parameter. The default value is $false. When this parameter is set to $true, any High priority messages sent from the mailbox are automatically downgraded to Normal priority.

    So I change it for one user to see if Downgrade High Priority feature will work in exchange 2013.

    Set-Mailbox UserName –DowngradeHighPriorityMessagesEnabled $true

    I send a high priority test message from this user, but the recipient still receive the high priority message. It seems that Downgrade High Priority feature doesn’t work. I am not convinced, so I go to check the definition of DowngradeHighPriorityMessagesEnabled parameter in Set-Mailbox cmdlet.

    It says:  The DowngradeHighPriorityMessagesEnabled parameter specifies whether to prevent the mailbox from sending high priority messages to an X.400 mail system. If this parameter is set to $true and the mailbox sends a high priority message destined to an X.400 mail system, the message priority is changed to normal priority.

    So it seems like DowngradeHighPriorityMessages feature only applies to messages that sent to X.400 mail system. And what we experienced in configuring priority queuing is normal behavior. Hope my test and researching will be helpful for you.


    Regards,

    Lynn-Li

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 15, 2016 7:38 AM
    Moderator

All replies

  • Hi, Moltron

    I will do some test and research on this setting, will let you know the results as soon as possible.

    Thanks for patience!


    Regards,

    Lynn-Li

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 15, 2016 7:03 AM
    Moderator
  • Hi,

    I configured the setting in my exchange 2013 test environment, unfortunately I got the same results as yours.

    Here are my steps:

    1.    Open EdgeTransport.exe.config on all Exchange servers.
    2.    Configure PriorityQueuingEnabled to true.
    3.    Restart the Microsoft Exchange Transport service on all Mailbox servers.

    I use outlook to create a high priority test message that's larger than the value specified by the MaxHighPriorityMessageSize key, recipient still receive the message with high priority.

    Then I read this document

    https://technet.microsoft.com/en-us/library/bb691107%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396

    At the end of this document, it said: The Set-Mailbox cmdlet has the DowngradeHighPriorityMessagesEnabled parameter. The default value is $false. When this parameter is set to $true, any High priority messages sent from the mailbox are automatically downgraded to Normal priority.

    So I change it for one user to see if Downgrade High Priority feature will work in exchange 2013.

    Set-Mailbox UserName –DowngradeHighPriorityMessagesEnabled $true

    I send a high priority test message from this user, but the recipient still receive the high priority message. It seems that Downgrade High Priority feature doesn’t work. I am not convinced, so I go to check the definition of DowngradeHighPriorityMessagesEnabled parameter in Set-Mailbox cmdlet.

    It says:  The DowngradeHighPriorityMessagesEnabled parameter specifies whether to prevent the mailbox from sending high priority messages to an X.400 mail system. If this parameter is set to $true and the mailbox sends a high priority message destined to an X.400 mail system, the message priority is changed to normal priority.

    So it seems like DowngradeHighPriorityMessages feature only applies to messages that sent to X.400 mail system. And what we experienced in configuring priority queuing is normal behavior. Hope my test and researching will be helpful for you.


    Regards,

    Lynn-Li

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 15, 2016 7:38 AM
    Moderator
  • Thanks Lynn-Li for looking into this in-depth.  This helped in re-enforcing the idea that priority queuing just is not going to work for us.  We had to turn it off as it caused another side effect.  We use DAG groups, and the shadow queues would grow and grow to a huge amount (thousands of emails) while priority queuing was enabled.  I'm convinced this is a bug, and maybe it's fixed somewhere in a CU.  We're not fully patched - waiting on software support for something else that ties to Exchange.

    We've come up with another way to get these messages out quickly. 

    Thanks!

    Tuesday, October 11, 2016 1:05 PM