locked
problem with inserting wmf images into Microsoft Word 2010 RRS feed

  • Question

  • Hello,

    I have a client who uses WMF and TIF images for mechanical manuals.  Ever since they upgraded from Office 2000 (to 2002), they've had issues with wmf files not inserting correctly into word.  they continued using Office 2000, but after the upgrade to Office 2010, Office 2000 stopped reading TIF files.  Word 2010 reads TIF files just fine, so now the problem is with WMF files.  When you insert one into Word 2010, it doesn't resize the image so that the entire image fits on the screen, like so:

     

    After it inserts, you can't crop or resize the image at all so that the entire image is there, it thinks that the cropped version is the whole image. 

    We really don't want to go back to Office 2000 for them, and they apparently have nearly 7000 WMF files.  Long-term we do want them to stop using the WMF files, so I'm working on trying to find a decent conversion program (the photo editor for Office 2010 doesn't want to export the WMF files into a jpeg format, for instance...it worked once but usually just errors out), but I'm wondering if anyone can help us figure out why it doesn't insert correctly.  I've looked through the options in Word but haven't seen anything that should be causing the issue.

    I did try opening the wmf file in 2010's photo editor and then told it to send to Word, and it did do that, but that's kind of a bothersome step to have them do every time. 

    Thanks in advance!

    Tuesday, October 4, 2011 4:01 PM

All replies

  • Office 2010 definitely will import TIF and WMF files and I cannot duplicate the problem you are describing with WMF images that I have.

    A few things to check:

    1.       Document format, doc or docx?

    2.       Is Word setup to default to inserting images as InLine Shapes or Floating (wrapped text)? Word > Options > Advanced > Cut, Copy, Paste settings.

    3.       What is the Smart Copy Settings (same place in options as #2)? Is it set for 2002 – 2010?

    4.       Try inserting one of the images into a Table Cell … does it resize appropriately?


    Kind Regards, Rich ... http://greatcirclelearning.com
    Wednesday, October 5, 2011 1:27 AM
  • Hi Rich,

    Thanks for your reply!

    I messed with some of the settings, but they seemed to have no effect.  It is strange that you can't replicate the issue with a wmf file there...I wonder if it's the wmf file itself but I believe it occurs with other wmf files that he has as well, and I guess I'm not sure, but I'd be surprised if there was that much of a difference between the wmf files you're using and the ones he's using..  What I checked:

    1. document format is docx, I did try doc, same effect.

    2. Looks like it's set up to insert images as inline with text.  I did try a few other settings there, same thing.

    3. Smart copy settings is set for 2002-2010, but I tried it as 97-2000, same thing.

    4. I tried inserting as a table cell, same thing, unfortunately. 

    I also tried copying the image in the photo editor (where it actually shows the whole image) and pasting into word, same issue.  I also just tried inserting it into excel to see if it did the same thing, and it does.

    Thanks again!

    Wednesday, October 5, 2011 2:17 PM
  • Hello,

    I had the same problem :
    When inserting a WMF image into Word, it is cropped.

    This was due to a change of resolution (I work with multiple screens).
    I set all my screens to the same resolution and restarted my computer.
    The WMF insertion function again correctly.

    Regards,
    Friday, December 1, 2017 11:13 AM