locked
Alert for Security Groups not working RRS feed

  • Question

  • Hi,

    I am trying to set up an alert on SharePoint to go out to everybody in an AD Security Group. I encountered the problem that the initial "Alert Created" email went out to everybody, but after that the actual alerts don't get sent. Googling this problem has taken me to a lot of sites with a similar problem, but unfortunately I haven't found a solution that works for me.

    It seems one of the key points is that the Security Group needs to be added to a SharePoint Group that has got access permissions to the list I am trying to alert on. I have done that. I have added the AD Group to a SharePoint Group that has got read, view and contribute permissions to the list. But still no success.

    I have added an individual alert for myself and that comes through just fine. But the alert to the Security Group just isn't being sent.

    Am I missing something else?

    • Moved by Mike Walsh FIN Tuesday, June 8, 2010 7:13 AM not customization (From:SharePoint - Design and Customization (pre-SharePoint 2010))
    Tuesday, June 8, 2010 1:52 AM

All replies

  • Hi,

     

    Firstly, go to site actions > site settings >modify all site settings > site administration > user alerts and check if your alert is there for your security group and, also, check you have set alerts in list level or item level.

     

    Secondly, here is an article to introduce troubleshooting alerts:

    http://blogs.msdn.com/b/vedvyas/archive/2009/09/02/troubleshooting-moss-alerts.aspx

     

    Hope it is helpful!


    Seven
    Thursday, June 10, 2010 8:16 AM
  • Seven,

    thanks for the links. Unfortunately I couldn't fix the problem with the information on those sites. The alerts in general work, and the email is set up correctly. If I register an individual to the alert it works without problems. However, as soon as I add a security group to the alert, the emails are not sent.

    That is, the initial email is sent, but any actual change alert is not. So far most authors suggest that this is a spermission error, but I have added the security group to the general viewers group and it should now have full access to the list I am running the alert on. I even tried giving the security group contribute access and still the alerts are not being sent.

    Thursday, June 10, 2010 10:36 PM
  • Hi,

     

    First of all, run IISRESET and then try again.

     

    Secondly, go to central administration > operation > timer job definitions > “web application” view > select your web application in the menu bar to check if Immediate alerts working fine. If not, please run the following operations:

    stsadm -o setproperty -propertyname alerts-enabled -propertyvalue false -url http://...

     

    stsadm -o setproperty -propertyname alerts-enabled -propertyvalue true -url http://...

     

    stsadm -o setproperty -propertyname job-immediate-alerts -propertyvalue "every 5 minutes"  -url http://...

    And then try again.

     

    At last, if the issue is still there, please check your email server settings in terms of the following articles:

    http://www.sharepoint-tips.com/2007/10/email-alerts-not-getting-sent-while.html

    http://social.technet.microsoft.com/Forums/en-US/sharepointworkflow/thread/36c3b5b5-af03-4f8a-b202-b62db330c21c/

     

    Hope it is helpful!


    Seven
    • Marked as answer by Seven M Friday, June 18, 2010 8:09 AM
    • Unmarked as answer by andreasbbbbb Tuesday, June 22, 2010 12:26 AM
    Friday, June 11, 2010 2:58 AM
  • Unfortunately this didn't fix the problem, either. The Job Status seems to run fine. No problems there (at least according to SharePoint it all succeeds).

    And the sending of emails to groups actually works, as the group received the initial notification that the alert has been set up. It is just the actual alert notifications that don't get sent.

    Tuesday, June 22, 2010 12:26 AM
  • I am having this same issue. 

    Did anyone find a resolution?

    Wednesday, October 20, 2010 7:38 PM
  • I used the alert  pipeline to rout my alerts. it seemed to work when i could not get alerts to work for a client.

     

    http://sptoolbox.codeplex.com/releases/view/8255

     

    Nagesh

    • Proposed as answer by Nagesh T Friday, October 29, 2010 3:03 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, November 2, 2010 5:11 PM
    Wednesday, October 20, 2010 7:53 PM
  • It appears that SharePoint sends the email to the Security Groups Anonymously.  There is a property on the security group called RequiresSenderAuthenticationEnabled that can be set to false from within Exchange that will resolve the issue.  It may take a few minutes for the alerts to send and receive after the change has been made.
    Dennis Bottjer | Follow Me: @dbottjer | Blog: Dennis Bottjer.com
    Wednesday, August 24, 2011 3:36 PM
  • You are subscribing for an alert on a document library. Here you configure the alerts to be sent to a e-mail enabled security group. You find that they do not receive alerts.

    can you check if you individually copy and paste all the users in the security group - are they able to receive the alerts ?

    Is there any recipient limitation for the sharepoint service account on the Exchange server ?

    Please check it.

    Thanks,

    Raj

     

    Wednesday, August 24, 2011 8:38 PM