locked
SharePoint 2007 - Information Management Policy Page will not open RRS feed

  • Question

  • When trying to create an new policy (under any content type/ list / library) I get the generic SharePoint error page.  Is it possible to reload the Information Management Policy feature?

    Looking through the logs this is the only error I could find:

    The file '/_layouts/RatingPolicyConfiguration.ascx' does not exist. at System.Web.UI.Util.CheckVirtualFileExists(VirtualPath virtualPath)
    at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
    at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
    at System.Web.UI.TemplateControl.LoadControl(VirtualPath virtualPath)
    at Microsoft.Office.RecordsManagement.InformationPolicy.ApplicationPages.PolicyConfig.OnInit(EventArgs e)
    at System.Web.UI.Control.InitRecursive(Control namingContainer)
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Wednesday, April 20, 2011 11:51 PM

Answers

  • Hi,

    Thanks to share your post.

    For the issue, as my point of view, what happens with your config is that you did activate the rating language files features (web app features) for the wrong web application. Make sure to choose the right one (the one that contains your site collection) via the application picker and then try again to activate the site collection feature.

    Hope this could help you!

    Leo

    • Marked as answer by Emir Liu Thursday, May 5, 2011 10:09 AM
    Thursday, April 28, 2011 9:29 AM

All replies

  • I have also found the following in logs:

     

    04/20/2011 20:11:17.43 w3wp.exe (0x1C7C)                       0x1060  Windows SharePoint Services   General                                75fe                High       Failed to determine definition for Feature with ID '593ee132-558f-4bf9-82b9-f862fbd28e79'.  Skipping this feature for element querying consideration.     

    04/20/2011 20:11:22.79 w3wp.exe (0x1C7C)                       0x1060                                  1388                                       8e2x      High                    Failed to find the content type schema for ct-1033-0x0100bc41bf680ef9457ebc4c556fb9bfd436 while caching feature data.    

    04/20/2011 20:11:22.79 w3wp.exe (0x1C7C)                       0x1060  Windows SharePoint Services   General                                8e2s                Medium               Unknown SPRequest error occurred. More information: 0x8000ffff        

    04/20/2011 20:11:22.79 w3wp.exe (0x1C7C)                       0x1060  Windows SharePoint Services   General                                7fad                Medium               Unable to locate the xml-definition for CType with SPContentTypeId '0x0100BC41BF680EF9457EBC4C556FB9BFD436', exception: Microsoft.SharePoint.SPException: Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED)) ---> System.Runtime.InteropServices.COMException (0x8000FFFF): Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))     at Microsoft.SharePoint.Library.SPRequestInternalClass.GetGlobalContentTypeXml(String bstrUrl, Int32 type, UInt32 lcid, Object varIdBytes)     at Microsoft.SharePoint.Library.SPRequest.GetGlobalContentTypeXml(String bstrUrl, Int32 type, UInt32 lcid, Object varIdBytes)     --- End of inner exception stack trace ---     at Microsoft.SharePoint.Library.SPRequest.GetGlobalContentTypeXml(String bstrUrl, Int32 type, UInt32 lcid, Object...      

    04/20/2011 20:11:22.79*               w3wp.exe (0x1C7C)                        0x1060  Windows SharePoint Services   General                                       7fad       Medium               ... varIdBytes)     at Microsoft.SharePoint.SPContentTypeCollection.FillCollection(SPRequest req, SqlDataReader rdr, Boolean openWeb)       

    04/20/2011 20:11:22.80 w3wp.exe (0x1C7C)                       0x1060                                  1388                                       8e2x      High                    Failed to find the content type schema for ct-1033-0x0101001b940dab6ad6487085fd25ba3a462a9f while caching feature data.    

    04/20/2011 20:11:22.80 w3wp.exe (0x1C7C)                       0x1060  Windows SharePoint Services   General                                8e2s                Medium               Unknown SPRequest error occurred. More information: 0x8000ffff        

    Boolean openWeb)


    Jaime Shomock
    Thursday, April 21, 2011 12:18 AM
  • Hi,

    Thanks to share your post.

    For the issue, as my point of view, what happens with your config is that you did activate the rating language files features (web app features) for the wrong web application. Make sure to choose the right one (the one that contains your site collection) via the application picker and then try again to activate the site collection feature.

    Hope this could help you!

    Leo

    • Marked as answer by Emir Liu Thursday, May 5, 2011 10:09 AM
    Thursday, April 28, 2011 9:29 AM