locked
Flash cards not accepted via card reader - asks 'insert disk' RRS feed

  • Question

  • Help!

    I think service pack 3 is preventing me uploading digital images via a card reader. I used to be able to upload digital images on 2GB Transcend cards using a USB card reader.The only change that I've made to my software environment that I know of is installing service pack 3. Now whenever I try to upload a digital image taken on a Cannon Power Shot A630 using either of two USB card readers that I have on any of my three Dell Dimension computers and an IBM Think Pad (they run either Windows XP home or professional) I get the following message: 'Please insert a disk".

    I've tried all of the following combinations, but nothing works:

    1) three different Dell Dimension computers - 4600, 8200 and 8400 as a well as an IBM Thinkpad

    2) two 2GB Transcend flash cards that I've previously used plus a new unused 2GB flash card I bought from Rite Aid

    3) two different USB card readers one of which was a new card reader I bought from Radio Shack

    4) I've tried connecting the USB cable after I've booted up and before I've booted up

    5) I've tried inserting the flash card after attaching the card reader and attaching the card reader with the flash card already inserted

    6) I've gone into disk management and tried changing the driver letter and checked if I can change the flash card formatting or partitioning. So far as I can tell, disk management doesn't give me these options for these 2GB flash cards

    7) I've taken one of these flash cards to Rite Aid and their picture printing department has been able to read at least one of my old flash cards. Rite aid  can copy all the images on this card to a CD if I want. So the card has not been corrupted as far as I can tell.

    8) I've contacted Transcend technical support, but all they could tell was that their cards do not need drivers or any other software to work. The only help they offered was to say that  if my Transcend flash cards are faulty - which I am certain they are not - Transcend will replace them.

    I can only conclude that their is some glitch in service pack 3 - a security problem perhaps - that is preventing Windows XP Home and Professional from reading my flash cards like they used to.

    I've search the web with Google looking for answers. I've found people who have posted similar problems on various technical sites. The most common answer is to play around with disk management, but so far as I can tell, disk management doesn't give me any options to change anything with the 2GB flash cards that I have.

    So if anyone has any suggestions or knows of any Microsoft patches that I can download I would be very grateful. I can't believe that thousands of other users of flash cards haven't run into this problem.

    My thanks in advance for your suggestions.

    I really don't want to going to Rite Aid every time I take a picture!

    Thanks again in advance.

    Saturday, June 25, 2011 2:35 PM

All replies

  • It is really hard to say why you are having the problem you describe above, but I seriously doubt it is Windows XP or SP3.

    I have used several card readers and all type of flash memory over the past several years with Windows XP, w/SP1, SP1a, SP2, & SP3 and have never encountered your problem.

    I hope you find a solution, but I don't know of anything to try.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Saturday, June 25, 2011 3:09 PM
  • Can you please clarify these questions:

    Does the computer recognise the flash-card usb device?

    Does Disk Managemet 'see' the flash-card as a disk? (if a flash card is inserted)

    What kind of flash cards are you using? (SD, MMC etc).

    When exactly do you get the error "Please insert a disk"?  Is it when you try to access the drive (in other words, Windows 'sees' it)?

    Saturday, June 25, 2011 3:10 PM
  • Yes all my computers recognize the devise and assign it a drive letter. For one flash card where I have four directories on the card, my computers views the directories as each being a separate drive and gives each drive a letter drive (e.g. f, g, h and i).

    Yes, disk management sees all my flash cards on all my computers along with the same drive letters that 'my computer' assigns to them. Disk management will also let me change the drive letter e.g. from f:\ to r:\

    The flash cards I am using are a) two Transcend 150x SD 2GB cards and a PNY Optima SD 2GB card x307.

    The card readers are a Converter Drive Digital Concepts XD Reader/Writer Model No. CD-45 and a Dane Elec Hi Speed USB SDHC. There is no model number on the latter reader.

    When I use "My computer" to try and read any of my three flash cards on any of my three computers with either of my two card readers, it views the card readers as removable disks as in, for example "Removable Disk (F:)"

    In disk management the card reader and card are read as "Disk 1 Removable (F:)" - if, for example, the card has been labelled "F" by the system. The card is read as having "No Media" on it.

    If I right click on properties, I find that the reader/card is described as (in the case of the Dane Elec reader and the Transcend SD card): "Generic USB CF Reader USB Device". The "Device Type" is: "Disk drives". The 'Location' property is "Location 0". The 'Device Status" is: "This device is working properly". The device is enabled.

    Under the 'Volumes' tab the 'Status' is 'No media". Under the Driver tab of Disk Management properties the driver is listed as: 5.1.2535.0. This is listed as being a Microsoft driver. The Digital signer is 'Microsoft Windows Publisher'.

    The driver files are "disk.sys" and "PartMgr.sys". They are located in the Windows system32 drivers folder. Perhaps I have the wrong drivers.

    The message I get when I try and read all of my three flash cards on all of my computers with either of my two card readers is a pop-up window saying in the banner: "Insert Disk" and in the message section: "Please insert a disk into Drive F:"

    I get the "Please insert a disk" message when I try to read the the card by clicking on it with the mouse.

    Previously, when I used the Dane Elec reader with a flash card already inserted in it, Windows would automatically read the card and open the pop up window that asks what you want to do with the card e.g. explore it, copy it, etc.

    I hope this answers your questions.

    Any solutions would be much appreciated.

    While it may not be Service Pack 3 that is the problem, I assume it must be a software issue, since I have tried use several different kinds of hardware in different combinations. Do you agree. I am running Zone Alarm and Malwarebytes. Could they be the cause of the problem? I personally doubt this. I have to assume it is something to do with Windows.

    Sunday, June 26, 2011 2:14 PM
  • I agree with Rick Dee that I don't think this is an SP3 problem.  I am not familiar with the latest versions of the Zone Alarm and Malwarebytes products you mention, but as a trouble-shooting measure, I would un-install them, or at least disable them (temporarily).  They could very well be implementing some sort of Intrusion Detection System, which may disable flash drives.
    Sunday, June 26, 2011 2:27 PM