Has anyone noticed a frozen clock on the taskbar? RRS feed

All replies

  • Hi there,

    This is a strange issue and I’m curious to know when and how the issue started.

    For any new appears issue, I think it’s worth to try System Restore.

    Meanwhile, have you setup auto sync up with Internet Time Server? If so, do you get a correct time when you click “Update now” in “Internet Time Settings” properties?

    One more question, did the time display on the taskbar always show the same time (17:41) all the time? Will the time change while you change the time zone to another one and change it back?

    Monday, January 25, 2010 7:57 AM
  • Hi.
    I really have no idea whatsoever about potential causes. First occurence is when I posted it.

    I thought it was worth a post given it is so odd that the task bar display can be "disconnected" from the bubble display/mouse over or the clock display upon clicking on the taskbar.
    A reboot did the trick but I'll keep a watchfull eye. Nothing else worked (changing time,time zone, etc) - the time was always correct, just not updated on the taskbar.

    Another odd UI issue I noticed is when closing an app occasionally leads to having the icon remain on the taskbar until a reboot (no, it's not pinned).

    Somehow, those are surely related (refresh issue).
    Tuesday, January 26, 2010 1:03 PM
  • Aha, both the original issue and the leaving icon on taskbar issues disappear after a reboot. I agree with you that they should be related.

    If those type of issues appears frequently, you can consider use Clean Boot (http://support.microsoft.com/kb/929135) to check if the issue was caused by background programs conflicts, if the issue disappeared in clean boot, you can try to narrow down the root cause of the issue via dichotomy.

    If it’s happens incidentally (e.g. appears every one or two weeks), you can safely ignore it. Life is not always perfect. :)

    Wednesday, January 27, 2010 12:58 AM
  • In case anyone is still having or had this problem, I have found a solution without restarting the computer. Open up your task manager, kill explore.exe and then re-open explorer.exe, the problem is then fixed!



    • Proposed as answer by Emeraldfire59 Wednesday, December 15, 2010 12:31 AM
    Thursday, June 17, 2010 8:15 PM
  • Hi, Brandon_S is right. I tried Ending Process on the Task Manager and then opening Explorer.exe and in went back to normal.

    I also had this problem a while a go!

    Thanks Brandon_S.

    • Proposed as answer by Emeraldfire59 Wednesday, December 15, 2010 12:31 AM
    Wednesday, December 15, 2010 12:30 AM
  • I have also been experiencing this problem. Restarting explorer.exe works, however this doesn't seem like a graceful solution. Any other suggestions on what might be casuing the taskbar to no longer update? The taskbar still functions but does not update with changes when opening programs or the clock changing among other things. Or if there is another thread / site that could give some insight into this problem that would be great. Thanks all for you help ahead of time.

    Wednesday, May 30, 2012 5:24 PM
  • I just fixed mine by unlocking the task bar and adjusting the size and it refreshed it.
    • Edited by bbrocker Friday, August 31, 2012 4:59 AM
    • Proposed as answer by theta_ Sunday, August 18, 2013 1:03 PM
    Friday, August 31, 2012 4:59 AM
  • I'm having all the same problems listed above (clock, icons, etc.). It started after I ungraded to Windows 8. Never saw that problem with 7. I appreciate bbrocker's remedy because it was driving me crazy. This morning the taskbar simply became unresponsive. When it finally cleared up I was prompted to send the issue to Microsoft. Hopefully it's related to the freezing and they'll address it in an update.
    Wednesday, October 31, 2012 2:33 PM
  • Same here on Windows 8 - not seen before on XP, Vista, or 7. Clock display update just stops at a randomly, while mouse-over or click doe show correct time local and for additional locations. 
    Tuesday, December 4, 2012 8:41 AM
  • it seems that it is the entire taskbar that is not updating, the clock seems to be stuck, but on my system, you can see the taskbar showing tasks that are no longer open still showing.

    restarting the explorer clears up the problem- but doesn't solve it

    I use process hacker in place of the system task manager- still have not come to any cause of the issue at this time.

    let me note I'm on Windows 8- just realized I saw no specifics to what OS this forum was covering- but that's what I'm using
    • Edited by CAMXposure Wednesday, December 19, 2012 12:08 PM correction
    Wednesday, December 19, 2012 12:03 PM
  • Same issue here. It's very random. Hasn't happened for me in a while but has just started recently doing it again.

    As said, its not just the clock, but the entire taskbar UI stops updating; the actual buttons still update but the changes to the ui don't.

    Saturday, February 16, 2013 5:23 PM
  • This is an issue I've seen since Windows 8 RTM. It persists to this day on fully patched Windows 8 installations. The taskbar will, after a period, refuse to refresh until you switch to the Windows 8 (Modern UI) Start page, at which time it will do a one-time refresh. During the freeze, system tray icons can become out of date (missing or mis-indexed), the taskbar clock will not update, etc.. 

    Restarting explorer will fix the issue for a time.

    Jeremy Collake

    Thursday, May 30, 2013 6:56 AM
  • Hey, has anybody figured this out.  This really sucks because I cant use my alarm clock program, please if anybody has a solution for this.  I think setting turn off display + sleep mode to never should fix this, will let everyone know shortly.  Going back to the metro screen and then back to the desktop fixes it as wel, but I want it to always show the right time for my alarm clock, what the hell is wrong with mocrosoft putting out a hacked product.


    turning off sleep and disabling display shut off does indeed work, clock stays the same.  This bug should be addressed in the future.

    • Edited by jaypluz Friday, June 21, 2013 8:55 PM update
    Thursday, June 20, 2013 11:49 PM
  • I've tried the fix here, but the time has displayed at 1:30PM for a few weeks now. The time in the app when I click on it is always correct, but not the display. I'd like to either fix it, or turn it off!
    Saturday, October 5, 2013 9:17 PM
  • This issue is still occurring for me (on multiple computers). Has anybody found a permanent solution? 

    The entire taskbar freezes (Clock, Applications, etc.). If I open the metro UI it will update, but only once (any changes after that are not seen). If I move the taskbar to another position and back it seems to fix the issue temporarily. No need to restart explorer for me.

    I was going to update to 8.1, since my computer keeps telling me to go to the store and do so, but 8.1 is not in the store for Volume License users!!! Why does Microsoft remove the 8.1 update from the store for VL users, but does not remove the constant reminders to go to the store and update? Anyway, does anybody know if this issue is present in 8.1 as well??

    Thursday, December 26, 2013 2:37 PM
  • it happens to me its obviously a windows 8 glitch
    Wednesday, January 15, 2014 7:14 AM