none
Project 2013 copy predecessors and successors to excel not correct when ID is with 4 digits RRS feed

  • Question

  • Hello, 

    I have found something that looks like a bug in MSP.

    When i copy cells from Project to excel i get all columns data correct, but if i have a task with multiple  predecessors and one of the predecessors ID is greater to 1000 (4 digits) it is coming out in correct in the excel.

    For example:

    • Pred IDs:     1234,231
    • In excel:      1,234,231
    • Pred IDs:     23,1234
    • In excel:      231,234
    • Pred IDs:     953,1051,805,955,473,1851,803,1922,1968
    • In excel:      9,531,051,805,955,470,000,000,000,000,000 

    Anyone is familiar with that issue?  can someone reproduce it and check if it is a bug?



    Ofir Marco , MCTS P.Z. Projects

    Tuesday, July 14, 2015 8:38 AM

Answers

All replies

  • No bug, Excel thinks that it is a number. Make the target cell text.
    Tuesday, July 14, 2015 10:46 AM
  • I have tried, i changed the sheet to be Text before the copy and then copied it.

    But still when i used regular paste it changed the cells to be number for that column.

    Only if i change the cells to be Text and paste using paste special - keep destination formatting, it works.

    I guess this is it?  no way to use regular paste without it changing the original format? 


    Ofir Marco , MCTS P.Z. Projects

    Wednesday, July 15, 2015 12:24 PM
  • Pls try this; select the whole Excel column by clicking the header and set its format to "Text". Ignore the error messages (smart tips) displayed after pasting information.

    Wednesday, July 15, 2015 1:27 PM
  • Thanks everyone.

    I resolved it by making the excel sheet as text, then pasting using the option "Match destination formatting".

    On other ways it is not works well all the time.


    Ofir Marco , MCTS P.Z. Projects

    Sunday, July 26, 2015 7:14 AM