none
Server 2016 guest on Hyper-V 2012 R2 slowness

    Question

  • We have a 2 node cluster hosting about 30 VM's running 2012 R2 and they are all running great. We have now deployed 3 VM's using 2016 and they all seem much slower to their 2012 R2 counterparts. Just opening control panel or other GUI's seem to take at least 4-5 times longer. Has anyone else seen this before or having any recommendations to tuning the host settings specifically for 2016 VM's to help them run smoother/quicker?
    Wednesday, April 26, 2017 4:48 PM

All replies

  • Thank you Tim. I will review the documentation and see where it goes.
    Friday, April 28, 2017 10:51 AM
  • Hi Sir,

    That server has more than one CPU ?

    That VM resides in CSV , right ? What is the connection between cluster nodes and storage , SMB or iSCSI or FC ?

    Also , please check the performance bottleneck inside 2016 VM (such as memory,disk ).

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Saturday, April 29, 2017 5:25 AM
    Moderator
  • The hosts have 2 proc w/12 cores and the 2016 VM's have 4 core each w/8 gig ram. The CSV's are on a NetApp FAS over Iscsi, multipath 1 gig. No performance issues I can find and we use both Veeam One as well as Solarwinds for monitoring and no performance issues are reported except during backups then disk read times go up but nothing significant. I am wondering if the VM Additions might be the cause. We just purchased 2016 for the hosts so will be migrating soon so maybe that will resolve it.
    Saturday, April 29, 2017 11:34 AM