locked
Cannot type with non-english letters in Word 2010 H&B. RRS feed

  • Question

  • Having problem with Word application in MS Office 2010 Home and Business.
    Non-english characters just wouldn't show up when typing (like latvian additional letters ā, ē, č, etc. same also happens when typing in russian with cyrillic letters). Not like they would be showing up with question marks instead of letters or with some other crazy symbols, but the effect like i wouldn't be typing anything at all. It happens only in Word. This issue didn't come up in any other office or 3rd party editing software. Only in Word under any user profile I log in to computer. OS: Windows 7 Pro OEM. Have tried anything me and my college could imagine including full system reinstall. After reinstall everything was back to normal, i could type with latvian and russian letteres with no problem. Seemed the problem was fixed, but next day user called me and told that the problem is back. User doesn't have any administrative rights on the computer, so nothing that could effect the computer globally on every profile couldn't be installed.

    Any ideas what else could i try to solve this problem? Maybe someone had something similar?

    10x 4ward!

    Thursday, February 14, 2013 1:47 PM

All replies

  • Is the correct language applied to text? In particular, make sure that the option to "Detect language automatically" is cleared in the Language dialog box (Review tab | Language | Set Proofing Language.
     
    In Windows, what are the settings for input language (keyboard layout)?

    Stefan Blom, Microsoft Word MVP
    Thursday, February 14, 2013 7:35 PM
  • I tried it with different latvian keyboard layouts and standard russian layout. All of them are working fine in other office applications and in notepad. With same fonts are configured.

    I'll check it out about "Detect language automatically". The user is not reachable now, i'll call her on Monday and will write you back if this was the issue or not. Thanks for ur advice!

    Friday, February 15, 2013 2:09 PM
  • Please do post back with the results of your testing next week.

    Stefan Blom, Microsoft Word MVP
    Friday, February 15, 2013 7:23 PM
  • "Detect language automatically" was really checked, but selecting it off didn't solve the problem. Still can type only standard English letters and not any of additional ones (like latvian ā, ū, ē, š, č etc) or using another alphabet (like cyrillic)
    Tuesday, February 19, 2013 12:28 PM
  • "Detect language automatically" was really checked, but selecting it off didn't solve the problem. Still can type only standard English letters and not any of additional ones (like latvian a, u, e, š, c etc) or using another alphabet (like cyrillic)

               
              
    After you turned off "Detect language automatically," did you verify that the correct language was applied to text? Note that the language may change at the insertion point (it's a character property).

    Stefan Blom, Microsoft Word MVP
    Tuesday, February 19, 2013 3:26 PM
  • Hi,

    Same problem here, after fresh install. Windows 8, Office Home and Business 2010. Latvian characters are showing OK in other applications (e.g. notepad), and also, after copy/paste shows up in Word. But does not show up after typing. Any new ideas? Trying Repair option currently.

    ----

    After Repair: didn't help. I checked other Office programs - in Excel and others Latvian letters works fine.

    Wednesday, February 27, 2013 9:05 AM
  • What else have you tried so far?
     
    Note, however, that there might be a particular issue with Latvian installations of Office...

    Stefan Blom, Microsoft Word MVP
    Wednesday, February 27, 2013 7:37 PM
  • -Removed  & fresh installed office - no luck

    -Office is installed in English language

    -Two other computers with same settings - works fine

    -However small progress - I added other language layout (Latvian -QWERTY) where special Latvian letters should be entered by holding right [alt gr] - with this, I can finally type latvian letters, however it is not very convinient.

    Thursday, February 28, 2013 5:28 AM
  • It seems as if the input language (keyboard layout) is part of the problem, then. Which keyboards and drivers are being used for those computers where things work?

    Stefan Blom, Microsoft Word MVP
    Saturday, March 2, 2013 12:05 AM
  • I use same layout for all 3 computers - it does not work only on this one, with seemingly same config. It is custom layout created in Latvia. if it helps, here are the download link: http://laacz.lv/f/misc/apos/apostrofs-punkts.zip
    Sunday, March 3, 2013 6:50 AM
  • I had the same problem.

    The problem is an other program call pdf something ...   you must uninstall it .

    that's the solution of this problem .

    Friday, March 8, 2013 9:41 AM
  • Sounds like you are referring to an add-in. See http://support.microsoft.com/kb/921541/en-us/ (How to troubleshoot problems that occur when you start or use Word).

    Stefan Blom, Microsoft Word MVP
    Friday, March 8, 2013 7:19 PM
  • Many thanks for the advice. I had a similar issue with switching to bulgarian and this solved the problem. The program is called PDF Complete.
    Thursday, June 20, 2013 6:46 AM
  • I had same issue. After uninstall PDF Complete, problem is gone. Thank's
    Monday, July 22, 2013 10:59 AM
  • Thank you a lot - same issue that was resolved by uninstalling PDF Complete

    Sunday, September 1, 2013 12:24 PM
  • Thanks alot I uninstall PDF Complete and my problem gone :)))))

    Monday, September 30, 2013 6:53 PM
  • Just want to add more details to the community knowledge. Buggy PDF Complete 4.1.9 Corp was unintentionally installed with HP OS OEM Win7 installation media. Word 2013 had the same problem with plugin. Current PDF Comlete Demo (4.1.045) has no problems with this.
    • Edited by Andrew Smirnov Friday, January 20, 2017 11:44 AM added test results
    Friday, January 20, 2017 11:38 AM