locked
CLR errors again and again. RRS feed

  • Question

  • Hi. I have done all needed to uninstall .NET 4. This was completed successfully (registry, new assembly folder, etc..). I reinstalled .NET 4 and that was a complete success also. I immediately went to install an updated version of Handbrake (the reason I re-installed .NET 4 to begin with among other .NET 4 update issues.

    Handbrake installed fine and now ran without the CLR error. As soon as Microsoft did it's 'WIndows Update' (security and other related .NET 4 only items) and I went to run Handbrake again it would run no more, the CLR error was back. I also tried installing an updated Bullzip PDF Printer which I've used for years and it ran into a CLR errors as installing resulting in a bad install having to be removed.

    I've cleaned .NET 4 more times then I care to remember and each time these (and likely others) run perfectly. As soon as the updates go in every one that depends on .NET 4 comes back with a CLR error. The CLR number is always the same. I can't (shouldn't) stop Microsoft from installing security updates for .NET 4, but something that enters my system after the basic install of .NET 4 is wreaking havoc.

    The first 3 times I ran Combofix. On a 1TB main drive that takes awhile clean or not. And SAS runs all the time. At the moment the files couldn't be cleaner.

    Will this CLR problem ever end? I know I'm not alone, yet no end user should have to go through this. Fortunate for me I have a bit of experience. But this is one glitch that's overwhelming and I am stumped. 

    Keith

    Wednesday, March 7, 2012 6:59 PM

All replies

  • I realize you have Windows 7 on your computer, but when you have problems with third party software the VERY FIRST place to go for help is TO THE SOURCE of the third party software.  Microsoft is not going to modify Windows to accommodate third party software.  It is the sole responsibility of the software publisher to ensure their software is written properly to run as desired on Windows!

    You probably did more damage to your system by trying to uninstall and re-install .NET 4.  You may have to do a complete wipe of your hard drive and do a fresh, clean install of Windows 7 to correct all the problems that seem to have been injected by your actions.

    If you had to run Combofix because of malware, then there is absolutely no way of knowing what damage was done to your system!  Another very good reason to wipe your hard drive clean and do a fresh. clean install!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Wednesday, March 7, 2012 8:00 PM
  • Actually I'd agree with you, but the system (registry to) is as close to clean as will ever be possible. Again I'd agree but this started way back when .NET 4 first released. I first became aware of this error then.

    Other then this issue, I have never experienced a glitch of any type. My system hops as if it was just installed. One thing is certain, I didn't do any damage during the uninstalls and cleaning. I know my registry, I even took a picture of it pristine. I compared when I noticed the issue. Looking only at areas even remotely related to .NET. You might say a waste of time but they were pretty much identical.

    I hope your wrong as I've been there, done that. It was the easy way out... Now I just was hoping to find some solution a bit deeper, but a solution none the less. A do-over (fresh - clean) didn't work the first time when I put new sata-3 drives in.

    I only mentioned the 2 apps. All is fine till the binaries for .Net4 get updated. Someone who has higher programming skills than I have or could imagine said to turn off updates and install whats proven not to cause issue. I think Windows 7 is solid. The only time I've been forced to look at the multiple choice start up screen is when I booted the computer after a power outage.

    This might seem a rare case, it's not. I've done what you suggest already. It's time to nail the problem. It's what I do, just not this time.

    I really do appreciate the feedback though regardless. Thanks.

    ===============

    Update:

    I downloaded four more small fw apps that rely on .Net 4 just to be certain. Apps aren't the issue.

    I can't leave issues alone. Went and cleaned out .Net 4 along with all it's updates security or otherwise. Installed .Net 4 -again- but decided to stretch what happens after (updates) out a bit just like programming, line by line.

    At the same time WU immediately wants to update the .Net 4 install. At this time there are 4 security and 2 performance / fix updates. I let it install 1 security update. No issues. 3 more security to go.

    This is ongoing. I'm guessing it's either one of the updates, or, the order they are getting installed.

    I'd feel outcast if I didn't know this same thing happened to others.


    hkb



    • Edited by kickmekeith Thursday, March 8, 2012 11:01 AM
    Thursday, March 8, 2012 12:38 AM
  • There are no two ways about it - your system has been damaged by malware and no matter what you do it will never function correctly until you wipe the HDD clean and do a fresh clean, clean install.

    How do you expect anyone to come up with an answer to your situation when absolutely no one know what happened to yoru system any more than you do.

    Be realistic - your system has been damage by malware!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Thursday, March 8, 2012 12:22 PM
  • Wait, I did a wipe already.  Am putting back the updates 1 at a time. I'm very familiar with malware. I know a couple (as of now) can slip by every anti virus or malware prevention software there is. The easiest probably a browser re-direct. The worse, transformers or a complete hijack & theft. Seen the worst of the worst.

    And there's no denying another .Net 4 update failed installation on many computers, that was a more than a year ago. The update vanished rather quickly. New ones came and all was right with the world.

    But I see your point. I've told people to do the same thing, wipe. When I checked their machines only one needed a wipe, all, happy ever after.

    One thing I don't know is how 'sfc' works, crc,  or an md5 database?. Does it actually check every Microsoft item that becomes even partially involved with the OS? If it doesn't it should.

    Just please wait till I finish putting in all back updates. I will let you know, for better or worse...  I've been wrong before, but so have you.


    hkb

    Thursday, March 8, 2012 4:46 PM
  • Installed all security updates and no CLR error yet. 2 updates to go, 3 with the optional. If the 2-2011 updates work fine (which they should), then it's with update kb2600217x64. An update Microsoft says is an Important update yet remains automatically unchecked, like a prior update that would never get checked automatically.That's the prior that suddenly was pulled.

    It's these 2 unchecked .Net 4 updates where these issues started for me each time. If I leave the latest, kb2600217 alone everything's fine. If I install it, it will roll back. And the whole CLR problem will start again as it did with the pulled update.

    Near 30 years of this and there's always something. But it so much better than the CPM era. Can we agree on that?


    hkb


    Friday, March 9, 2012 4:48 AM
  • I'm having the same problem. If I reinstall .Net 4 everything works fine, until Windows Update does all the .Net related updates.

    Edit: seems like one of the updates messed up the right of  some files in Windows/Microsoft.NET (perhaps the fact that I have UAC disabled has something to do with it?) Using "Take ownership" on the folder seems to have fixed it.

    • Edited by psxlover Sunday, July 1, 2012 5:59 PM
    Sunday, July 1, 2012 5:11 PM
  • This is what I do. I just don't install these net 4 updates anymore. I do install all net 4 security updates.

    2 Net Framework 4 updates are dated 9/13/2011 (kb2468871 & kb2533523) and the other 2/14/2012 (kb2600217). Even though 2 apparently address performance issues, I see & have no performance or delay issues & the one app that requires Net 4, sparkles.

    Seems some of the (newer) apps I've seen rely on Java and earlier versions of Net Framework. But to my displeasure one of my favorite apps wants Net 4. Otherwise it would lay dormant in my system and I'd turn off it's service(s).

    Your 'edit' Take Ownership on the folder, is something to explore. And I will if I ever have the issues that MS is fixing.


    hkb

    Sunday, July 1, 2012 6:52 PM