locked
Enable-UMMailbox : Unified Messaging can't validate or generate a UM PIN for mailbox max.muster..... : Failed to log on as network service. Error: 5. RRS feed

  • Question

  • When i try in powershell from another Server....its our Management Server to enable-ummailbox for any user i got the error message from title above. 

    When i try from powershell on the local exchange Server i got the same error. When i try from the Exchange Management Shell on th eexchange Server the command is working and it activates UMMailbox for the user.

    In the beginning of the script :

    Add-PSSnapin Microsoft.Exchange.Management.PowerShell.SnapIn
    Import-Module ActiveDirectory
    Import-Module Lync
    .'C:\Program Files\Microsoft\Exchange Server\V15\bin\RemoteExchange.ps1' 
     cd \ 
     Connect-ExchangeServer -auto 

    And then i try the command:

    Enable-UMMailbox "Max Muster" -UMMailboxPolicy "hereisourmailboxpolicy" -PinExpired $true -Extensions 6006 -SIPResourceIdentifier max.muster@ourdomain.com

    and become the error:

    Enable-UMMailbox : Unified Messaging can't validate or generate a UM PIN for mailbox max.muster..... : Failed to log on as network service. Error: 5. 

    I cannot find something via Google related to this error.

    Why is the command working in the exchange Management shell, but not in powershell or in a script via powershell?

    I Hope somebody can help


    • Edited by Moli87 Friday, August 5, 2016 8:50 AM
    Wednesday, August 3, 2016 10:57 AM

All replies

  • Does nobody know something about that error or can give me hint?
    Tuesday, August 9, 2016 10:22 AM
  • I figured it out here:

    I was wondering why it is working in exchange management shell but not in the script. I changed this 3 Lines in my script:

    .'C:\Program Files\Microsoft\Exchange Server\V15\bin\RemoteExchange.ps1'

    cd\

    Connect-ExchangeServer -auto 

    to:

    .'C:\Program Files\Microsoft\Exchange Server\V15\bin\RemoteExchange.ps1'; Connect-ExchangeServer -auto

    Now it is working, it activates the UMMailbox via powershell script. Everything else is also working in the script.


    • Edited by Moli87 Friday, August 12, 2016 8:13 AM
    Friday, August 12, 2016 8:12 AM
  • how did you fix it?
    Wednesday, September 6, 2017 6:50 PM
  • .'C:\Program Files\Microsoft\Exchange Server\V15\bin\RemoteExchange.ps1'; Connect-ExchangeServer -auto

    Same for me. Thank you.

    Tuesday, July 3, 2018 2:21 PM