locked
Skype for Bussiness autodiscovery RRS feed

  • Question

  • hello

    I have Skype for bussiness server and I'm trying to make autodiscovery for external clients.

    1) created A record in external DNS, lyncdiscover that's points to my public IP address

    2) 2 SRV records: 1) service: _sipfederationtls, protocol: _tcp, target: lyncdiscover.mydomain.com, priority: 100, weight 1, port 5061;  2) service: _sip, protocol: _tls, target: lyncdiscover.mydomain.com, priority: 100, weight: 1, port 443;

    ports 443 and 5061 is forwarded to my internal SfB server, when I set external server address lyncdiscover.mydomain.com works fine, but on autoconfiguration mode I cannotsign in, what I missed?


    Shota Tadumadze

    Wednesday, November 23, 2016 9:20 AM

Answers

  • Hi Shototadumadze,

    The lyncdiscover.domain.com record should point to your public ip address for your reverse proxy server.

    Both the SRV records are looking to be pointing to the wrong target FQDN.

    The SRV records should point to your access edge FQDN of your edge server not lyncdiscover.domain.com.

    Have you opened the required firewall ports for the reverse proxy and edge server. Theres a great firewall diagram from Randy Chapman http://lynciverse.blogspot.co.uk/2015/05/skype-for-business-server-2015-firewall.html

    If you need anything else just let us know.

    Thanks,

    Martin



    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". Thank you. This forum post is based upon my personal experience and does not reflect the opinion or view of my employer.

    • Marked as answer by shototadumadze Tuesday, November 29, 2016 12:09 PM
    Wednesday, November 23, 2016 9:41 AM
  • Deleted
    • Proposed as answer by Liinus Wednesday, November 23, 2016 11:02 AM
    • Marked as answer by shototadumadze Tuesday, November 29, 2016 12:09 PM
    Wednesday, November 23, 2016 10:04 AM
  • Hi shototadumadze,

    Welcome to post in our forum.

    For this issue, I agree with Martin.

    As a supplement, you need to publish the Autodiscover Service on port 80 or on port 443.

    The following blog is about creating DNS records for the Autodiscover Service in Lync Server 2013 (It’s same to SFB server 2015)https://technet.microsoft.com/en-us/library/hh690010%28v=ocs.15%29.aspx?f=255&MSPPError=-2147217396

    Autodiscover service requirements for Lync Server 2013 (It’s same to SFB server 2015)https://technet.microsoft.com/en-us/library/hh690012(v=ocs.15).aspx

    Hope this reply helpful to you.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Alice-Wang Monday, November 28, 2016 9:40 AM
    • Marked as answer by shototadumadze Tuesday, November 29, 2016 12:09 PM
    Thursday, November 24, 2016 6:47 AM

All replies

  • Hi Shototadumadze,

    The lyncdiscover.domain.com record should point to your public ip address for your reverse proxy server.

    Both the SRV records are looking to be pointing to the wrong target FQDN.

    The SRV records should point to your access edge FQDN of your edge server not lyncdiscover.domain.com.

    Have you opened the required firewall ports for the reverse proxy and edge server. Theres a great firewall diagram from Randy Chapman http://lynciverse.blogspot.co.uk/2015/05/skype-for-business-server-2015-firewall.html

    If you need anything else just let us know.

    Thanks,

    Martin



    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". Thank you. This forum post is based upon my personal experience and does not reflect the opinion or view of my employer.

    • Marked as answer by shototadumadze Tuesday, November 29, 2016 12:09 PM
    Wednesday, November 23, 2016 9:41 AM
  • Deleted
    • Proposed as answer by Liinus Wednesday, November 23, 2016 11:02 AM
    • Marked as answer by shototadumadze Tuesday, November 29, 2016 12:09 PM
    Wednesday, November 23, 2016 10:04 AM
  • Hi shototadumadze,

    Welcome to post in our forum.

    For this issue, I agree with Martin.

    As a supplement, you need to publish the Autodiscover Service on port 80 or on port 443.

    The following blog is about creating DNS records for the Autodiscover Service in Lync Server 2013 (It’s same to SFB server 2015)https://technet.microsoft.com/en-us/library/hh690010%28v=ocs.15%29.aspx?f=255&MSPPError=-2147217396

    Autodiscover service requirements for Lync Server 2013 (It’s same to SFB server 2015)https://technet.microsoft.com/en-us/library/hh690012(v=ocs.15).aspx

    Hope this reply helpful to you.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Alice-Wang Monday, November 28, 2016 9:40 AM
    • Marked as answer by shototadumadze Tuesday, November 29, 2016 12:09 PM
    Thursday, November 24, 2016 6:47 AM