none
Email and WF

    Question

  • Hi 

    have a list that allows incoming Emails and the setting: "Save all attachments in folders grouped by e-mail sender"

    - and then have a WF with these start settings:

       

    however the WF doesn't start when a email is received ?

    I've tried to Re-publish - remove the Start automatically etc. etc. 

    How do I ensure this automatic start ?


    • Edited by JmATK Monday, April 10, 2017 9:13 AM
    Monday, April 10, 2017 8:47 AM

Answers

  • Hi JmATK,

    The email processing is running in the context of "System Account". SharePoint declarative workflows will not automatically start on items that are created or modified by the system account.

    Please try to enable the “Workflow can use app permissions” feature. Information about the steps to enable workflow app permissions.

    Here is a similar issue for your reference:

    http://www.sharepointmaestra.com/Lists/Posts/Post.aspx?ID=1

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by JmATK Tuesday, April 11, 2017 9:53 AM
    Tuesday, April 11, 2017 8:25 AM
    Moderator

All replies

  • What happens if you drag and drop an item into the list? Does that work?

    Can you trigger the Workflow manually on emails that were added but failed to start?

    I'd be looking at permissions and user accounts, who is the workflow running as and do they have the permission to start the workflow. Also is the item being created in a state suitable for the workflow to run? Is it checked in etc.


    Monday, April 10, 2017 8:51 AM
  • Hi Alex 

    If i drop a file it starts - so its the "folder" that's the issue?   or is it a System account problem? 

    yes I can trigger it manually :) 

    there's no impersonation steps - so thinking its the system account that it runs under? 

    Should I run this?

    stsadm.exe –o setproperty –propertyname declarativeworkflowautostartonemailenabled –propertyvalue yes



    • Edited by JmATK Tuesday, April 11, 2017 6:14 AM
    Monday, April 10, 2017 9:18 AM
  • Hi JmATK,

    The email processing is running in the context of "System Account". SharePoint declarative workflows will not automatically start on items that are created or modified by the system account.

    Please try to enable the “Workflow can use app permissions” feature. Information about the steps to enable workflow app permissions.

    Here is a similar issue for your reference:

    http://www.sharepointmaestra.com/Lists/Posts/Post.aspx?ID=1

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by JmATK Tuesday, April 11, 2017 9:53 AM
    Tuesday, April 11, 2017 8:25 AM
    Moderator
  • Hi Linda

    thanks

    but getting this when I try to activate that feature 

    An unexpected error has occurred. Technical Details Troubleshoot issues with Microsoft SharePoint Foundation. Correlation ID: e5e7e69d-92cf-6046-f824-0d4830e1fad6

    ULS : Can't find WorkflowServiceProxy or its service application proxy type name is null.... 

    There's no workflow 2013 installed and its a SPD 2010 WF

    If I do the:  stsadm -o setproperty -pn declarativeworkflowautostartonemailenabled -pv true 

    An update conflict has occurred, and you must re-try this action. The object SPWebService was updated by sp13_Farm, in the OWSTIMER (5484) process, on machine xxxx

    (update - Stsadm:  operation completed success :)... )   







    • Edited by JmATK Tuesday, April 11, 2017 9:53 AM
    Tuesday, April 11, 2017 9:24 AM