Access to On-Prem Data Source Forbidden


  • In Power BI preview site...

    Successfully downloaded the gateway and created a connection to an on-prem SQL database.  Data source in Power BI admin says "ready".  I can see tables and views.  Works fine.

    I click on the data source in power BI and cut/paste the ODATA URL.  I open Excel 2013, Open Power Query, Select "From Odata..", Paste the ODATA URL. 

    I get the following error: "Access to the resource is forbidden".  I've tried all the possible authentication options in Power Query (basic, anon, using my PowerBI preview account, using the account I used for the data source, etc.) All return the same error.


    Friday, September 27, 2013 7:07 AM


All replies

  • Hi Eric,

    When creating the data source in the Power BI Admin center, did you check the Enable OData Feed checkbox?


    Friday, September 27, 2013 11:34 AM
  • Yes, checked both Cloud & ODATA.
    Friday, September 27, 2013 1:36 PM
  • I too am having this problem, I created the gateway (ensured that it is registered and has started) and the data source (ensured that OData feed is enabled and status is ready) through the Power BI admin interface.

    I have tried both Excel 2013 and Excel 2010, but I get the same "Access to the resource is forbidden." error message. The account I am using to authenticate is the same I use to sign into the Power BI dashboard.

    Friday, September 27, 2013 7:07 PM
  • Right, I've tried my trial-ID for PowerBI & the windows-auth account that works w/ the data source.  

    I've even tried to log into Excel Desktop before i start Power Query with my PowerBI Trial ID thinking that Excel is passing credentials.

    No joy.

    Friday, September 27, 2013 7:42 PM
  • Would you please try to use "Microsoft Online Service ID", and then click "sign in", logging in with your xxx@xxx.onmicrosoft.com" account?

    Saturday, September 28, 2013 12:33 PM
  • I have same problem !!
    Sunday, September 29, 2013 4:14 PM
  • Tried.  Tried the data sources ID as well. 
    Monday, September 30, 2013 12:55 AM
  • When creating data source on IT Admin Portal, in step 3 "Users & Groups", you're asked to set ACL. Only people added here can access the OData.

    Would you please make sure the you're using that account to log in after selecting "Micorosoft Online Service ID"?

    Monday, September 30, 2013 4:52 AM
  • BTW, in step 1 of creating data source, there's a check box "Enable OData Feed". By default it's not checked. Would you please make sure you checked this box if you'd like to access it in PowerQuery?
    Monday, September 30, 2013 4:56 AM
  • Hello.

    Thanks for answers.

    I had check Enable OData Feed , and set my account to users and groups, and gateway work and is enabled.

    I used same Microsoft Online Service ID to Excel 2013 that set to users and groups for data source that created.

    Monday, September 30, 2013 7:00 AM
  • Then do you already assigned license to your account on O365 admin center?

    If you didn't do this, you need to go to O365 admin center, select "Users & Groups", then click on your account, you will be able to see a page with the following content. Please make sure the boxes are checked.

    Assign licenses
    <input checked="checked" id="sku0" name="sku0" title="Microsoft Power BI for Office 365" type="checkbox" /> <label boxtype="Label" class="BOX-MainTertiary LicenseProduct" for="sku0">Microsoft Power BI for Office 365</label> 23 of 25 licenses available
    <input checked="checked" id="sku0_Service0" name="sku0_Service0" title="Microsoft Power BI Information Services Plan 1" type="checkbox" /> <label boxtype="Label" class="BOX-MainBodyText" for="sku0_Service0">Microsoft Power BI Information Services Plan 1</label>
    <input checked="checked" id="sku0_Service1" name="sku0_Service1" title="Microsoft Power BI Reporting and Analytics Plan 1" type="checkbox" /> <label boxtype="Label" class="BOX-MainBodyText" for="sku0_Service1">Microsoft Power BI Reporting and Analytics Plan 1</label>
    <input checked="checked" id="sku0_Service2" name="sku0_Service2" title="SharePoint Online (Plan 2)" type="checkbox" /> <label boxtype="Label" class="BOX-MainBodyText" for="sku0_Service2">SharePoint Online (Plan 2)</label>

    Monday, September 30, 2013 8:35 AM
  • Monday, September 30, 2013 8:38 AM
  • I had already do that !!!!

    May be problem is that on Power Query ribbon in Excel 2013 when press Sign-In option return an error that page don't exist.

    But i had sign in Excel 2013 with Microsoft Online Service ID that use in Office 365

    Monday, September 30, 2013 8:46 AM
  • Log in Excel successfully doesn't mean you could consume the OData directly, you need to log in again. I think your failure is because you didn't Sign-in successfully.

    Would you mind to share your tenant name, i.e. xxx.onmicrosoft.com?

    Monday, September 30, 2013 10:26 AM
  • Thanks for your answer


    Monday, September 30, 2013 1:28 PM
  • So that's the problem...

    I try to another machine with Excel 2013 and button Sign-In is enabled and after sign-in all looks that work...

    This machine is windows 7

    So problem why to other machine, windows 8, with Excel 2013 , same version, same Microsoft Online Service ID , Sign-In is not enabled , and when i put it in a new menu group goes enable but when click that returns that not found page ?????

    Monday, September 30, 2013 2:11 PM
  • Everything is ok , i see my data , thanks a lot for your help.

    The problem was version of Power Query install on machine that i had the problem.

    Monday, September 30, 2013 5:02 PM
  • One other catch for the benefit of those reading this thread. When signing in, you need to use an all lowercase version of your sign in name. There's a bug (or at least there was) that gave this error if you had any caps in your sign in name.


    Tuesday, October 01, 2013 12:58 AM
  • Which version of Power Query was causing the problem? I tried the version that comes with Office365 and  I have tried updating to the latest version of Power Query. Neither option solved my problem.
    Tuesday, October 01, 2013 8:55 PM
  • Hi Kevin

    Have a look at this... there are two versions of Power Query out there right now. One is "released" and one is for the Power BI preview



    Wednesday, October 02, 2013 1:37 PM
  • Version: 2.7.3416.121
    Wednesday, October 02, 2013 2:14 PM
  • This did not solve the issue for me.  Issue exactly as described, but I have Power Query for BI Preview installed ((2.9.3xxx). I tried all the log-in options -- the organizational account doesn't work, example below



    Friday, January 03, 2014 5:04 PM
  • I had a similar issue until I changed the account I was actually signed into Excel as (upper right corner of Excel).  When I changed that to the same account that had been granted access to the feed, I could get to the data.


    Saturday, February 01, 2014 8:46 PM