none
Error when trying to read TimesheetLines data from OData feed to Excel RRS feed

  • Question

  • Hi,

    Ihave the following case:

    Resources have filled and submitted timesheets in PWA for a period. The timesheets have been approved. I would like to read this data, the TimesheetLines, into Excel for reporting. I have followed the steps to access the OData feed outlined here

    http://www.prasannaadavi.com/2014/06/timesheet-status-report-with-odata-in.html

    and here

    https://pmarinescu.wordpress.com/2015/03/13/timesheet-reporting-using-multiple-tables-in-odata/

    However, when trying to import the data, before defining the relationships between the tables, I get an error message:

    "We couldn't get data from the Data Model. Here's the error message we got:

    Either the dimension with the ID of 'ID1' does not exist in the database with the ID of 'ID2', or the user does not have permission to access the object."

    Has anyone ran into this and solved the problem? The error message is quite clear but I still don't know where to look for a solution/fix.

    Would much appriciate help with this.

    ---

    Maybe useful to add that this problem occurs only with Office 2016 products. In Office 2013 (e.g. Excel 2013) all works fine. Product development, I guess :P

    • Edited by MartinAalto Thursday, February 4, 2016 11:54 AM
    Friday, January 15, 2016 12:40 PM

All replies

  • Hi MartinAalto,

    Do you have access to Odata feed? Could you confirm by typing in the link of your project online tenant in browser as per below format?

    https://<YourProjectOnlineTenantAddress>/_api/ProjectData/Timesheets

    The Odata feed is permission controlled to access this API the user will need 'Access Project Server Reporting Service' - this should be granted via a Project Server Security Group.


    Cheers, Badal Ratra MCTS




    • Edited by Badal Ratra Friday, January 15, 2016 10:50 PM
    Friday, January 15, 2016 10:49 PM
  • Hi,

    Thank you for your reply.

    I'm able to get the raw XML in the browser for Timesheets, but when trying to read the same OData-feed into e.g. Excel, I get the above-mentioned error.

    Wednesday, January 20, 2016 6:56 AM
  • Hi, 

    Are you using Excel 2016 ? If yes, there are 2 places you can connect to OData.

    1. Other sources / Odata
    2. New Query / From Other source / Odata 

    If you choose the first one, it won't work. You have to use the second one, which asks for credentials.

    Hope ite helps

    Hugues


    Hugues Perron

    Tuesday, March 1, 2016 1:05 AM
  • Have you tried opening Excel as an administrator?

    I am seeing some issues currently on Project Pro and Excel where the solution is to right click the application and select "run as administrator".

    Also I have seen somewhere that there can be an issue logging in when the windows references are wrong on the useraccounts of your windows machine. There is a great blog about this but I lost it, maybe some one can help you out with this.

    Kind regards,

    Erik

    Thursday, March 3, 2016 5:07 PM
  • Thanks, tried, but didn't work for me.
    Thursday, March 31, 2016 6:28 AM
  • Tried also as admin but no luck.

    Hope someone could link the blog you mentioned because that sound like a possible solution.

    Thursday, March 31, 2016 6:29 AM
  • You might also want to see my article on this topic for additional information and ideas. http://community.powerbi.com/t5/Community-Blog/Microsoft-Project-Online-Timesheet-Reporting-using-Power-BI/ba-p/9930

    Treb Gatte, Project MVP | Blog | Twitter | Academy

    Friday, April 1, 2016 7:22 PM
    Moderator
  • Thanks Hugues, that was exactly the problem.

    Any idea of why the first option do not work ? It does ask for credential.

    Francois

    Tuesday, August 9, 2016 4:03 PM