locked
remote desktop stopped working with Windows 7 Service Pack 1 RRS feed

  • Question

  • I routinely use remote desktop from a Win 7 pro laptop to a Win 7 Ultimate desktop machine, but this has recently stopped working (around the same time both machines updated to service pack 1). I can connect from the Win 7 Ultimate desktop to the Win 7 Pro laptop, but not in the reverse. Looking at the wireshark trace, they look more or less the same, except that the failing connection dialog stops after several exchanges. There isn't any error indication.

    One thing to note: the client complains about the certificates not being issued by a trusted authority, but I click ignore. All of this is on a gigabit LAN.

     

    Monday, January 2, 2012 9:28 PM

Answers

  • In addition to the previously mentioned updates, an update from 23/04/13 seems to have caused similar rdp/terminal issues.

    To resolve, I've had to uninstall the following three security updates (and remember to hide them once uninstalled):

    • KB2621440
    • KB2667402
    • KB2840149
    • Marked as answer by Niki Han Thursday, May 9, 2013 2:19 AM
    Wednesday, May 8, 2013 9:06 AM

All replies

  • I've recent experienced the same thing in the last month: I use multiple computers (Windows 7 Ultimate, OS X 10.7) to connect to my Windows 7 Pro SP1 desktop and now I cannot connect. On all machines, the RDC client asks for credentials, then prompts that the identity of the desktop cannot be verified, then nothing happens. No errors, just goes back to the "connect" screen of the RDC client.

    Event viewer on the machines (server/client) show no errors, but the server is showing Security Audit entries with the username & IP of remote computer.

    Windows firewall is configured to let the connection occur, and the network location is a 'Home' network. Very strange.
    Tuesday, January 3, 2012 10:57 PM
  • Remote Desktop gained the ability to remote the Aero UI in SP1 via RemoteFX, implying a fairly major rework, so it is likely  placing a completely different set of demands than its predecessor on the display drivers and graphics subsystem...

    You might try updating the display drivers on the remote or even both systems.  Go directly to the web site of the maker of the video card and download and install their latest release for your hardware and OS version.

    There are many articles online about RemoteFX.  Some of them might yield more information about what could be going wrong for you.

    Good luck!

     

    -Noel


    Detailed how-to in my new eBook: Configure The Windows 7 "To Work" Options

    Wednesday, January 4, 2012 2:22 AM
  • Hi,

     

    I would like to verify if two computers are in domain environment. What is the message when trying to remote to Windows 7 Ultimate? What is your Remote Desktop configuration under System Properties? Please set "Allow connection from any version of Remote Desktop" option.

     

    Also, please disable security software and perform clean boot on both computers for a test.

     


    Niki Han

    TechNet Community Support

    • Proposed as answer by Niki Han Thursday, January 12, 2012 2:02 AM
    • Marked as answer by Niki Han Monday, January 23, 2012 2:01 AM
    • Unmarked as answer by Niki Han Tuesday, January 31, 2012 2:09 AM
    Wednesday, January 4, 2012 9:15 AM
  • Niki,

     

    Thanks for the reply. Sorry for the long delay in responding.

    Both computers are in a workgroup, not a domain. I have set  things up to Allow connection form any version of Remote Desktop. I have windows firewall disabled, and am using another security product (Avira Internet Security 2012, which I was using before the failures started). I've disabled the Avira firewall, and I've opened tcp connections on port 3389. No change in behvaior. I can still connect from Win 7 ultimate to Win 7 pro, but not the nother way.

    Walt

    Sunday, January 29, 2012 8:59 AM
  • You mentioned "there isn't any error indication"...  Did you find none in the Windows event logs either?  You probably checked, but I wanted to remind you to do so if you hadn't.

     

    -Noel


    Detailed how-to in my new eBook: Configure The Windows 7 "To Work" Options

    Sunday, January 29, 2012 1:27 PM
  • Noel,

     

    That is correct, no errors indicated in the system or application logs or as a dialog box. I see the message about securing the connection, then nothing.

    I did see two notifications in the TerminalServicesRemoteConnectionManager Operational log on the remote machine indicating the Listener RDPTcp received a connection, and User Authentication succeeded.

    On the local machine I see in the TerminalServicesLocalSessionManager  operational log: Remote Desktop Service start failed. The relevant status code was 0x800706b5. But this message isn't correlated with when I try and connect to the remote machine.

    I added the registry key for SessionImageSize, and did a clean install of the latest nvidia driver. Same symptoms.

     

    Walt

    Sunday, January 29, 2012 7:26 PM
  • I forgot to mention, disabling virus checker and firewall didn't help. Still fails.  See my earlier note about the remote machine reporting successful authentication.

    Walt

    Sunday, January 29, 2012 7:43 PM
  • I am still having this problem. I wiresharked the network traffic and the last think from the Win 7 U machine is a disconnect of the session.

    Walt

    Thursday, March 29, 2012 12:57 AM
  • I assume you've tried all the various "Experience" settings.

    Do you have just the two systems?  I ask because it would be interesting to know whether you can RDP into another different system from the one that's failing to make the connection.

    Another random thought:  Did you ever have any Norton security software on either system?  I ask because I helped with a similar problem a long while back and it turned out some remnant of Norton Internet Security had been left in a system after the package had been removed.

      

    -Noel


    Detailed how-to in my eBook:  
    In development:

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Thursday, March 29, 2012 2:20 AM
  • Hi,

    Not sure if you fixed your problem butI ran intothe same situation on my domain between a windows 7 Ulti x64 and the x86 client just after installing Service Pack 1 on the x86 computer.

    The Windows Ulti x86 was not taking connections from client machines or fromthe server.

    Made sence to me to havea lookin the services menu and make sure "Remote Desktop Service" is started andset to "Automatic".

    For some reason, after installing SP1the servicewas set to manual.

    Fixed my problem anyway. hopethishelps many others!

    Shannon Downes (I.T.)
    shaz@lordshaz.com

    Tuesday, April 10, 2012 1:25 PM
  • Shannon,

    Yes, I check that early on. All of teh remote desktop services are running on both machines.  I used to be ablt to connect from the Ultimate to the Pro machine, but not the other way. But now I can't connect either way.

    Walt

    Tuesday, April 10, 2012 4:35 PM
  • After updating WIn 7 to SP1 on two remote desktop computers in Belgium, we now can't connect to them from the UK.

    If we make an RDP connection to a different computer in BElgium, that can't connect to the two desktops either.

    SO far this has prevented two of our home-working staff doing any work today.

    Wednesday, May 2, 2012 5:23 PM
  • There have been several people with exactly the same issue. I wonder if anyone from Microsoft is listening and has any ideas?
    Thursday, May 3, 2012 2:36 AM
  • Not sure but probably this will help.

    Deployment of Windows 7 SP1 on a computer which already has update KB2621440 installed breaks the RDP on that computer. In these cases when an attempt is made to connect to the computer RDP connection fails during initialization process after authentication and Remote Desktop Service fails on the target Computer.

    Following is the workaround.

    1.Uninstall KB2621440

    2.Restart Computer

    3.Reinstall KB2621440

    I hope this information will be helpful
    Thursday, May 3, 2012 6:13 PM
  • kb2621440 was installed after SP1.

    I tried uninstalling this update, but it made no difference. I also uninstalled both 2621440 and 2667402, rebooted and reinstalled both, but still didn't help.

    Walt

    Saturday, May 5, 2012 5:21 AM
  • I am having the same issue.  Added SP1 to a Windows 7 Pro machine and am now unable to remote to it (I was able to do so yesterday).  All services are running, all settings are correct. Something to note...I can connect if someone is logged on the machine when I try to connect.
    • Proposed as answer by sqlng Thursday, May 10, 2012 5:34 PM
    • Unproposed as answer by sqlng Thursday, May 10, 2012 5:34 PM
    Monday, May 7, 2012 2:26 PM
  • I had the same problem after SP1 and here is how I resolved:

    1. disable remote desktop access, apply and reboot
    2. reenable destop access and apply
    • Proposed as answer by Kevin Kinney Wednesday, May 30, 2012 3:25 PM
    Thursday, May 10, 2012 5:36 PM
  • Woohoo ... that's it. Disable/Reenable the RDP resolves it. Thanks.
    Monday, May 28, 2012 5:01 AM
  • This worked for me. After step 3 (reinstall KB2621440) RDP worked and I stopped getting "Remote Desktop Service start failed. The relevant status code was 0x800706b5." events.
    Monday, June 4, 2012 1:04 AM
  • I have tried both of these ideas, and neither made a difference. I am not getting any errors. The connection fails silently (control simply returns to the remote desktop login dialog box).

    Now I can't remote in either direction (originally I could connect from the Ulti system to the pro system but not any more). 

    I am able to connect from another Win 7 pro PC to my original Pro machine, but going the other way (from my original failing Win 7 pro PC to my new laptop) fails after briefly displaying a dialog box indicating it is looking for credential tiles (I didn't notice this before and I haven't yet googled it).

    Going from the new PC to the Ultimate PC also silently fails.

    So perhaps I have two problems, a credentials problem with my Pro machine and some other problem on the Ulti machine.

    Tuesday, June 5, 2012 3:28 AM
  • I had the same problem after SP1 and here is how I resolved:

    1. disable remote desktop access, apply and reboot
    2. reenable destop access and apply

    just disable through Control Panel > System > Remote tab > "Don't allow connections to this computer?"

    Or is there another way?


    MitchMeranovich

    Tuesday, June 5, 2012 10:56 PM
  • I'm in Walt's boat.  I've tried everything... nothing is working.  Thinking about saying goodbye to windows and welcoming in MacOS. 

    Uninstalling KB2621440 didn't help.

    I CAN CONNECT TO THE PROBLEM PC WITH MY IPHONE!  Why not window's RDP? 


    MitchMeranovich

    Wednesday, June 6, 2012 1:01 AM
  • I've had similar experiences in the past,  and it appeared to be caused by Avira. Do you have this? Uninstall it and try again.
    Friday, June 8, 2012 8:18 PM
  • Those of you experiencing this problem, do you or do you not have HomeGroup networking enabled?  Do things get better if you disable HomeGroup networking on both affected computers and reboot each?

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Friday, June 8, 2012 10:56 PM
  • I do use Avira. I disabled virus check and firewall, and also made sure to explicitly open the firewall to the specific ports. I did not try uninstalling it (which I will tomorrow night).

    Walt

    Monday, June 11, 2012 3:59 AM
  • I am not using home group.
    Monday, June 11, 2012 3:59 AM
  • Hi Walt,

    I tried removing 2667402 too although I'm not sure where the idea came from since it's only mentioned once on this page but it seems to have worked. I went to reinstall it via WSUS to verify and it did not re-detect. When I went manually looking for it I notice there is a v2 of that update released the day after your last post (Tuesday 12/6/2012). Having reinstalled this my RDP to the problem Win7 Pro virtual machine is still working.

    Check http://technet.microsoft.com/en-us/security/bulletin/ms12-020
    http://www.microsoft.com/en-us/download/details.aspx?id=29145 for x86
    http://www.microsoft.com/en-us/download/details.aspx?id=29138 for x64

    My problem may have been slightly different however since I got event log errors for the Remote Desktop Services service crashing after the password was entered on the login screen and Welcome message displayed. Those events included 7034 "The Remote Desktop Services service terminated unexpectedly.  It has done this 3 time(s)." which was the last in a series of 7034 messages each time it happened.

    Hope this helps

    Thursday, June 14, 2012 2:35 AM
  • OK. Remote Desktop is again working. I didn't change anything (although Windows updated lots of things, and I had updates of Avira as well). I found a postng about Avira and Remote Desktop, which suggested opening TCP port 3389 (which I had done) or changing the security level to medium (which I just tried and found I could connect to and from my Windows Ultimate machine. Setting security level back to custom (where I had it) and Remote Desktop still works.

    I am happy I have it working but I can't point to why tings changed. Thanks to everyine who offered advice.

    Walt

    Wednesday, June 27, 2012 4:50 AM
  • Hi All -

    I recently had about 20 of our beta Win7 users experience this same symptom, and I'm still tracking down root cause.  The nice part is that I think we found a working solution.  We presently set the remote desktop settings via group policy.  For whatever the machines are fine for awhile (10 mins to several hours or days) and then RDP stops working.  Run a command prompt via run as administrator and try this:

    netstat -abn | findstr 3389

    you'll notice that 3389 (remote desktop) isn't even binding.  After a few days of troubleshooting one of our guys came up with this - (thanks Stuart Porter)

    http://www.pburch.com/blog/tag/fdenytsconnections/

    http://support.microsoft.com/kb/2083411

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/fcd1faa4-214d-4ae3-a15d-1203b91447c7/

    http://www.computerperformance.co.uk/w2k3/services/terminal_services_remote_desktop.htm

    Anyhow make a long story short -- open up regedit and goto

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\fDenyTSConnections

    And if the value is set to (1) then this is likely what's blocking your TS session.  Please set the value to (0).

    Repeat the netstat from above and you'll notice that 3389 is magically listening again. I was shocked but seems to have fixed our issue. The other thing we noticed is that you may also have the windows firewall turned on and blocking 3389.  Check your firewall settings!

    • Proposed as answer by Mark L Gibbons Tuesday, February 5, 2013 9:46 PM
    Friday, July 6, 2012 3:46 AM
  • Uninstalling 2621440 and 2667402 did the trick for me the first time.

    Symptoms: "remote desktop service start failed 0x800706b5" event ID 17 in the
                        applications and services logs/microsoft/windows/TerminalServices-localsessionmanager/operational log.
                        Used CurrPort to check if 3389 was listening (or to check if some other process was using it).

    Only problem: reinstalling them also brings the problem back.

    Then uninstalled 2621440 again, no improvement after a reboot. So that's not the one.
    Uninstalled 2667402 and rebooted.
    This is more hopeful, I get the option to login and the Windows 7 logo but then it crashes again.
    Restarted the "remote desktop services" and i'm in.

    So, buggy but running.

    Thursday, July 12, 2012 11:12 AM
  • And it became to buggy...

    Used a Windows 7 DVD with SP1 and upgraded the installation. All other programs are not affected.
    From there used the windows update to get to the current patchlevel.

    It works now.

    Friday, July 13, 2012 6:51 AM
  • Having spent hours trying to fix this I saw this thread and this suggestion fixed it for me. Crazy! Many thanks for the info.
    Tuesday, February 5, 2013 9:46 PM
  • In addition to the previously mentioned updates, an update from 23/04/13 seems to have caused similar rdp/terminal issues.

    To resolve, I've had to uninstall the following three security updates (and remember to hide them once uninstalled):

    • KB2621440
    • KB2667402
    • KB2840149
    • Marked as answer by Niki Han Thursday, May 9, 2013 2:19 AM
    Wednesday, May 8, 2013 9:06 AM
  • I tried this and it DID NOT work.

    The solution was quite simple:

    I found that unchecking "Printers" on the local resources tab of Remote Desktop connection was the answer.

    Good luck to all!


    Thursday, July 11, 2013 1:40 AM
  • I fixed this problem in the following manner:

    1. In the search window on the start menu, type Services.

    2. Select Services in the resulting window

    3. Once you've accessed the Services (Local) window, scroll down until you see Remote Access Auto Connection Manager and Remote Access Connection Manager.

    4. Make sure they are both Started in the Status column.  If not, right click in the Status column next to each and choose Start.

    5. Check the Startup Type for each of these services.  If they are set to Manual or Disabled, right click in the Startup Type column.  Select Properties. Select Automatic.

    Wednesday, October 2, 2013 2:36 AM
  • Registry Fix: Hkey local machine * System*CurrentControlSet*Control*Terminal Server* fDenyTSConnections change DWORD to 0 Then restart RDP services. You should be all set.
    • Edited by SurEnough Tuesday, February 4, 2014 1:17 PM
    Tuesday, February 4, 2014 1:14 PM