none
Backup takes to much time RRS feed

  • Question

  • Hello, 
    We backuping deduplicated volume ~4TB size with DPM. 
    In most cases backup takes 30-60 min. But sometimes it takes few days. 
    This issue happens only for backup job wich starts on Saturdays. (Job scheduled to run everyday) 
    The only‌ thing I have found is that we have DedupJobs (Garbage Collection and Scrubbing) scheduled on Sutardays for protected volume. When Saturdays backup starts both job being completed. 
    Can these dedup jobs somehow impact backup time.
    Can these dedup jobs make huge ammount of USN journal changes?
    How can I view that changes was made in USN journal between Friday and Saturday backup jobs?
    What else can have such impact for file server backup time?

    We have same issue for 3 different File servers. These servers protected with different DPM servers and located in different sites, so issue probably not related to network. Also all other jobs are OK.

    We are using DPM2016 on Win2012R2, but same issue was when we have been on DMP2012R2.
    Thank you.

    Saturday, February 25, 2017 8:26 PM

Answers

  • Hello,

    It's due to the Garbage Collection (GC) job on deduped volume that is scheduled to run by default the last Saturday of every month at 2:45am (you can see a log in Data Deduplication Event log, ID 6419: "Garbage Collection job has started" with description "Full: true"

    The full mode GC has modification impact on whole dedup database files of the deduped volume which represents a large amount of data to be transfered during subsequent DPM sync

    You can disable the full mode GC on large file server (i've found on a technet article it's even best practice)

    https://support.microsoft.com/en-us/kb/3066175

    Did it on my environment and no more issue since then

    Larry


    Friday, March 3, 2017 6:57 PM

All replies

  • Hello,

    It's due to the Garbage Collection (GC) job on deduped volume that is scheduled to run by default the last Saturday of every month at 2:45am (you can see a log in Data Deduplication Event log, ID 6419: "Garbage Collection job has started" with description "Full: true"

    The full mode GC has modification impact on whole dedup database files of the deduped volume which represents a large amount of data to be transfered during subsequent DPM sync

    You can disable the full mode GC on large file server (i've found on a technet article it's even best practice)

    https://support.microsoft.com/en-us/kb/3066175

    Did it on my environment and no more issue since then

    Larry


    Friday, March 3, 2017 6:57 PM
  • Hi, 

    Thank you for your answer I will try your solution and post about results.

    Thursday, March 9, 2017 2:37 PM
  • Yes, after disabling full GB, problem was fixed. Thank you. 
    Sunday, April 9, 2017 5:40 PM