none
Litetouch behaviour change RRS feed

  • Question

  • Can anyone throw light on this issue? I run two MDT servers both exhibiting similar issues. I can no longer run litetouch.vbs from an administrator login where the deployment share is mapped using the username password pair as set in the custom.ini file. Running litetouch.vbs from the scripts folder manually USED to work fine. I would then choose a post deployment task from the pop up dialogue box to deploy applications as necessary. What happens now is strange; I'll get output like "cannot find script file z:\scripts\litetouch.wsf" although it is in the same folder I have just launched litetouch.vbs from. I also see on the other server an error that there is an error "y:\scripts\litetouch.vbs, line 88 character 1, network path not found, code 80070035". This line incidentally is "iRetVal = oShell.Run(sCmd, 1, true)"

    Logs are not helping me much. I tried running Litetouch.wsf instead manually (as this would appear to be the step that is never being processed from litetouch.vbs) but the MDT dialogue box just sits there hanging on "Processing Bootstrap Settings". I can see the c:\Minint folder being created on the pc calling litetouch to deploy (from a local administrator login). Any ideas anyone? Please!

    This has been working fine until now...and I am resisting installing again from scratch alhough I suppose it is an option.

    BTW. Running MDT version  6.1.2373.0 on one server, 6.0.2223.0 on the other, OS is Windows 2008 R2 on both.

    Cheers!


    C Edwards

    Tuesday, June 4, 2013 11:00 AM

All replies

  • This is maybe due to UAC, if you mapped the z: drive in your admin session then it won't be available inside your UAC session.

    Try to open cmd.exe as an administrator, make sure you have "administrator:" in the title of your cmd windows.

    Then map the z: drive with a net use in this CMD and launch litetouch.vbs.

    Tuesday, June 4, 2013 1:24 PM
  • Hi, Did try this but getting errors after running litetouch.vbs like "a connection to the deploymentshare (\\servername\deploymentsharename) could not be made. Can not reach Deployroot. Possible cause: Network routing error or Network configuration error" instead.

    -Although the mapping stays browsable in the command line and I can see the scripts folder. Maddening!


    C Edwards

    Tuesday, June 4, 2013 3:16 PM
  • This is another error.

    Are you sure that the deployroot variable in the bootstrap.ini is correctly set ?

    Tuesday, June 4, 2013 3:43 PM
  • One of the first things I looked for before writing to the forum. As I have said this has been working well until now and I'm failing to find what is the cause of this change of behaviour. The settings have not changed.

    C Edwards

    Thursday, June 6, 2013 1:48 PM
  • Do you have the same issue when booting from a MDT boot image ?

    My technet galleries contributions : ConfigMgr driver injector SCCM Collection splitter

    Thursday, June 6, 2013 8:06 PM
  • Colin, did you ever fix your issue? Same scenario is happening to me and I'm currently trying to track it down. Running two deployment shares, both from the same Windows Server 2012 box.

    Getting the exact same error: "\\deploymentshare\scripts\litetouch.vbs(88, 1) (null): 0x800700C1."

    I also tried running litetouch.wsf and getting a "Input Error: Can not find script file litetouch.wsf," which is highly amusing since I can browse right to the file. 

    In my particular environment, this is only happening on Windows XP VMs, in both Hyper-V and VMware. The Windows 7/8 VMs don't appear to have this issue. 

    Not a huge deal - we don't image production machines with XP - but a curiosity, nonetheless. 


    -Nick O.

    Edit: Come to think of it, may be an issue with the WADK. Going to set up a deployment share with WAIK for testing.
    • Edited by Nick Ourso Wednesday, September 18, 2013 7:34 PM Edit
    Wednesday, September 18, 2013 6:53 PM
  • 0x800700c1 is a *different* error here.

    C:\windows\system32>err 0x800700c1
    # as an HRESULT: Severity: FAILURE (1), Facility: 0x7, Code 0xc1
    # for hex 0xc1 / decimal 193 :
      ERROR_BAD_EXE_FORMAT                                          winerror.h
    # %1 is not a valid Win32 application.

    This means that you are trying to run the program litetouch.vbs, however litetouch.vbs is not a program. it's a script, and you need to run the script with the interpreter cscript.exe which is the program:

    cscript.exe <path>\litetouch.vbs

    Typically, the error "can not find script file litetouch.wsf" is because you are running cscript litetouch.vbs non-elevated. litetouch.wsf *must* run elevated, no exceptions.

    However if you can't run litetouch.wsf when called directly:

    cscript.exe <path>\litetouch.wsf

    Then I question your server configuration. Verify the permissions, ensure that you not running off of some cheap non-Windows NAS device. Can you open in Notepad? Get a network trace. Then check again.


    Keith Garner - keithga.wordpress.com

    Wednesday, September 18, 2013 10:17 PM
    Moderator
  • I'm running "cscript.exe <path>\litetouch.vbs" to pull the 0x800700c1 error. Also running "cscript.exe <path>\litetouch.wsf", which returns the strange albeit amusing "cannot find script file" error.

    I installed the WAIK and MDT 2012u1 on a test VM (Windows 7 x86) and had no issue. And then uninstalled the WAIK, installed WADK, uninstalled/reinstalled MDT 2010u1, and made a new deployment share. Again, no issue. 

    So now I'm curious if there is something amiss with production server, which is Windows Server 2012. Noting, again, this only occurs on Windows XP devices. Windows 7/8 have no issue running the litetouch scripts from the prod server.

    Since we don't deploy XP to production devices, I could always slide by with using a test VM just for XP. Right now, the strange behavior with Windows XP is more of a curiosity than anything else.


    -Nick O.

    Thursday, September 19, 2013 3:29 PM