none
SBS 2003 e MOSS 2007

    Question

  • Salve,

    è possibile far si che exchange 2003 (server SBS 2003) invii automaticamente l'emails in una lista sharepoint 2007?

    grazie

    stefano gragnani

    Monday, June 6, 2011 7:15 AM

Answers

All replies

  • Ciao stegra,

    si, è possibile... mi vengono in mente due modi (ovviamente su sharepoint deve essere attivata l'incoming email):

    1. realizzando un applicativo cdo lato exchange

    2. utilizzare un'apposita (o anche di un utente) cassetta postale di exchange sulla quale creare una regola che redirige la posta sulla lista di sharepoint

    Ci potrebbero essere anche altri modi, ma il tutto dipende da dove partono (vengono create) le email che devono arrivare su SharePoint.

    Ciao

     

     


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Monday, June 6, 2011 7:56 PM
  • Ciao Patrizia e grazie per la risposta, avrei ancora bisogno di aiuto ...

    1. Attivazione 'incoming email'.

      Ho creato una 'Unità Organizzativa' (OU) sul server dove gira l'exchange (sbs-server), che ho chiamato MOSS2007. A questo punto ho 'Delegato il controllo' e qui ho il primo problema: che utente devo mettere? So che devo usare il 'Central Administration Application Pool account' (sto seguendo la guida http://www.google.it/url?sa=t&source=web&cd=4&ved=0CDYQFjAD&url=http%3A%2F%2Fwww.slideshare.net%2Fp_sripada%2Fhow-to-configure-email-enabled-lists-in-moss2007-rtm-using-exchange-2003-presentation&ei=XdjtTdSyGYvQsgbOt_jjAw&usg=AFQjCNF4Gr4-PEmC8hK3TX5fvmHfaAkFSw) ma in pratica come devo fare? Ho provato a mettere l'amministratore di dominio ma poi, alla fine della procedura quando creo la lista SP con cui fare una prova, ottengo un errore. Dopo varie prove ho aggiunto vari utenti e l'errore è scomparso. Ovviamente dovrei capire come devo fare. Ho concesso le autorizzazioni 'Lettura', 'Scrittura' e 'Crea tutti gli oggetti figlio'.

      Sempre in sbs-server ho aperto il DNS Manager e ho creato un MX record per il server dove gira Sharepoint 2007 (server-hp): Host = server-hp; FQDN = server-hp.rinaldi.local.

      Ora, in server-hp (dove gira MOSS 2007) ho configurato l'SMTP (Default SMTP Virtual Server):

                                             Access --> Relay --> Granted 'sbs-server' (il server di exchange)

                                             Delivery --> Advanced --> Fully-qualified domain name = server-hp.rinaldi.local; Smart host: sbs-server.rinaldi.local

      A questo punto da 'Amministrazione Centrale Sharepoint' ho configurato 'Incoming e-mail settings':

                                             Settings mode = Automatic

                                             Active Directory container where new distribution groups and contacts will be created: OU=MOSS2007,DC=rinaldi,DC=local

                                             SMTP mail server for incoming mail: server-hp.rinaldi.local

                                             E-mail server display address: mylist@server-hp.rinaldi.local

      Infine ho creato una 'Raccolta documenti' - provaemails - l'ho abilitata a ricevere emails con indirizzo email: provaemails@server-hp.rinaldi.local

      E ora? Come funziona? Ho provato ad inviare un'email a tale indirizzo ma tutto ciò che ottengo è un errore di MAILER-DAEMON: Sorry, I couldn't find any host named server-hp.rinaldi.local.

    2. Regola cassetta postale Exchange.

              Da quanto mi dici a me andrebbe bene 'utilizzare un'apposita (o anche di un utente) cassetta postale di exchange sulla quale creare una regola che redirige la posta sulla lista di sharepoint' però: come la creo la regola?

    grazie

    Stefano Gragnani

     

     

    Tuesday, June 7, 2011 8:35 AM
  • Ciao Stefano,

    mi sembra che manchi solo la configurazione del DNS, ovvero occorre dire al server di posta che quando viene inviata un'email con dominio "server.hp.rinaldi.local" deve essere girata all'smtp che hai abilitato e che è agganciato a SharePoint. Vedi da qui http://technet.microsoft.com/en-us/library/cc262947(office.12).aspx?lc=1033 e controlla che tutti i passi che hai fatto siano corretti.

    Per ciò che riguarda la regola, si fa dal client di posta: devi dire al client che ogni volta che riceve un'email con determinate caratteristiche (non hai specificato quali sono... una determinata parola nell'oggetto, o un particolare mittente, o ...) deve essere girata a provaemails@server.hp.rinaldi.local (ad esempio). Per lagestione di regole su Outlook 2003 vedi qui http://office.microsoft.com/it-it/outlook-help/CH006356467.aspx.

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Tuesday, June 7, 2011 10:33 AM
  • Ciao Patrizia,

    il DNS dovrei averlo configurato (l'MX record etc. etc.) e per quanto riguarda la regola avevo frainteso, pensavo a qualcosa lato exchange. Domani mattina avrò di nuovo tempo per questo problema ti tengo aggiornata.

    grazie

    stefano

    Tuesday, June 7, 2011 10:58 AM
  • Ciao Patrizia, ho letto  http://technet.microsoft.com/en-us/library/cc262947(office.12).aspx?lc=1033 e sembrerebbe che abbia fatto tutto, il condizionale è d'uopo perché di fatto non mi funziona e quindi da qualche parte devo sbagliare. Allora riassumiamo:

    • server dove gira exchange 2003: sbs-server (controller di dominio, dominio = Rinaldi.local)
    • server dove gira moss 2007: server-hp

    L'OU l'ho creata in sbs-server e l'ho chiamata 'MOSS2007' (OU=MOSS2007,DC=rinaldi,DC=local)

    L'MX Record l'ho creato in sbs-server:

    • Host = server-hp
    • FQDN = server-hp.rinaldi.local (server-hp = server dove gira moss 2007)

    L'SMTP (Default SMTP Virtual Server) l'ho configurato su server-hp:

    • Access --> Relay --> Granted 'sbs-server' (il server di exchange);
    • Delivery --> Advanced --> Fully-qualified domain name = server-hp.rinaldi.local; Smart host: sbs-server.rinaldi.local

    In (server-hp) Central Administration > Operations > Incoming E-Mail Settings:

    • SMTP mail server for incoming mail: server-hp.rinaldi.local        -- è corretto server-hp? ho provato anche con sbs-server ma non funziona lo stesso :-)
    • E-mail server display address: mylist@server-hp.rinaldi.local

    Quando creo la 'Raccolta documenti' - provaemails - abilitata a ricevere emails con indirizzo email: provaemails@server-hp.rinaldi.local questa viene creata senza errori e nell'OU in sbs-server viene creato un nuovo contatto con nome uguale a quello della raccolta documenti: provaemails.

    Se provo ad inviare una email all'indirizzo provaemails@server-hp.rinaldi.local, questa non viene recapitata perché l'indirizzo non viene trovato.

    Devo modificare la configurazione dell'SMTP in sbs-server? Io non ho modificato questa configurazione, ho solo configurato (come sopra specificato) l'SMTP di server-hp. O, forse, devo aggiungere un altro connettore SMTP in sbs-server? E in tal caso come deve essere configurato? Per quanto riguarda la configurazione del DNS mi pare che si debba solo creare l'MX record o sbaglio?

    ciao

    grazie

    stefano

    Wednesday, June 8, 2011 8:37 AM
  • Ciao stefano,

    i passaggi li hai fatti tutti.

    "L'SMTP (Default SMTP Virtual Server) l'ho configurato su server-hp:": giusto

    "Delivery --> Advanced --> Fully-qualified domain name =server-hp.rinaldi.local; Smart host:sbs-server.rinaldi.local": lascia vuoto Smart host.

    "SMTP mail server for incoming mail: server-hp.rinaldi.local        -- è corretto server-hp? ho provato anche con sbs-server ma non funziona lo stesso :-)": è corretto server-hp; per la precisione devi mettere lo stesso nome che hai usato nella creazione del server smtp o un suo alias, se l'hai creato; io di solito aggiungo un alias e uso quello in modo da avere un nome più significativo. Aggiungi qui, nell'apposita sezione, l'indirizzo tcpip (o gli indirizzi) del server che può effettuare il relay all'smtp.

    Prova a fare queste modifiche e vediamo come va. Nell'event viewer dei due server hai qualche segnalazione?

    Ciao

     


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Wednesday, June 8, 2011 9:20 AM
  • Ciao Patrizia e grazie per il tempo che mi dedichi,

    allora, ho tolto lo Smart Host ma non cambia niente, mentre l'indirizzo IP del server che può effettuare il relay (e cioè sbs-server) l'avevo già messo se non sbaglio, cioè:

    Access --> Relay --> Granted 'sbs-server' (il server di exchange); (10.0.0.100)

    Nell'event viewer di entrambi i servers (sbs-server e server-hp) non si ha nessuna segnalazione dopo che ho ricevuto l'email di non recapito:

    Il messaggio non ha raggiunto alcuni o tutti i destinatari.

     

          Oggetto:    dd

          Inviato:    08/06/2011 11:38

    • Impossibile raggiungere i destinatari seguenti:
    •  
    •       Rinaldi Portal testemails 08/06/2011 11:38
    •             Account di posta elettronica non presente nell'organizzazione a cui è stato inviato il messaggio. Controllare l'indirizzo di posta elettronica o contattare direttamente il destinatario per conoscere l'indirizzo corretto.
    •             <rinaldisuperforni.com #5.1.1>

    ciao

    grazie

    stefano

     

    Wednesday, June 8, 2011 9:46 AM
  • Ciao stefano, prego!

    Avevo dimenticato, togli l'ip di exchange da "Access --> Relay --> Granted 'sbs-server' (il server di exchange); (10.0.0.100)" e mettilo nell'amministrazione centrale di sharepoint.

    Chi è "rinaldisuperforni.com"?

    Secondo me non sente correttamente l'smtp. Se ancora non va prova a cambiare la configurazione lasciando tutto *libero*, ovvero togli l'aggancio alla OU che hai appositamente creato.

    "Rinaldi Portal testemails" a quale indirizzo corrisponde? nella segnalazione dovrebbe esserci l'email, non il display name, se non ricordo male.

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Wednesday, June 8, 2011 9:55 AM
  • Ciao Patrizia,

    • ho tolto l'IP da Access --> Relay ... in amministrazione centrale di sharepoint dove lo vado a mettere?
    • rinaldisuperforni.com è il dominio esterno
    • ho tolto l'OU ma non cambia niente
    • Rinaldi Portal testemails = testemails@server-hp.rinaldi.local

    in pratica ho provato con le tue ultime indicazioni tranne per l'IP che l'ho tolto da Access --> Relay ma non l'ho rimesso da nessuna altra parte perché in Amministrazione centrale di SP non so dove metterlo.

    ciao

    grazie

    stefano

     

    Wednesday, June 8, 2011 10:11 AM
  • Scusa Stefano, mi sono spiegata male: l'ip di relay deve stare solo nella configurazione dell'incoming email di sharepoint (dove giustamente l'avevi messo) e non, eventualmente, nella configurazione dell'smtp, se per caso l'avevi aggiunto anche lì. Però volevo fare la prova abilitando tutti i server, per cui spunta l'accettazione da tutti i server di posta; facciamo questo solo per provare.

    Sempre nella configurazione dell'incoming email in amministrazione centrale metti "No" anche nella gestione del servizio directory.

    Facciamo tutto questo per provare se c'è qualche problema con le limitazioni.

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Wednesday, June 8, 2011 10:53 AM
  • Ciao Patrizia, riassumendo:

    1. SMTP: tolto l'IP di relay
    2. Amministrazione centrale:
    • Settings mode: Automatic
    • Use the SharePoint Directory Management Service to create distribution groups and contacts? NO
    • E-mail server display address: mylist@server-hp.rinaldi.local
    • Accept mail from all e-mail servers: SI

    il risultato, purtroppo, è il solito.

    ciao

    grazie

    stefano

    Thursday, June 9, 2011 7:08 AM
  • Ciao Stefano,

    mi sono riletta tutto... ma stai provando ad inviare a Moss da un dominio esterno (rinaldisuperforni.com è il dominio esterno)? Se è così, occorre configurare l'SMTP send connector in Exchange. Su questo, purtroppo, non ti posso aiutare, perché non ricordo più come si fa in Exchange 2003 e mi sembra fosse piuttosto diverso da Exchange 2007/2010. Hai provato ad inviare dall'interno a Moss?
    Se può aiutarti, puoi scaricare questa guida http://www.combined-knowledge.com/Downloads/2007/How%20to%20configure%20Email%20Enabled%20Lists%20in%20Moss2007%20RTM%20using%20Exchange%202003.pdf che ripete tutti i passaggi.

    Fammi sapere, ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Friday, June 10, 2011 12:17 PM
  • Ciao Patrizia,

    Io le prove le ho fatte tutte inviando una email a moss dal mio account outlook dal quale posso inviare/ricevere posta dall'interno/esterno, pensavo si trattasse di posta interna come quando invio una email ad un collega che si trova nel dominio ...

    grazie ciao stefano

     

    Friday, June 10, 2011 12:33 PM
  • C'è un'altra cosa Stefano: nell'access relay non usare il nome server ma metti l'ip (Access --> Relay --> Granted 'sbs-server' (il server di exchange) perché in alcuni casi sono stati segnalati errori se si mette il nome.

    Riesci anche ad aggiungere l'SMTP send connector in Exchange?

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Friday, June 10, 2011 2:59 PM
  • Ciao Patrizia,

    ho messo l'IP nell'access relay, per quanto riguarda l'aggiunta di un SMTP send connector in exchange l'ho fatto, l'ho chiamato SMPT_MOSS, come va configurato? Io ho fatto così:

    • Uitlizza DNS per il routing a ogni spazio indirizo sul contenitore: SI
    • Teste di ponte locali: SBS-SERVER (mi permette di inserire solo questo server)
    • Spazio indirizzo: SMTP   *   1
    • Ambito connettore: Tutta l'organizzazione

    ciao

    grazie

    stefano

    Friday, June 10, 2011 3:45 PM
  • Ciao Stefano,

    mi dispiace, ma non credo che così vada bene: il connettore deve puntare all'smtp di moss, in modo che exchange possa fare il routing delle email che arrivano per SharePoint. Come ti dicevo, io non ricordo più l'exchange 2003, però ho trovato questo post dove ci sono riassunti i passi: http://serverfault.com/questions/88467/configuring-exchange-to-relay-internal-e-mails-to-an-smtp-server.

    Qui http://www.combined-knowledge.com/Downloads/2007/How%20to%20configure%20Email%20Enabled%20Lists%20in%20Moss2007%20RTM%20using%20Exchange%202007.pdf, invece, trovi la configurazione per Exchange 2007, che io ho effettuato con successo anche qualche giorno fa; prova comunque a dare un'occhiata alle immagini, magari ti aiutano.

    Credo che appena riuscirai a configurare correttamente il routing, tutto funzionerà!

    Ciao


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Friday, June 10, 2011 4:38 PM
  • Ciao Patrizia,

    bingo funziona! Ho configurato correttamente l'SMTP seguendo il link che mi hai inviato e adesso finalmente la lista sharepoint riceve l'emails.

    A questo punto, però, ho il problema iniziale: inviare alla lista sharepoint tutte l'emails che arrivano ad una determinata cassetta postale di exchange 2003. Per fare delle prove, dal mio outlook ho creato una regola che inoltra le emails inviate a me alla lista sharepoint ma la lista non riceve nessuna email. Se nella regola inoltro, oltre che all'indirizzo della lista, anche ad un altro indirizzo di un utente in dominio, questi riceve l'email regolarmente!

    In definitiva:

    • se invio una email alla lista OK - la lista riceve l'email
    • se inoltro, tramite regola, l'email alla lista NO - la lista non riceve l'email. La regola se cambio indirizzo funziona.

    ciao

    grazie

    stefano

     

    Monday, June 13, 2011 8:29 AM
  • Ciao Stefano, bene, almeno una parte è a posto!

    E' davvero strano che se invii l'email direttamente a SharePoint funzioni e con una regola no.

    Se inoltri manualmente alla lista di SharePoint un'email ricevuta, funziona?

    Hai creato la regola di tipo client o di tipo server? Dovrebbe essere di tipo server.

    Ciao

     

     


    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Monday, June 13, 2011 9:14 PM
  • Ciao Patrizia,

    • Se inoltri manualmente alla lista di SharePoint un'email ricevuta, funziona?   SI
    • Hai creato la regola di tipo client o di tipo server? Penso di tipo server visto che dopo il nome della regola non cè niente (se creo una regola che dipende dal client accanto al nome della regola compare tra parentesi  la dicitura solo client)

    ciao

    grazie

    stefano

     

    Tuesday, June 14, 2011 9:13 AM
  • Ciao Stefano,

    "Se inoltri manualmente alla lista di SharePoint un'email ricevuta, funziona?   SI"

    e allora la configurazione è corretta, sia lato SharePoint che Exchange.

    Se nella regola metti un secondo destinatario con un indirizzo interno, funziona?

    Hai provato, magari, a creare la regola lato client?

    In alternativa mi viene in mente solo di creare un utente-contatto in AD; fargli creare la cassetta postale exchange cambiando, nelle proprietà smtp, l'indirizzo con quello creato per la lista di sharepoint e, dall'utente AD relativo alla cassetta postale che riceve le emails da inoltrare, vai nelle opzioni di "Delivery" e metti come destinatario il nuovo contatto.


    Ciao

    Pat (Microsoft Office Project MVP) -- http://patriziamonti.wordpress.com

    Tuesday, June 14, 2011 6:55 PM
  • Ciao Patrizia,

    scusami per il ritardo nel farmi sentire ma sono stato 'riderizionato' su altri problemi, comunque ho ancora (non ci ho più lavorato ...) il problema della regola. Si , se metto un secondo destinatario con un indirizzo interno funziona, ho provato anche a creare la regola lato client ma niente da fare. Appena avrò il tempo di ridedicarmi a questo problema ti aggiornerò.

    ciao

    grazie

    stefano

    Thursday, June 23, 2011 6:48 AM
  • Ciao,

    ho risolto mettendo l'indirizzo email della lista SP come indirizzo di inoltro dell'utente di AD che riceve le emails.

    ciao

    grazie

    stefano

     

    Friday, July 1, 2011 9:28 AM