none
Group Policy / Local users RRS feed

  • Question

  • So In all my searching I can't really find a workaround for this. I have a domain and plenty of domain users but I have one department that remains local user accounts. All I want to do is set the default homepage for these 47 domain connected machines.

    So with domain users I can use loopback policy to apply the user gpo settings to any computer in those specific OU's.  But that simply will not apply to local accounts.  Any other thoughts on how to make this work centrally?  Not super interested in doing one by one.

    thanks in advance.

    Edit: I did try pushing a registry setting via the computer config but doesn't seem to be taking.

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    “Start Page”=”http”

    • Edited by RyGy14 Friday, August 28, 2015 3:20 PM
    Friday, August 28, 2015 3:00 PM

All replies

  • Hi,

    <quote>

    Edit: I did try pushing a registry setting via the computer config but doesn't seem to be taking.

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    “Start Page”=”http”

    </quote>

    try adding a valid url.... IE will fall back to using the HKLM value, if the HKCU key for Start Page cannot be resolved.

    eg.

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    “Start Page”=”https://accounting/default.aspx”

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main]
    “Start Page”=”https://hr/default.aspx”


    Rob^_^

    Saturday, August 29, 2015 3:25 AM
  • Sorry for the long delay on this one.  Got side tracked.

    So far nothing has worked.  At this point I am setting

    under computer config

    HKLM\Software\Microsoft\Internet Explorer\Main\Default_Page_URL

    HKLM\Software\Microsoft\Internet Explorer\Main\Start Page

    under user config

    HKCU\HKLM\Software\Microsoft\Internet Explorer\Main\Default_Page_URL

    HKCU\HKLM\Software\Microsoft\Internet Explorer\Main\Start Page

    both test user and test pc are in the same OU

    when I check gpresult both policies are applied, when I check the registry HKLM is correct, but HKCU is still the MS default.   thoughts?

    Friday, September 11, 2015 1:47 PM
  • I'm not sure this is possible at all.  These aren't domain users but local users, so I'm not sure one can use group policy to change the HKCU of a local user....no?
    Friday, September 11, 2015 3:53 PM
  • Hi,

    It sounds like you are using a pinned site shortcut.... Launching a pinned site shortcut will only navigate to the designated (single) start/landing page... the IE settings for homepage(s) is ignored.

    You change a pinned sites landing page value in the markup for the mspinned site meta.. once changed on the server, it will automatically be updated the next time a user visits the site.

    To troubleshoot the issue, on a client machine (using the users profile), open a normal IE window, then f12>Networking tab, click the "Start" button to record the requests and responses, then return to IE (without closing the dev tool window).

    Manually type the address of your homepage setting in the address bar... observe the results (viz what happens eg... a blank page is opened instead?).

    Return to the dev tool's Networking tab, I expect that you will see some 302 responses... indicating that there is server side credential validation (LDAP credential validation) or that an intranet site (File>Properties menu to determine which IE security zone a domain maps to) is using Windows credential validation, OR that the site is using a cookie token to "Keep users logged in"....

    Tools>Internet Options>Security tab, click "Reset all zones to default".. then Local Intranet zone icon, settings .... check that

    to avoid this problem... create a simple landing page for the Intranet site that has only links to the login/join page on it and does not use server side tests for a 'currently logged in user"... do not use the sites' login/join page as the users homepage.


    Rob^_^


    Saturday, September 12, 2015 2:51 AM