none
Exchange Server 2007 error during updating SP3 RRS feed

  • Question

  • Hi 

    My exchange server 2007 needs to update to sp3 and the OS is W2K8 Ent. During the update process, there was a prerequisite check and its failed to continue because of the following error.  

    1.Error:The Simple Mail Transfer Protocol (SMTP) service is installed on this computer. This must be removed before Setup can continue.

    2.Error:The Windows Firewall service must be started before Setup can continue.

    3.Error:Setup cannot continue with the upgrade because the 'beremote' () process (ID: 7860) has open files. Close the process and restart Setup.

    I tried to remove the SMTP but it wont uninstall from the server, and IIS is installed on the server also. 
    So, is the SMTP is dependent with IIS and how can I proceed the update now ? And also please remarks on the 3rd error.

    Thanks in advance. 

    Sunday, March 9, 2014 10:04 AM

Answers

  • Point -3

    BEREMOTE is the service of your Backup Exec. you stop this service during the update process. see if this service is running in task manager if yes, then stop it.

    point 1 - using the roles and features uninstall the SMTP service.

    see if this works else update the status

    If you find this helpful then kindly mark this as answer. Thanks.

    Sunday, March 9, 2014 10:13 AM
  • run the servermanagercmd -q

    see the output, does it list out smtp servier in green.

    if you have previously uninstalled SMTP service, try restarting your server.

    there was another post with the same error, 

    http://social.technet.microsoft.com/Forums/en-US/7ab14bc1-1a1a-4b6c-a15a-8a13469ae1c8/exchange-2008-installer-detects-smtp-service-but-its-not-installed?forum=exchangesvrdeploylegacy

    If you find this helpful then kindly mark this as answer. Thanks.

    Sunday, March 9, 2014 11:05 AM

All replies

  • Point -3

    BEREMOTE is the service of your Backup Exec. you stop this service during the update process. see if this service is running in task manager if yes, then stop it.

    point 1 - using the roles and features uninstall the SMTP service.

    see if this works else update the status

    If you find this helpful then kindly mark this as answer. Thanks.

    Sunday, March 9, 2014 10:13 AM
  • Thanks for your remarks, but point 1: I already tried to uninstall the SMTP role, but it wont. Any other suggestion regarding this issue ?

    Thanks.

    Sunday, March 9, 2014 10:39 AM
  • what is the error you are getting .. and how are you trying to uninstall SMTP?
    Sunday, March 9, 2014 10:59 AM
  • run the servermanagercmd -q

    see the output, does it list out smtp servier in green.

    if you have previously uninstalled SMTP service, try restarting your server.

    there was another post with the same error, 

    http://social.technet.microsoft.com/Forums/en-US/7ab14bc1-1a1a-4b6c-a15a-8a13469ae1c8/exchange-2008-installer-detects-smtp-service-but-its-not-installed?forum=exchangesvrdeploylegacy

    If you find this helpful then kindly mark this as answer. Thanks.

    Sunday, March 9, 2014 11:05 AM
  • sc delete smtpsvc  try this out.

    If you find this helpful then kindly mark this as answer. Thanks.

    Sunday, March 9, 2014 11:14 AM