none
Featured Sites/Open to Anyone with a Guest Link

    Question

  • I was having a terrible time setting up access permissions; the steps in https://social.technet.microsoft.com/Forums/en-US/aec7daa0-49cf-418a-8625-0b2bb7eb3403/setting-up-sharepoint-365-folder-accesspermissions?forum=onlineservicessharepoint helped a great deal.  Somehow I was able to get rid of the Guest Link associated with the folders .... I'm not sure how.  I deleted the Link from "Featured Sites" and I'm wondering if that had anything to do with it; perhaps adding the link to Featured Sites opened up Guest Access?  I'm not going to touch Featured Sites until I'm sure that this is unrelated to the issue I was experiencing with access permissions.  Any insight would be appreciated -- thx DMiller
    Wednesday, March 22, 2017 3:52 PM

Answers

  • Hi DMillerAssociates,

    If you want to access the folder through a link, you can use the link of the folder (https://domain.sharepoint.com/sites/<site>/<library>/<folder>) instead of using the guest link (https://domain.sharepoint.com/sites/<site>/_layouts/15/guestaccess.aspx?folderid=<guid>&authkey=<key>)

    To disable the guest links feature, we can turn external sharing off for individual site collections, or for the entire SharePoint Online environment.

    For individual site collections:

    1. From the SharePoint admin center, click site collections.

    2. Check the box next to those site collections whose sharing settings you want to turn off.

    3. In the ribbon, click Sharing.

    4. Don’t select “Allow sharing with all external users, and by using anonymous access links”.

    For the entire SharePoint Online environment:

    1. From the SharePoint admin center, click Sharing.

    2. Under Sharing outside your organization, don’t select “Allow sharing with all external users and using anonymous access links”.

    For more information, read the following article:

    https://support.office.com/en-us/article/Manage-external-sharing-for-your-SharePoint-online-environment-caf3fcb7-300e-4165-b1da-27917d213c8d

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, March 28, 2017 2:17 AM

All replies

  • Hi DMiller,

    The guest link (Open to anyone with a guest link) is a feature in SharePoint Online.

    We can use this feature to send users a guest link that they can use to view or edit individual documents on your site anonymously.

    Read the following article for more information.

    https://support.office.com/en-us/article/Share-sites-or-documents-with-people-outside-your-organization-5f4cee39-5c91-4dc8-8fb1-96bca76f4eb0

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, March 23, 2017 7:50 AM
  • I understand that but what happened was I have certain folders I only want certain people--internal or external--to see.  When a folder has the Open to Anyone with a Guest Link any user has Contribute privileges; as soon as they access that folder Sharepoint adds their name to "Shared With" .... the "Manage Links" did nothing, and I still have no idea how I managed to make the Guest Link property go away .... I don't think adding a link to Featured Sites was the issue ... and Stopping Inherited Permissions and resetting Permissions as described and answered in my other post did not get rid of the Guest Link for these folders.  
    Thursday, March 23, 2017 12:50 PM
  • My problem may have to do with how I added the link to Featured Sites, which I did to make it easy to get right to the Site (perhaps there's a better way?).  As soon as I stated accessing the folder through the Featured Sites link I found that any user could access the folder regardless of the way the permissions were set.  After the user accesses that folder when I go back to check the permissions again the User has been added as a Contributor.  Prior to that, when I clicked the "Check Permissions" button Sharepoint told me Permission Levels given to the user were "None" .... I'm not seeing the "Guest Link" anymore but the way I'm setting permissions is clearly wrong ... based on this information can anyone tell me what I'm missing?  
    Friday, March 24, 2017 2:18 PM
  • Hi DMillerAssociates,

    If you want to access the folder through a link, you can use the link of the folder (https://domain.sharepoint.com/sites/<site>/<library>/<folder>) instead of using the guest link (https://domain.sharepoint.com/sites/<site>/_layouts/15/guestaccess.aspx?folderid=<guid>&authkey=<key>)

    To disable the guest links feature, we can turn external sharing off for individual site collections, or for the entire SharePoint Online environment.

    For individual site collections:

    1. From the SharePoint admin center, click site collections.

    2. Check the box next to those site collections whose sharing settings you want to turn off.

    3. In the ribbon, click Sharing.

    4. Don’t select “Allow sharing with all external users, and by using anonymous access links”.

    For the entire SharePoint Online environment:

    1. From the SharePoint admin center, click Sharing.

    2. Under Sharing outside your organization, don’t select “Allow sharing with all external users and using anonymous access links”.

    For more information, read the following article:

    https://support.office.com/en-us/article/Manage-external-sharing-for-your-SharePoint-online-environment-caf3fcb7-300e-4165-b1da-27917d213c8d

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, March 28, 2017 2:17 AM