locked
HTML CheckBox when opned using word check boxes are shown as red x RRS feed

  • Question

  • HTML CheckBox when opened using word 2010 the check boxes are shown as red x, how can i fix this?

    <html >
    <head>
        <title></title>
    </head>
    <body>

     <input type="checkbox" value="myvalue1" checked="checked"  />
      <input type="checkbox" value="myvalue2" checked="checked"  />
      <input type="checkbox" value="myvalue3"   />
      <input type="checkbox" value="myvalue4"   />
      <input type="checkbox" value="myvalue5"   />
    <p>

    Test 

    </p>
    </body>
    </html>

    Sunday, May 3, 2015 6:44 PM

All replies

  • while converting html to word are the html checkboxes supported by word? 
    Monday, May 4, 2015 7:17 PM
  • Hi Tomhare,

    Thanks for posting in MSDN forum.

    This forum is for developers discusing devleoping issues involve Word like Word automation, customization. Since the issue is more relative to end-user, I would like to move it to Word IT Pro Discussion forum.

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us.

    Thanks for your understanding.

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, May 5, 2015 2:44 AM
  • ok thank you Fei Xue

     i will follow on the new thread

    Tuesday, May 5, 2015 2:57 AM
  • Hi,

    I created an html file based on your provided code, in IE, your code works as expected that all checkboxes display well.

    In Word, this behavior seems to be related to a Trust Center settings:

    In Word 2010, File -> Options -> Trust Center -> Trust Center Settings -> ActiveX Settings -> Check which option is selected. My test result is that if "Disable all controls without notification" is ticked, the checkbox will display the red X. We can switch to "Prompt me before enabling all controls with minimal restrictions" to check the result.

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here.
    Tuesday, May 5, 2015 3:19 AM
  • yes in IE its fine before i post in here i have tried  meny options in word including  checking "Prompt me before enabling all controls with minimal restrictions"  as well also tried checking "enable all controls with out restrictions" i have also tried un checking the protected mood.

    results are still the same all RED X, is there any other options i am missing, did you test it  by pasting the above html to a note pad and save it as .doc-->open it in word--> and be able to see the check boxes properly displayed in word instead of RED x...

    Tuesday, May 5, 2015 4:32 AM
  • I am using Word 2010 to open the file
    Tuesday, May 5, 2015 4:33 AM
  • Hi,

    I created a Text Document "Test.txt", copied your code above and pasted it into the file "Test.txt", saved it.

    Then I changed the file extention to ".html", not ".doc", opened the file with Word 2010, and the behavior just met what I described above.

    Note: Before you quit Word, make sure you have saved the changes to the file.

    You can try to follow my steps and check the result. If the problem persists, maybe you can share the file that you created to me, I'll check it here on my side.

    Please send the file to our email address, and add the url of this thread for easy tracking.

    ibsofc@microsoft.com

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here.
    Tuesday, May 5, 2015 5:20 AM
  • I have tried exactly the same steps as yours it still didn't work, 

    created

    1.Test.txt

    2.copied and pasted above html code

    3.changed .txt to .html and opened it using word , saved file  before exiting word 

    active x is checked for prompt Prompt me before enabling all controls with minimal restrictions

    are there other  options that i need to check in order to make this work

    i have attached and emailed you the .html i created

    Thanks.

    Tuesday, May 5, 2015 4:21 PM
  • the HTML check boxes didn't work on word for me but i have used work around

    for our generated HTML..i have replaced html check boxes by Wingdings  and it works well

    • Replaced Checked check box by

       <font face="Wingdings 2"><font size="+2">R</font></font>

     

    • Replaced Unchecked  Check box by

    <font face="Wingdings 2"><font size="+3">*</font></font>

    Wednesday, May 6, 2015 3:00 AM
  • Hi,

    I can confirm your workaround works, but only in the scenario that you don't need to change the checkbox status any more.

    Another workaround is to use the checkbox content control from the Developer tab -> Controls, the checkbox is active:

    If you need to resolve the issue the html checkboxes don't display issue, I'm still thinking which option could cause the issue, did you get any warning message that something is blocked on the message bar in Word?

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here.
    Wednesday, May 6, 2015 3:19 AM
  • i didn't get any warning message, but normally if you pasted the previous html  with check box control

    and you were able to see the controls properly displayed on word 2010, there must be some options that i needs

    to check or uncheck in word.

    since the HTMl is generated dynamically from  an application code and is not manually created it wouldn't be convenient to use  Developer tab -> Controls,  

    Wednesday, May 6, 2015 3:35 AM
  • Hi,

    I'm currently doing research on this topic on my side, once I find anything I will let you know as soon as possible.

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here.
    Thursday, May 7, 2015 6:07 AM
  • ok i will follow 
    Thursday, May 7, 2015 6:41 AM
  • Hi,

    Sorry for replying late, I've been quite busy.

    I haven't found the option that may be involved in your scenario, but we can perform these steps below to narrow down the issue:

    1. Make sure you have ticked the option I mentioned above, then restart Word. If I just change the option in Word sometimes I need to restart Word to make the change take effect.

    2. Run Word in Safe Mode:

    Press Win + R, type "winword.exe /safe" in the blank box, press Enter.

    Running Word in safe mode can eliminate the interference by add-ins, if the checkbox can appear in Word safe mode, disable the suspicious add-ins to try again.

    3. In case other background programs are interfering with Word, please perform a clean boot to troubleshoot the issue.

    4. Clear the cache of Office to try again:

    The Office Document Cache

    http://support.microsoft.com/kb/2299848

    The temporary files

    http://support.microsoft.com/kb/211632

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here.
    Monday, May 11, 2015 2:25 PM
  • Most likely, Word's security settings are the reason why the check boxes are disabled.


    Stefan Blom, Microsoft Word MVP

    Monday, May 11, 2015 6:26 PM
  • is there any specific security settings that i need to check or uncheck..i tried all the above suggested steps no change it still showing as RED X 
    Monday, May 11, 2015 8:05 PM
  • Usually, HTML forms are treated as "active content," meaning that Protected view is involved. I'm not sure which options apply to HTML content, though, because I don't use Word for HTML documents.

    I suspect that you have to experiment with the security options in the Trust Center dialog box (click the Trust Center Settings button at File tab | Options | Trust Center).

    Alernatively, try putting the file in a trusted location (this will be safer than changing the security options).


    Stefan Blom, Microsoft Word MVP

    Tuesday, May 12, 2015 7:57 AM
  • Hi,

    Just checking in to see if the information provided by Stefan was helpful. Please let us know if you would like further assistance.

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here.
    Friday, May 15, 2015 2:09 AM
  • I have tried  the suggested options it didn't work in word 2010, how ever word  2007 was able to display the html check boxes properly.  i would very much like to know if there is any thing i can try to make it work on word 2010.

    Thanks for the follow up

    Friday, May 15, 2015 6:45 AM
  • I have this same problem with Word 2013, but only on some machines.  My desktop machine running Win7 Enterprise with Word 2013 15.0.4639.1000 displays the checkboxes.  My laptop running Win8.1 Enterprise with Word 2013 15.0.4711.1001 displays a red X where the checkboxes should be.  Please advise.
    Friday, May 15, 2015 5:07 PM
  • Hi,

    The reply from edlegs4live reminds me something that it may be related to some updates. But I haven't received many reports about this issue yet, and I'm using a newer version of Word 2013 and don't have the issue.

    My Word build number is 15.0.4719.1000, which should be more updated than 15.0.4711.1001.

    Please make sure your Office and Word are up-to-date and check the result again.

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here.
    • Proposed as answer by edlegs4live Tuesday, May 19, 2015 3:59 PM
    Tuesday, May 19, 2015 9:53 AM
  • Thanks Melon!  After applying the latest update to 15.0.4719.1000, the issue is resolved for me.
    Tuesday, May 19, 2015 3:58 PM
  • Hi tomhare,

    Have you got a chance to check the build version too? It has worked for edlegs4live.

    Regards,

    Melon Chen

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here.
    Wednesday, May 20, 2015 1:30 AM
  • version 14.0.7149.5000(32 bit)
    Wednesday, May 20, 2015 3:20 AM