locked
office 2010 icons unrecognized when open object from inside v. office 2010 RRS feed

  • Question

  • Hello

    The issue we have is icons of Office applications are not recognized when trying open any office object (doc, docx,xsl, xslx..) from inside virtual office 2010. example when create an word 2010 document and save it, then trying to re-open it againg from File > open, the icon is unrecognized. when double click on it it opens the correct application. this is true for Excel 2010, and PPT 2010. when openining from Windows all icons are displayed correctly. the file association from the app-v client shows the correct icons.

    GPOs are applied to open docs, xsl,.. in compatibility mode.

    We tested on a clean machine without GPOs or Office XP and we have the same issue

    Environment

    clients: windows XP SP3 with office XP installed physically office 2010 virtualized

    App-v client 4.6 SP1 HF 6

    Sequncer: 4.6 SP1 HF 3

    Office is customized to install Word, Excel, and PPT, local interaction is true 

    Thanks for your help

    
    
    
    Thursday, August 2, 2012 1:19 PM

Answers

  • Hi

    The problem was when adding %CISDL-Windows%\Installer to the exclusion list. It contains the folder {90140000-0011-0000-1000-0000000FF1CE} which contains office icons. we had to keep the folder and delete the contaents manually exdept the above folder.

    • Marked as answer by Raz N Wednesday, August 8, 2012 3:58 PM
    Wednesday, August 8, 2012 3:57 PM

All replies

  • Hello,

    How did you create your package?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, August 2, 2012 1:32 PM
  • Hello Nicke

    Thanks for your response

    we followed MS prescriptive guide for 4.6 SP1 in general, created customization file with all components disabled and XML file with the required components

    here is a snippet of the XML file.

    
    <Configuration Product="ProPlus">
    	<Display Level="basic" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />
    	<Logging Type="standard" Path="%temp%" Template="Microsoft Office Professional Plus Setup(*).txt" />
    	<INSTALLLOCATION Value="Q:\O2010" />
    	<AddLanguage Id="match" ShellTransform="yes" />
    	<AddLanguage Id="en-us" />
    	<OptionState Id="ACCESSFiles" State="absent" Children="force" />
    	<OptionState Id="EXCELFiles" State="local" Children="force" />
    	<OptionState Id="GrooveFiles" State="absent" Children="force" />
    	<OptionState Id="OneNoteFiles" State="absent" Children="force" />
    	<OptionState Id="OUTLOOKFiles" State="absent" Children="force" />
    	<OptionState Id="PPTFiles" State="local" Children="force" />
    	<OptionState Id="PubPrimary" State="absent" Children="force" />
    	<OptionState Id="WORDFiles" State="local" Children="force" />
    	<OptionState Id="XDOCSFiles" State="absent" Children="force" />
    Thanks
    Thursday, August 2, 2012 1:54 PM
  • Hello,

    The prescriptive guidance offers quite a few options in doing a sequence. That doesn't really tell me what you did?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, August 2, 2012 1:55 PM
  • Hello Nicke

    Here are the steps in general

    Sequencing :

    Create from template with the following exclusion list

    %CSIDL_COMMON_APPDATA%\Microsoft\RAC

    %CSIDL_PROGRAM_FILES%\MSECACHE

    %CSIDL_WINDOWS%\Installer

    %CSIDL_WINDOWS%\SoftwareDistribution

    %SFT_MNT%\Config.msi

    %SFT_MNT%\MSOCACHE

    C:\MSOCACHE

    Q:\Config.msi

    Q:\MSOCACHE

    \REGISTRY\MACHINE\Software\Policies

    \REGISTRY\USER\%SFT_SID%\Software\Microsoft\Tracing

    \REGISTRY\USER\%SFT_SID%\Software\Microsoft\Windows\CurrentVersion\Internet Settings

    \REGISTRY\USER\%SFT_SID%\Software\Microsoft\Internet Explorer

    \REGISTRY\USER\%SFT_SID%\Policies

    Create custom package and run  (setup /config <xml file name>.xml

    Run setup/modify proplus /config <xmlfile>.xml to remove sharepoint workspace

    Create and delete TreatAs reg keys

     Run the required office componenets

    Choose customize further to delete Notepad and IE from the list

    Did not add the following

    %commonprogramfiles%\Microsoft   Shared\virtualization handler\VirtualSearchHost.exe

    %commonprogramfiles%\Microsoft   Shared\Virtualization Handler\VirtualOWSSuppManager.exe

    %commonprogramfiles%\Microsoft   Shared\Virtualization Handler\MapiServer.exe

    %windir%\system32\Control.exe   %SFT_MNT%\<short path>\Office14\mlcfg32.cpl

    %SFT_MNT%\<short path>\Office14\MSOSync.exe

    Did not run componenets for streaming

    Create package compressed

    Edit package and changed SOFTPKG version to 14.0.6024.1000

    Checked office virtual registry for merge

    Saved file

    Thanks for your help

    Thursday, August 2, 2012 5:50 PM
  • Hello,

    If you redo the package - without the additional exclusions. Does that alter behavior?

    Nicke Källén | The Knack| Twitter: @Znackattack

    • Marked as answer by Raz N Wednesday, August 8, 2012 3:51 PM
    • Unmarked as answer by Raz N Wednesday, August 8, 2012 3:51 PM
    Thursday, August 2, 2012 6:03 PM
  • Hi

    The problem was when adding %CISDL-Windows%\Installer to the exclusion list. It contains the folder {90140000-0011-0000-1000-0000000FF1CE} which contains office icons. we had to keep the folder and delete the contaents manually exdept the above folder.

    • Marked as answer by Raz N Wednesday, August 8, 2012 3:58 PM
    Wednesday, August 8, 2012 3:57 PM
  • Hi

    The problem was when adding %CISDL-Windows%\Installer to the exclusion list. It contains the folder {90140000-0011-0000-1000-0000000FF1CE} which contains office icons. we had to keep the folder and delete the contaents manually exdept the above folder.

    Great stuff, thanks for posting.


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Wednesday, August 8, 2012 3:59 PM
    Moderator