none
LoadGen 2013 RRS feed

  • Question

  • I am trying to make use of LoadGen 2013 in an Exchange 2013 environment. Initially I started with LoadGen on a different machine (same domain) and then moved LoadGen to the exchange server itself.

    When I select the number of mailboxes greater than 20 I get an error message that it is fixing the user count to 20.

    If I set it to 19 or 20 I dont get the message.

    StoreBuilder.General Error: 0 : 12/01/2014 01:32:39 -- Diagnostic context (user: '87e4cd54-add7-4ca0-8365-66ee438a5b0a'):
     distinguishedName 'CN=EXCHANGE1 CA868A55-LGU000042,OU=Exchange1Store,OU=Users,OU=LoadGen Objects,DC=NST,DC=NET', exchServerDn '/o=MCBP/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EXCHANGE1', userDn '/o=MCBP/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=CA868A55-LGU000042', mailNickName 'CA868A55-LGU000042', emailAddress 'CA868A55-LGU000042@NST.NET'.
    StoreBuilder.General Error: 0 : 12/01/2014 01:32:39 -- Diagnostic context (user: '87e4cd54-add7-4ca0-8365-66ee438a5b0a'):
     distinguishedName 'CN=EXCHANGE1 CA868A55-LGU000042,OU=Exchange1Store,OU=Users,OU=LoadGen Objects,DC=NST,DC=NET', exchServerDn '/o=MCBP/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EXCHANGE1', userDn '/o=MCBP/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=CA868A55-LGU000042', mailNickName 'CA868A55-LGU000042', emailAddress 'CA868A55-LGU000042@NST.NET'.
    Engine.General Warning: 0 : 12/01/2014 01:32:39 -- Caught a non-fatal exception in executeTaskStub. The exception was handled by the task module: Microsoft.Mapi.MapiExceptionNetworkError: MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80004005, ec=2423)
    Diagnostic context:
        ......
        Lid: 16280   dwParam: 0x0 Msg: EEInfo: ComputerName: n/a
        Lid: 8600    dwParam: 0x0 Msg: EEInfo: ProcessID: 3644
        Lid: 12696   dwParam: 0x0 Msg: EEInfo: Generation Time: 0414-12-01T09:32:39.9530000Z
        Lid: 10648   dwParam: 0x0 Msg: EEInfo: Generating component: 14
        Lid: 14744   dwParam: 0x0 Msg: EEInfo: Status: -1073606646
        Lid: 9624    dwParam: 0x0 Msg: EEInfo: Detection location: 1380
        Lid: 13720   dwParam: 0x0 Msg: EEInfo: Flags: 0
        Lid: 11672   dwParam: 0x0 Msg: EEInfo: NumberOfParameters: 2
        Lid: 12952   dwParam: 0x0 Msg: EEInfo: prm[0]: Long val: 12175
        Lid: 8856    dwParam: 0x0 Msg: EEInfo: prm[1]: Unicode  string: /rpc/rpcproxy.dll?d0d142f3-93fe-4a88-97e2-ab2124805482@NST.NET:6001
        Lid: 62184  
        Lid: 16280   dwParam: 0x0 Msg: EEInfo: ComputerName: n/a
        Lid: 8600    dwParam: 0x0 Msg: EEInfo: ProcessID: 3644
        Lid: 12696   dwParam: 0x0 Msg: EEInfo: Generation Time: 0414-12-01T09:32:39.9530000Z
        Lid: 10648   dwParam: 0x0 Msg: EEInfo: Generating component: 14
        Lid: 14744   dwParam: 0x0 Msg: EEInfo: Status: 65536
        Lid: 9624    dwParam: 0x0 Msg: EEInfo: Detection location: 1385
        Lid: 13720   dwParam: 0x0 Msg: EEInfo: Flags: 0
        Lid: 11672   dwParam: 0x0 Msg: EEInfo: NumberOfParameters: 2
        Lid: 12952   dwParam: 0x0 Msg: EEInfo: prm[0]: Long val: 8
        Lid: 13976   dwParam: 0x0 Msg: EEInfo: prm[1]: Binary buffer[size=788]
        Lid: 62184  
        Lid: 16280   dwParam: 0x0 Msg: EEInfo: ComputerName: n/a
        Lid: 8600    dwParam: 0x0 Msg: EEInfo: ProcessID: 3644
        Lid: 12696   dwParam: 0x0 Msg: EEInfo: Generation Time: 0414-12-01T09:32:39.9370000Z
        Lid: 10648   dwParam: 0x0 Msg: EEInfo: Generating component: 13
        Lid: 14744   dwParam: 0x0 Msg: EEInfo: Status: 14
        Lid: 9624    dwParam: 0x0 Msg: EEInfo: Detection location: 3001
        Lid: 13720   dwParam: 0x0 Msg: EEInfo: Flags: 0
        Lid: 11672   dwParam: 0x0 Msg: EEInfo: NumberOfParameters: 1
        Lid: 12952   dwParam: 0x0 Msg: EEInfo: prm[0]: Long val: 12180
        Lid: 59505   StoreEc: 0x977     
        Lid: 50544   ClientVersion: 15.0.805.0
        Lid: 52080   StoreEc: 0x977     
        Lid: 51152  
        Lid: 52465   StoreEc: 0x977     
        Lid: 60065  
        Lid: 33777   StoreEc: 0x977     
        Lid: 59805  
        Lid: 52487   StoreEc: 0x977     
        Lid: 19778  
        Lid: 27970   StoreEc: 0x977     
        Lid: 17730  
        Lid: 25922   StoreEc: 0x977     
       at Microsoft.Mapi.MapiExceptionHelper.InternalThrowIfErrorOrWarning(String message, Int32 hresult, Boolean allowWarnings, Int32 ec, DiagnosticContext diagCtx, Exception innerException)
       at Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, IExInterface iUnknown, Exception innerException)
       at Microsoft.Mapi.ExRpcConnectionFactory.Create(ExRpcConnectionInfo connectionInfo)
       at Microsoft.Mapi.MapiStore.OpenMapiStore(String serverDn, String userDn, String mailboxDn, Guid guidMailbox, Guid guidMdb, String userName, String domainName, String password, String httpProxyServerName, ConnectFlag connectFlags, OpenStoreFlag storeFlags, CultureInfo cultureInfo, Boolean wantRedirect, String& correctServerDN, ClientIdentityInfo clientIdentity, String applicationId, Client xropClient, Boolean wantWebServices, Byte[] clientSessionInfo, TimeSpan connectionTimeout, TimeSpan callTimeout, Byte[] tenantHint)
       at Microsoft.Mapi.MapiStore.OpenMailbox(String serverDn, String userDn, String mailboxDn, String userName, String domainName, String password, String httpProxyServerName, ConnectFlag connectFlags, OpenStoreFlag storeFlags, CultureInfo cultureInfo, WindowsIdentity windowsIdentity, String applicationId)
       at Microsoft.Exchange.Swordfish.Extensions.MapiCommon.MapiStoreUtil.<>c__DisplayClass2.<OpenMailbox>b__0()
       at Microsoft.Exchange.Swordfish.IL.ILUtil.DoTryFilterCatch(ThreadStart tryClause, Predicate`1 filterClause, Action`1 catchClause)
       at Microsoft.Exchange.Swordfish.Extensions.MapiCommon.MapiStoreUtil.OpenMailbox(User user, ConnectFlag connectFlags, OpenStoreFlag openStoreFlags)
       at Microsoft.Exchange.Swordfish.Extensions.StoreBuilder.Builder.EnsureMailboxStore(User user)
       at Microsoft.Exchange.Swordfish.Extensions.StoreBuilder.Builder.BuildInboxRules(User user)
       at Microsoft.Exchange.Swordfish.Extensions.StoreBuilder.Builder.BuildMailboxStore(User user)

     

    Could you please let me know a solution.

    Monday, December 1, 2014 9:47 AM

Answers

  • Hi kayvwar,

    I find a similar thread, following is the detailedinformaiton:

    This error occurs when on the specify test user group dialog we do not configure an Outlook group as one of the user groups. So for example if we define UserGroup1 as any of the OWA client types and do not add a secondary user group with any of the Outlook client types we will encounter this error. So please add an outlook group as well. Also, after editing, we need to reload it from the "Start a new test" page for Exchange Load Generator to pick up the custom settings.  
    
    For more inforamtion about Load Generator, we can refer to the following articles:
    
    Title: Creating and Running the Exchange Load Generator Test
    
    Link:  http://technet.microsoft.com/en-us/library/bb508866(v=exchg.80).aspx 
    
    Title: Frequently Asked Questions about Exchange Load Generator
    
    Link:  http://technet.microsoft.com/en-us/library/bb508898(v=exchg.80).aspx
    
    Meanwhile, we can download the "Microsoft Exchange Load Generator 2013.doc" from website "http://www.microsoft.com/en-in/download/details.aspx?id=40726" which contains the detailed steps of how to use  Exchange Load Generator for test.

    More details: https://social.technet.microsoft.com/Forums/msonline/en-US/d4461646-a5e4-4e20-ae9f-aae9eecec8f4/loadgen2013-initializing-mailbox-error?forum=exchangesvrgeneral

    Please also make sure you run LoadGen as Administrator.

    Important!

    LoadGen should be used only in laboratories that have no connection to the production environment.

    More details to see: http://www.microsoft.com/en-hk/download/details.aspx?id=40726

     

    Thanks


    Mavis Huang
    TechNet Community Support


    Wednesday, December 3, 2014 12:28 PM
    Moderator

All replies

  • You've posted this on the Exchange 2003 and Exchange 2007 forum.  Please delete it from here and move it to the Exchange 2013 forum.
    Monday, December 1, 2014 2:13 PM
  • Hi kayvwar,

    I find a similar thread, following is the detailedinformaiton:

    This error occurs when on the specify test user group dialog we do not configure an Outlook group as one of the user groups. So for example if we define UserGroup1 as any of the OWA client types and do not add a secondary user group with any of the Outlook client types we will encounter this error. So please add an outlook group as well. Also, after editing, we need to reload it from the "Start a new test" page for Exchange Load Generator to pick up the custom settings.  
    
    For more inforamtion about Load Generator, we can refer to the following articles:
    
    Title: Creating and Running the Exchange Load Generator Test
    
    Link:  http://technet.microsoft.com/en-us/library/bb508866(v=exchg.80).aspx 
    
    Title: Frequently Asked Questions about Exchange Load Generator
    
    Link:  http://technet.microsoft.com/en-us/library/bb508898(v=exchg.80).aspx
    
    Meanwhile, we can download the "Microsoft Exchange Load Generator 2013.doc" from website "http://www.microsoft.com/en-in/download/details.aspx?id=40726" which contains the detailed steps of how to use  Exchange Load Generator for test.

    More details: https://social.technet.microsoft.com/Forums/msonline/en-US/d4461646-a5e4-4e20-ae9f-aae9eecec8f4/loadgen2013-initializing-mailbox-error?forum=exchangesvrgeneral

    Please also make sure you run LoadGen as Administrator.

    Important!

    LoadGen should be used only in laboratories that have no connection to the production environment.

    More details to see: http://www.microsoft.com/en-hk/download/details.aspx?id=40726

     

    Thanks


    Mavis Huang
    TechNet Community Support


    Wednesday, December 3, 2014 12:28 PM
    Moderator