none
SBS2011 faxing is not working

    Question

  • I just finished a SBS2003 to SBS2011 swing migration, everything is working great except for FAXing.

    When sending a fax from the server or from a workstation the modem dials, negotiates with the fax machine on the other end of the line, transmits for a few seconds and then disconnects with "Fatal Error". I have tried a number of things which I will detail in a moment.

    For the first day faxing seemed to work, then it started giving errors. Upon furter investigation we found that some of our outbound faxes had issues that we didn't know about. Sending the fax 4 times to one person, etc.

    Here are the errors we get
    From the Fax Log
    Error Desciption: Unknown fatal error
    Error Code: 0x0000000c


    From the System Event logs:
    Log Name: Application
    Source: Microsoft Fax
    Date: 8/20/2012 10:35:36 AM
    Event ID: 32027
    Task Category: Outbound
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: BOONE-SERVER.boone.local
    Description:
    An error was encountered while sending a fax. This fax will not be sent, because the maximum number of retries has been exhausted. If you restart the transmission and difficulties persist, please verify that the phone line, fax sending device, and fax receiving device are working properly. Sender: Administrator. Billing code: . Sender company: Boone Insurance Associates. Sender dept: . Device name: U.S. Robotics 56K FAX EXT PnP. Job ID: 0x0201cd7ef9f098e1. User name: BOONE\administrator.
    Please check the activity log for further details of this event.

    Server Details
    Dell T110 II
    SBS 2011 Standard
    16GB of RAM
    Raid 10 with 6x300GB 10K drives
    Everything is fully patched (OS, Exchange, Sharepoint)

    Fax routing is set up to go to a folder on the data drive and to a sharepoint library.

    Here is what I have tried
    - Uninstalling the Fax Server role from the server and then reinstalling it.
    - Running the "Repair the Fax service" wizard from the SBS console
    - A new modem from a different manufacture, same results.
    Both Modems list 2008R2 compatibility and searches reveal other are using them successfully with SBS2011:
    MultiTech - MT9234ZBA-NAM
    http://www.multitech.com/en_US/PRODUCTS/Families/MultiModemZBA
    US Robotics 5686G
    http://www.usr.com/support/product-template.asp?prod=5686g

    - Adjusted settings on the modem properties
    Port Speed: 9600 - No difference
    Error Correction: Turned off - No difference

    - Have tried sending to multiple fax machines.
    - When I changed folder permissions on the server:
    c:\ProgramData\Microsoft\WIndows NT\MSFax
    So that everyone has full access, now 50% of faxes will go out when sending from the server itself. (I have not had any of the desktop user try.)

    Next I tried to find a patern thinking it might be an issue with specific cover pages, but it doesn't make a difference for each cover page or even if there is a cover page.

    I thought it might be a line issue, but then I can't rectify in my mind why the SBS2003 server (using an internal modem) and a fax machine work fine on the exact same line.

    Any help would be greatly appreciated.
    Tuesday, August 21, 2012 6:45 AM

All replies

  • There should be some log files as well at this location c:\ProgramData\Microsoft\WIndows NT\MSFax can you upload them on skydrive if that's possible?

    Since you have pretty much covered everything that I could think off :-) still I have to ask have you installed The Fax Service crashes when a fax server receives a fax on a computer that is running Windows Server 2008 or Windows Server 2008 R2

    http://support.microsoft.com/kb/973640.

    To verify if this hotfix is installed or not

    Run this command from powershell

    Get-WmiObject -query 'select * from win32_quickfixengineering' | where {$_.hotfixid -eq "KB973640"} | foreach {$_.hotfixid}

      if KB973640 is installed, command will return kb973640 as a value ,  and blank output if  kb973640 is not installed.



    Tuesday, August 21, 2012 11:47 AM
  • Yes those logs are where I got this error information from:

    Error Desciption: Unknown fatal error
    Error Code: 0x0000000c

    I saw that hotfix information, but since I am not having any of those specific issues I have not installed it. Since I am running out of ideas I may give a try anyway. 

    - Nathan

    Tuesday, August 21, 2012 3:55 PM
  • I've the same problem here on my SBS2011 Essentials, and I've some more observations:

    • The error seems to depend on the recipient. Some recipients can reveive faxes, others the server disconnects although the line is free and it gets a fax connection.
    • When I attach the modem to my Win7 Ultimate x64 Workstation and use Windows Fax-and-Scan there, it works without a problem

    Wednesday, August 22, 2012 2:21 PM
  • Hi,

    Please try to repair the Fax service:

    1.Open the Windows SBS Console in Advanced Mode.

    Note: To open the console in Advanced Mode, click Start, click All Programs, click Windows Small Business Server, and then click Windows SBS Console (Advanced Mode).

    2.In the User Account Control dialog, click Continue.

    3.Click the Network tab, and then click Devices.

    4.Click Repair the Fax service.

    Does it work?

    Regards,


    Arthur Li

    TechNet Community Support

    Friday, August 24, 2012 5:18 AM
    Moderator
  • Can't find SBS Console in SBS 2011 Essentials. Is there a CMD/Powershell command to do the repair?

    Saturday, August 25, 2012 3:23 AM
  • I had already tried that a twice as well as an uninstall/reinstall. Neither helped.

    It does look like it is working now, not sure exactly what fixed it as I did a few different things all at the same time as one last ditch effort before I was going to open a case with Microsoft.

    - Deleted the shared Fax printer on the server (this doesn't appear to get deleted and recreated when you reinstall or repair the fax service/roll)
    - Deleted the Com1 port from device manager and had the server reinstall it
    - Replaced the Serial cable (highly doubt this fixed it as it was receive faxes okay for the most part, just couldn't send)
    - Deleted the modem yet again from device manager and had the server reinstall it.

    Seems to be working for now. It is going to take a few days of it working for me to believe this is really over.


    Saturday, August 25, 2012 3:58 AM
  • Hi enotsIT ,did you also installed KB973640 as a part of your troubleshooting?
    Saturday, August 25, 2012 4:57 AM
  • No, I had it already to try even though the issue didn't match mine at all, but I didn't install it. 
    Sunday, August 26, 2012 4:30 AM
  • Worked for almost a week and now it is doing the same thing again. 
    Friday, August 31, 2012 8:20 PM
  • If i were you i will install http://support.microsoft.com/kb/973640 first . If it still doesn't works provided you have a class A modem ( US robotics) call microsoft for the possible solution.

    Post back logs, if possible . If i can figure something out of those will post back ,  best option is  call microsoft support.

    Saturday, September 01, 2012 8:10 AM
  • I'm having the same issue with SBS2008; outgoing faxes are failing with 0x0000000c in the transmission log while the recipient is getting several partial pages instead of the complete document.  It's more than a little distressing.

    KB973640 deals with the fax server crashing on incoming faxes; in this instance the fax server isn't crashing and the affected faxes are outgoing, not incoming.

    Tuesday, September 25, 2012 8:35 PM
  • I ended up going with GFI Faxmaker instead and it works perfectly. 
    Wednesday, September 26, 2012 2:26 AM