none
Sysprep and Capture Task Sequence Does Nothing RRS feed

  • Question

  • I've created a task sequence to capture a reference image but when I run it through LiteTouch.vbs, it runs through but doesn't do anything.

    If I change SkipCapture to NO, the wizard appears and I can successfully start the capture by entering the details manually. Sysprep fires up, machine boots into Win PE and starts capturing.

    Can anyone point out where I'm going wrong? Here are my rules

    [Settings]
    Priority=Init,Laptop,Desktop,VM,TaskSequenceID,Default
    Properties=ComputerSerial,ComputerType
    
    [Init]
    ComputerSerial=#Left("%SerialNumber%",7)#
    
    [Laptop]
    Subsection=Laptop-%IsLaptop%
    
    [Desktop]
    Subsection=Desktop-%IsDesktop%
    
    [Laptop-True]
    ComputerType=LT
    
    [Desktop-True]
    ComputerType=DT
    
    [001]
    JoinWorkgroup=WORKGROUP
    
    [002]
    DoCapture=YES
    ComputerBackupLocation=NETWORK
    BackupShare=\\SERVER\DeploymentShare$\Captures
    BackupDir=%OSDComputerName%
    
    [003]
    JoinDomain=domain.local
    DomainAdmin=mdt
    DomainAdminPassword=
    DomainAdminDomain=domain.local
    MachineObjectOU=ou=Computers,ou=dc=domain,dc=local
    
    [Default]
    _SMSTSOrgName=AAA
    _SMSTSPackageName=%TaskSequenceName% on %OSDComputerName%
    
    OSInstall=Y
    SkipComputerName=YES
    OSDComputerName=AAA-%ComputerType%-%ComputerSerial%
    SkipDomainMembership=YES
    SkipCapture=YES
    SkipUserData=YES
    SkipComputerBackup=YES
    SkipProductKey=YES
    ProductKey=
    SkipLocaleSelection=YES
    UILangugage=en-GB
    UserLocale=en-GB
    KeyboardLocale=en-GB
    InputLocale=en-GB
    SkipTimeZone=YES
    TimeZoneName=GMT Standard Time
    SkipRoles=YES
    SkipApplications=YES
    SkipAdminPassword=YES
    AdminPassword=
    SkipBitLocker=YES
    SkipSummary=YES
    SkipFinalSummary=YES
    Thanks


    Thursday, March 22, 2018 3:08 PM

Answers

  • I'm 99% sure skipping just skips the pages in the wizard but a value has to be supplied - I could be wrong though.

    However, I've figured it out now and it's arguably a better method.

    In the capture task sequence, if you add the 3 needed values as task sequence variables like this it works. You can set SkipCapture=YES in the rules and this does the rest.


    • Marked as answer by jim11212 Thursday, March 22, 2018 6:34 PM
    • Edited by jim11212 Thursday, March 22, 2018 6:46 PM
    Thursday, March 22, 2018 6:33 PM

All replies

  • I'm curious as to why you set the Rules to SkipCapture=Yes.

    Are you wondering why it Captures when you set Skip to NO? I'm missing something but that's what it's supposed to do, set that way.

    Thursday, March 22, 2018 3:44 PM
  • I want to be able to start the capture task sequence with no user input. In the [002] section, I've set what I think are the correct settings.

    Thursday, March 22, 2018 3:55 PM
  • What kind of input are you wanting to set ahead?
    Thursday, March 22, 2018 4:04 PM
  • These - path and filename

    Thursday, March 22, 2018 4:17 PM
  • Here is what I use for my Capture TS Rules. It gives the WIM a generic name but then I rename it once it's complete.

    [Settings]
    Priority=Default

    [Default]
    _SMSTSORGNAME=name of org
    OSInstall=Y
    SkipAppsOnUpgrade=NO
    SkipAdminPassword=YES
    ComputerBackupLocation=%DeployRoot%\Captures
    BackupFile=%OSDComputername%_#replace(date,"/",".") & ".wim"#
    SkipProductKey=YES
    SkipComputerName=YES
    SkipDomainMembership=YES
    SkipUserData=YES
    UserDataLocation=YES
    SkipLocaleSelection=YES
    SkipTaskSequence=NO
    SkipTimeZone=YES
    SkipApplications=NO
    SkipBitLocker=YES
    SkipSummary=YES
    SkipBDDWelcome=YES
    SkipCapture=NO
    DoCapture=YES
    SkipFinalSummary=NO

    TimeZone=020
    TimeZoneName=Central Standard Time

    JoinWorkgroup=WORKGROUP

    This creates a computer name based on date, and saves it to my MDT Build\Captures folder every time. Once done, I rename my WIM to something appropriate. The older version of MDT allowed me to name the WIM just prior to Capture but I don't see that option anymore.

    Thursday, March 22, 2018 4:26 PM
  • If I set SkipCapture to NO then set ComputerBackupLocation and BackupFile, it prompts me for inputs but ignore the values in the rules

    I'm not sure if it's because I'm trying to do this per task sequence. It just seems to ignore them either regardless of what SkipCapture is set to

    Thursday, March 22, 2018 4:41 PM
  • If you want all of your TS's to Capture the same way, try

    [002]
    DoCapture=Yes

    but under [Default],

    remove the OSDComputername line...... and instead try:

    ComputerBackupLocation=%DeployRoot%\Captures
    BackupFile=%OSDComputername%_#replace(date,"/",".") & ".wim"#

    This should capture the WIM to the same location, your Captures folder, and name them %OSDComputername% with a date association to it.


    and leave SkipCapture=NO
    Thursday, March 22, 2018 4:59 PM
  • Ok, so setting

    [002]
    DoCapture=YES

    and

    [Default]
    ComputerBackupLocation=%DeployRoot%\Captures
    BackupFile=#replace(date,"/","." & ".wim"#

    correctly sets the values when running through the wizard (i.e, SkipCapture=NO) so that part is good.

    However, you would then think simply changing SkipCapture=YES would hide the wizard and use those values automatically but it doesn't, the task sequence just closes.

    Just to clarify, it's only one task sequence that is capturing, the others are deploying etc.

    Thursday, March 22, 2018 5:23 PM
  • I'm fairly clear that skipping some things differs from one to another.

    If you Skip the admin password, you will be prompted for one if the info is not supplied in the INI. But if you Skip something like Capture, it literally does skip the capture step.

    Therefore, earlier, when you chose Skip=NO it did prompt for info, but I think in your initial post, the syntax may have been wrong. I'm wondering if the BackupDir=%OSDComputername% was wrong. Either way, referencing the location and file name as it interprets it made the difference. I'm sure there is likely a better solution than this ;)

    Thursday, March 22, 2018 5:30 PM
  • I'm 99% sure skipping just skips the pages in the wizard but a value has to be supplied - I could be wrong though.

    However, I've figured it out now and it's arguably a better method.

    In the capture task sequence, if you add the 3 needed values as task sequence variables like this it works. You can set SkipCapture=YES in the rules and this does the rest.


    • Marked as answer by jim11212 Thursday, March 22, 2018 6:34 PM
    • Edited by jim11212 Thursday, March 22, 2018 6:46 PM
    Thursday, March 22, 2018 6:33 PM