locked
How to reference cdrom drive in autounattended.xml RRS feed

  • Question

  • I used the waik to create an answer file to install server 2008 r2. I create a custom data.wim file and copied to to the sources directory on the dvd and put the xml file on the root of the dvd. The problem is I have no way to reference the data.wim file in the xml file as setup assigns the cdrom letter based on what's available. I looked for a system variable to reference the cdrom but couldn't find one. On one server the dvd drive was D: and on another it was F:. If I leave the drive letter out it fails all together so how can I make this work? Putting the data.wim file on a network share is not a viable option so it needs ot stay on the dvd.

    DataImage wcm:action="add">
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>2</PartitionID>
                        </InstallTo>
                        <InstallFrom>
                            <Path>F:\sources\data.wim</Path>
                        </InstallFrom>
                        <Order>1</Order>
                    </DataImage>
                </ImageInstall>

    Monday, December 24, 2012 3:30 AM

Answers

  • You could use UseConfigurationSet option in the unattendfile (<UseConfigurationSet>true</UseConfigurationSet>) and then use the path below:

    <Path>%configsetroot%\sources\data.wim</Path>


    • Edited by Henrik_Dahl Thursday, January 3, 2013 11:46 PM
    • Marked as answer by Buck Taylor Sunday, January 6, 2013 9:05 PM
    Thursday, January 3, 2013 11:45 PM

All replies

  • Hi,

    Please check if this page could help:

    ModifyPartition


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Tuesday, December 25, 2012 7:27 AM
  • That won't really help as that's for modifying disk partitions and has nothing to do with the cdrom.
    Wednesday, December 26, 2012 5:21 PM
  • You could use UseConfigurationSet option in the unattendfile (<UseConfigurationSet>true</UseConfigurationSet>) and then use the path below:

    <Path>%configsetroot%\sources\data.wim</Path>


    • Edited by Henrik_Dahl Thursday, January 3, 2013 11:46 PM
    • Marked as answer by Buck Taylor Sunday, January 6, 2013 9:05 PM
    Thursday, January 3, 2013 11:45 PM
  • That was exactly what I was looking for. Thank you very much!
    Sunday, January 6, 2013 9:06 PM