none
Windows 10 Update Control RRS feed

  • Question

  • I'd like to know how to tell Windows 10 Update to NOT INSTALL WHEN THE COMPUTER IS BUSY.  I used to be able to do that, but now I can't find the setting.

    On two occasions now my weekly backups were interrupted and ruined by Window Update, and had to be repeated.  I have 5 rather large weekly backups (near terabyte volumes) which take several hours each, and when they're interrupted my production is delayed significantly.  I schedule them for Saturday nights and check them on Sunday.  When they're interrupted they have to be repeated which runs into Monday and delays production.

    While I like the Windows Updates to be automatic so that there's one less task for me to handle manually, but there should be some way, as there used to be, to stop them from installing during computer activity.


    Capt. Dinosaur

    Sunday, February 17, 2019 4:50 PM

Answers

  • Sorry, I forgot to post the policy path.

    We can press Win+ R key, then type gpedit.msc in Run, and click OK.

    Navigate to Computer Configuration\Administrative Templates\Windows Components\Windows Update

    Then enable Configure Automatic Updates policy and select 4 - Auto download and schedule the install.

    Enable No auto-restart with logged on users for scheduled automatic update installations.

    Regards

    David


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Capt. Dinosaur Sunday, February 24, 2019 2:43 PM
    Saturday, February 23, 2019 6:15 PM
    Moderator

All replies

  • You may set Active Hours in Windows Update setting and during the time when backup is running, set those times in Active Hours so update won't interfere.
    Sunday, February 17, 2019 6:44 PM
  • Thanks for your reply.  I've tried Active Hours but it doesn't work because it only allows a maximum of 18 hours.  One of the PC's - in fact the one that got blitzed by the update - has one backup that starts at 5:00 PM on Saturday, then another - over 12 hours (almost a TB of data) that starts at 10:00 PM on Saturday and normally doesn't end until after 12:00 Noon on Sunday, which is more than 18 hours.

    There used to be a way to tell Update to NOT RESTART automatically, but that doesn't seem to exist anymore.  If it does, I can't find it.


    Capt. Dinosaur

    Sunday, February 17, 2019 7:16 PM
  • Hi,

    You can set Configure Automatic Updates policy and select 4 - Auto download and schedule the install.

    Also, you can set No auto-restart with logged on users for scheduled automatic update installations.

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Saturday, February 23, 2019 1:32 PM
    Moderator
  • Thank you for your reply, David, your suggestions appear to be my answer.  My problem, however, is that the Group Policy settings are such an labrynth of confusion that I can never find what I'm looking for.  I'd be very grateful if you could you please tell me the routing to those so that I can set them up.

    Capt. Dinosaur

    Saturday, February 23, 2019 4:10 PM
  • Sorry, I forgot to post the policy path.

    We can press Win+ R key, then type gpedit.msc in Run, and click OK.

    Navigate to Computer Configuration\Administrative Templates\Windows Components\Windows Update

    Then enable Configure Automatic Updates policy and select 4 - Auto download and schedule the install.

    Enable No auto-restart with logged on users for scheduled automatic update installations.

    Regards

    David


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Capt. Dinosaur Sunday, February 24, 2019 2:43 PM
    Saturday, February 23, 2019 6:15 PM
    Moderator
  • Thanks David.  Went there, did that, feel better.

    Capt. Dinosaur

    Sunday, February 24, 2019 2:43 PM