locked
sharepoint 2010 SQL Database Connection Failed monitor not resolving RRS feed

  • General discussion

  • In the Sharepoint 2010 MP there's a monitor called SQL Database Connection Failed

    It's disabled by default, but that's beside the point. I enabled it, since it's important to know when your farm looses connection to sql databases. The problem is that even on next discovery it is not resolving to Healthy, even though the connection is fixed. Did anyone else encounter this issue?

    Saturday, May 25, 2013 3:50 AM

All replies

  • Hi,

    Please try the resolution “Create a new override for the connection string value on the SQL Database Connection Failed monitors”

    Configuring the SharePoint 2010 Management Pack for System Center Operations Manager

    http://support.microsoft.com/kb/2690744

    In addition, please refer to the configurations on the following post:

    SharePoint 2010 MP for OpsMgr - Test and Production Multiple DB Instance Tuning for Configuration Databases

    http://blogs.catapultsystems.com/jcowan/archive/2012/08/31/sharepoint-2010-mp-for-opsmgr-test-and-production-multiple-db-instance-tuning-for-configuration-databases.aspx

    Thanks.

    Nicholas Li
    TechNet Community Support

    Friday, May 31, 2013 4:30 AM
  • did you enable it by overriding the class?

    This monitor is a duplicate of monitoring already being done in the SQL MP so it is a bit redundant.


    Scott Moss MVP (Operations Manager) President - System Center Virtual Users Group |Vice President - Atlanta Southeast Management Users Group (ATL SMUG)
    Please remember to click “Mark as Answer” on the post that helps you!
    my new blog om2012.wordpress.com

    Sunday, June 2, 2013 8:34 PM
  • Thanks guys,

    Nicholas, one issue with the recommended approach is you have to do this manually for EACH database/SQL server, and manually manage it for any new or changed database names.

     

    Scott, which specific monitor do you mean in SQL MP that is based on connection string?

    Thanks again

    Tuesday, June 11, 2013 9:52 PM
  • Additionally, when trying to follow the

    http://support.microsoft.com/kb/2690744 instructions for overriding the monitor with a different conn string, such as below, I found that it always goes back to default string anyway, and doesn't "save" the override value.

    Provider=SQLOLEDB;Data Source=MySQL;Initial Catalog=MyDb;Integrated Security=SSPI;Enlist=False;Connect Timeout=15

    goes back to default:

    Provider=SQLOLEDB;$Target/Property[Type="Microsoft.SharePoint.Foundation.2010.SPDatabase"]/ConnectionString$

    Wednesday, June 12, 2013 11:48 AM
  • I was finally able to override the blasted monitor with the

    Provider=SQLOLEDB;Data Source=MySQL;Initial Catalog=MyDb;Integrated Security=SSPI;Enlist=False;Connect Timeout=30

    that still creates bogus alerts that do not close. The really evil thing is that unless you enable it on all databases, including Configuration and Content databases, these databases will NOT be monitored. But if you do enable, expect alerts for sure, even if SharePoint didn't really loose connection to the database. Looks like this monitor is the achilles heel of the whole Management Pack

    Saturday, June 15, 2013 12:55 PM
  • the SharePoint mp, does not recreate monitoring already being done by other management packs, like the IIS, and SQL MPs, which are requirements for the SharePoint MP.

    KaliBaba, I was trying to say, that the database monitoring for the SharePoint databases is being done by the SQL MP, even though the SharePoint mp has been loaded. If the SharePoint databases show up in the view under Microsoft SQL Server > Databases > Database State view, you should be good to go. Hope this helps.


    Scott Moss MVP (Operations Manager) President - System Center Virtual Users Group |Vice President - Atlanta Southeast Management Users Group (ATL SMUG)
    Please remember to click “Mark as Answer” on the post that helps you!
    my new blog om2012.wordpress.com

    Sunday, June 16, 2013 4:39 AM