locked
sharepoint 2010 user information list custom property RRS feed

  • Question

  • hi

    i added a custom property to the user list and wish to display it. when i go to "user info list" > "list settings" > "edit view" i see 39 properties to choose from. how can i remove these default values and add my own properties to the view.

     

    thanx

     

    Sunday, October 24, 2010 10:25 AM

Answers

  • The UserInformation list is populated by the User Profile Properties defined in the User Profile Sevice Application in Central Administration. Unfortunately, you cannot remove properties that have been replicated to each site collection's UserInformation list. However, you can go to "Manage User Profile Properties" edit your custom property and in the "Policy Settings" check the "replicable" property and it will be pushed to the UserInformation list so you can add it to your view.


    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    Monday, October 25, 2010 1:29 AM

All replies

  • The UserInformation list is populated by the User Profile Properties defined in the User Profile Sevice Application in Central Administration. Unfortunately, you cannot remove properties that have been replicated to each site collection's UserInformation list. However, you can go to "Manage User Profile Properties" edit your custom property and in the "Policy Settings" check the "replicable" property and it will be pushed to the UserInformation list so you can add it to your view.


    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    Monday, October 25, 2010 1:29 AM
  • Hi,

    Is it possible to replicate custom User Profile Properties to the User Information List as well?

    Christian Fredh

    http://www.christianfredh.com/blog

    Thursday, March 24, 2011 1:03 PM
  • yes. It is possible to replicate custom profile properties as well. It is the same as answered by Steve.
    Wednesday, May 11, 2011 8:56 PM
  • Hi

    i have done as you suggested and marked the field as replicable and confirmed this has been done, however the column is not available to select in the User Information List as a column. 

    im getting to the user information list via this URL http://MYSPSERVERNAME/_catalogs/users/simple.aspx and im modifying the view to add columns but the column i just set as replicable is not in the list. - in case you ask, the list is populating from the user profile service.


    Sergio Giusti

    Monday, February 20, 2012 12:28 PM
  • Sergio,

    Did you wait or run the User Informatopn List Sync Job definition.


    Regards, Bilal | SharePoint Specialist

    Monday, February 20, 2012 12:51 PM
  • Hi

    no i didnt wait, although i did check the job definitions and couldnt find one related to the user information list.


    Sergio Giusti

    Monday, February 20, 2012 1:04 PM
  • Try to run the following in "SharePoint 2010 Management Shell":

    $job = Get-SPTimerJob "User Profle Service Application_ProfSync"
    $job.RunNow()

    Wait a litte bit then check it


    Regards, Bilal | SharePoint Specialist

    Monday, February 20, 2012 1:04 PM
  • Hi that code comes back with an error of:

    You cannot call a method on a null-valued expression.
    At line:1 char:13
    + $job.RunNow <<<< <>
         + CategoryInfo                   : InvalidOperation: (RunNow:String) [], RuntimeExec
        eption
         +FullyQualifiedErrorId : InvokeMethodOnNull

    The job definition you listed is not also one of the job definitions i can see in my job definition list.


    Sergio Giusti

    Monday, February 20, 2012 1:12 PM
  • Hi

    it must have ran in another job (i ran them all) and its now populated in the list, thank you for your help.


    Sergio Giusti

    Monday, February 20, 2012 1:17 PM
  • Welcome :)

    Regards, Bilal

    Thursday, March 8, 2012 7:00 AM
  • I know this is an old thread, but I have the exact same problem -- I cannot get a mapped AD property that SHOWS UP in a given user's profile settings to show up in the SharePoint user list view available property columns.  I've tried just about everything I can think of, does anyone have any other suggestions as to how to FORCE SharePoint 2010 to "pick up" that new property column?
    Thursday, February 27, 2014 3:34 PM
  • I also have the exact same problem but the solution isn't working. Mapped AD property (userAccountControl) doesn't show up in "user information list" > "list settings" > "edit view". It shows up in UPS, values are OK. I set property as "replicable" of course, then ran full sync, full crawl, waited for a day...nothing. We have SharePoint 2010.
    • Edited by alesp2 Monday, May 9, 2016 8:32 PM
    Monday, May 9, 2016 8:31 PM