locked
SharePoint 2013 workflow missing inside SPD RRS feed

  • Question

  • Hi all,

    I have installed SharePoint 2013 on my VM using Offline Installation principles(donwloading binaries and prerequisties and powreshell. SharePoint works very well without any problem. I Installed WorkFlow Manager Refresh and Service Bus 1.1 using Web Platform installer (Offline). I installed and configured Workflow Manager client 1.0. However when I open a site inside SPD and try to create a List or Site Workflow, I cannot find SharePoint 2013 workflows. There is only SharePoint 2010 workflow in the dropdownlist. Ayn reason why there is no SharePoint 2013 workflow. Appreciate all kind of advice.

    Sunday, May 3, 2015 5:47 PM

Answers

  • Hi,

    When you install Workflow Manager on a server it automatically installs the Workflow Manager Client on that server. You will still need to install the Workflow Manager Client on any additional servers.

    Make sure there is a site binding for Workflow Management Site on port 12291.

    go onto the server where you have the workflow manager installed-> Open IIS and go to Sites and click Workflow Management Site-> click "Bindings..."->Then add one like this:

    1. type: HTTP
    2. IP address: All Unassigned
    3. Port: 12291
    4. Host name: [leave it blank]
    5. Click OK and restart IIS.

    For more detailed information, refer to the following article:

    https://technet.microsoft.com/en-us/library/jj658588.aspx?f=255&MSPPError=-2147217396#section5

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Eric Tao Monday, May 25, 2015 2:30 AM
    • Marked as answer by Eric Tao Wednesday, May 27, 2015 5:33 AM
    Monday, May 11, 2015 6:02 AM

All replies

  • When you say that you configured the Workflow client did you run Register-spworkflow in Powershell on the sharepoint server?  

    https://technet.microsoft.com/en-us/library/jj658588.aspx?f=255&MSPPError=-2147217396#section5



    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Monday, May 4, 2015 1:48 AM
  • Hi,
    Yes I have executed Register-SPWorkflow and run Workflow Manager Configuration wizard.
    Monday, May 4, 2015 6:53 PM
  • Hi,

    It seems the site collection was created using blank template, which doesn't include all necessary dependency features for creating workflows.

    To fix this you need to enable hidden feature WorkflowServiceStore using PowerShell.

    Enable-SPFeature -Identity WorkflowServiceStore –Url $yourUrl

    For more detail information, refer to the following blog:

    http://anujabhojani.blogspot.in/2013/06/the-option-for-sharepoint-2013-workflow.html

    If the issue still persist, refer to the following article about Install and configure workflow for SharePoint Server 2013 to check whether you lose some steps:

    https://technet.microsoft.com/en-us/library/jj658588.aspx?f=255&MSPPError=-2147217396

    https://technet.microsoft.com/en-us/library/dn201724.aspx

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, May 5, 2015 6:57 AM
  • Hi,

    No, The site collection created using Team Site and I have checked all necessary features are activated.

    But, I checked Workflow Management Site under IIS. Only https site has been created and there is no http site there. I don't know missing this http site has any impact.

    • Edited by Medes71 Tuesday, May 5, 2015 7:57 AM
    Tuesday, May 5, 2015 7:55 AM
  • Hi,

    When you install Workflow Manager on a server it automatically installs the Workflow Manager Client on that server. You will still need to install the Workflow Manager Client on any additional servers.

    Make sure there is a site binding for Workflow Management Site on port 12291.

    go onto the server where you have the workflow manager installed-> Open IIS and go to Sites and click Workflow Management Site-> click "Bindings..."->Then add one like this:

    1. type: HTTP
    2. IP address: All Unassigned
    3. Port: 12291
    4. Host name: [leave it blank]
    5. Click OK and restart IIS.

    For more detailed information, refer to the following article:

    https://technet.microsoft.com/en-us/library/jj658588.aspx?f=255&MSPPError=-2147217396#section5

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Eric Tao Monday, May 25, 2015 2:30 AM
    • Marked as answer by Eric Tao Wednesday, May 27, 2015 5:33 AM
    Monday, May 11, 2015 6:02 AM