locked
Database Dismounted - Possible Corruption - Need Urgent Help RRS feed

  • Question

  • Dear All,

    In my Ex 2010 SP1 (Server 2008 R2 Ent SP1) I have three database files for three user groups in three different offices. Today a user tries to import an old 4GB PSt file (with possible corruptions etc in it). Half way through the import fails. After this the relevant database with this user's account belonging to dismounts in the EMC, therefore all those users whose accounts are in this database have gone offline.

    I take two backups daily one at 13:00 and one 19:00 using Windows 2008 backup. The corruption happened shortly after the 13:00 backup, so I can restore this backup and restore the database file in question BUT I only backup the drive hosting the database files (The F drive) and NOT the C drive.

    Can I go ahead and restore the file, someone told me that I need the transaction logs which are normally on the C drive.

    Please advise as I need to resolve this before the morning when my suers come to the office.

    Many thanks in advance,

    Bina


    Bina Hejazi
    Monday, September 19, 2011 10:04 PM

All replies

  • Have you tried to remount the store?

     

    Monday, September 19, 2011 10:36 PM
  • Hi Andy,

    Thanks for your note.

    the Store service is running and the other two databased are mounted and up & running. why would I want to stop/restart the Store? (if I understood you correctly)

    Bina


    Bina Hejazi
    Monday, September 19, 2011 10:42 PM
  • Right now one store is dismounted yes? What happens if you try to mount it?

     

    Monday, September 19, 2011 10:57 PM
  • Andy,

    The Store never dismounted. I have RU5 installed. The thing is that I have 3 Databases. Only one is dismounted that I cannot Mount. do you think stopping/restarting the Store might resolve this. I just fear that once I stop the Store it may not start again and the other two running databased also go down.

    at the moment all messages destined for the users on the dismounted database are in the queue. none of my Exchange services are stopped.

    any suggestion?

    Thanks - Bina


    Bina Hejazi
    Monday, September 19, 2011 10:57 PM
  • Ok, I think is some confusion of terms here. You say the store never dismounted, then you say only one is dismounted.

    When you try to mount the one store that is dismounted, what happens? If it fails, what are the exact and full event log errors?

     

    Monday, September 19, 2011 10:59 PM
  • nothing, it tries and fails and shows dismounted again! I have done it several times!
    Bina Hejazi
    Monday, September 19, 2011 11:01 PM
  • And nothing in the event logs? That would be very unusual.

     

    Monday, September 19, 2011 11:02 PM
  • Andy, by Store Itake it U mean the Store service, I see what you mean now.

    The event log after it fails to mount is:

    Exchange Search Indexer failed to enable the Mailbox Database BH-Users (GUID = 3b25451f-19db-4ce1-8cb4-6a0e9cb62565) after 1 tries. The last failure was: MapiExceptionMdbOffline: Unable to get CI watermark (hr=0x80004005, ec=1142)

    Diagnostic context:

        Lid: 1494    ---- Remote Context Beg ----

        Lid: 44215  

        Lid: 60049   StoreEc: 0x8004010F

        Lid: 49469  

        Lid: 65341   StoreEc: 0x8004010F

        Lid: 56125  

        Lid: 47933   StoreEc: 0x8004010F

        Lid: 32829  

        Lid: 49213   StoreEc: 0x8004010F

        Lid: 48573  

        Lid: 64957   StoreEc: 0x8004010F

        Lid: 9518    StoreEc: 0x476     

        Lid: 1750    ---- Remote Context End ----

        Lid: 8434    StoreEc: 0x476     


    Bina Hejazi
    Monday, September 19, 2011 11:07 PM
  • Andy,

     

    for further info, I ran the eseutil.exe on the database (dismounted) and it came back with "Integrity check successful"

     

    Rgds,

    Bina


    Bina Hejazi
    Tuesday, September 20, 2011 1:31 AM
  • and you have enough disk space?

    My first thought if you cant mount the store is to bounce the server and try again, but I know you are hesitant to try that.

     

    Tuesday, September 20, 2011 11:05 AM