locked
Datasheet View disabled... RRS feed

  • Question

  • Hi Everyone,

    I created a site in sharepoint 2010. Here when I click on list and try to click on DataSheet View I am unable to click becuase it disabled(In Grey colour).

    Will anyone please tell me how to enable DataSheet view..........

    Your help is really great.

    Thanks,

    Krishna


    Krishnasandeep

    Friday, April 6, 2012 9:08 AM

Answers

  • Hi Krishna,

    The datasheet view requires the Access Web Datasheet activex component.

    This could be missing for a number of reasons:

    • You don't have Office installed
    • You have the 64-bit version of Office installed
    • You are a browser other than Internet Explorer

    You are testing this from a server, then you may not want to install Office on it. Instead you could install the Access Runtime: http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=10910

    Hope this helps!

    joel


    joel
    Joel's SharePoint Architect Blog
    joelblogs.co.uk
    Want SharePoint Training?

    Friday, April 6, 2012 9:15 AM
  • Also, verify that you are using the 32 bit version of Internet Explorer and not the 64 bit one.
    Friday, April 6, 2012 10:42 AM
  • In case you are still having troubles trying to work with the Datasheet view:

    We've created an alternative solution that doesn't require any ActiveX controls, thus works on any browser and also supports custom fields:

    http://www.kwizcom.com/sharepoint-add-ons/list-in-line-editor/overview/

    Cheers

    Nimrod Geva

    KWizCom

    Wednesday, April 11, 2012 10:10 PM

All replies

  • Hi Krishna,

    The datasheet view requires the Access Web Datasheet activex component.

    This could be missing for a number of reasons:

    • You don't have Office installed
    • You have the 64-bit version of Office installed
    • You are a browser other than Internet Explorer

    You are testing this from a server, then you may not want to install Office on it. Instead you could install the Access Runtime: http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=10910

    Hope this helps!

    joel


    joel
    Joel's SharePoint Architect Blog
    joelblogs.co.uk
    Want SharePoint Training?

    Friday, April 6, 2012 9:15 AM
  • I know two possible ways to solve it:


    Don't happy, be worry...

    Friday, April 6, 2012 10:23 AM
  • Also, verify that you are using the 32 bit version of Internet Explorer and not the 64 bit one.
    Friday, April 6, 2012 10:42 AM
  • In case you are still having troubles trying to work with the Datasheet view:

    We've created an alternative solution that doesn't require any ActiveX controls, thus works on any browser and also supports custom fields:

    http://www.kwizcom.com/sharepoint-add-ons/list-in-line-editor/overview/

    Cheers

    Nimrod Geva

    KWizCom

    Wednesday, April 11, 2012 10:10 PM
  • Go to List ->List Settings -> Advanced settings -> Enable the Datasheet (specify whether datasheet cant be used to bulk edit)

    • Proposed as answer by Sheetal Lomate Thursday, January 30, 2014 11:52 AM
    Wednesday, July 31, 2013 2:12 PM
  • Thank you Joshy, my saviour after several hours of pain :)
    Thursday, November 14, 2013 12:22 PM
  • This helps.

    Krishnasandeep

    Friday, November 15, 2013 7:10 AM
  • How do you correct the issue if you are using the 64-bit IE?

    Monday, June 1, 2015 8:43 PM
  • How can I correct the issue if I am using the 64-bit version of Internet Explorer?
    Wednesday, June 3, 2015 3:52 PM
  • You don't.  There is no 64-bit version of the ActiveX control.  Thus, Datasheet View will never work in any IE version of the 64-bit browser.
    Wednesday, February 17, 2016 11:58 PM
  • One of our users on Windows 7 with Office 2013 32-bit ran into this problem when we upgraded to IE 10 and IE 11.  For IE 10 in compatibility mode, it should have worked.  It did on my system and I verified that this user could enable datasheet view from my browser.  So I knew the issue was local to her system.  On her system under IE 10, we tried installing all of the access database readers and repaired Office & uninstalled/installed Access portion with no improvement.  The option remained grayed out.  In IE 11, which should have worked under Enterprise Mode, trying to enable the datasheet view produced the same error notice reported in other threads, basically stating that there wasn't a valid ActiveX control available.  After following all of the standard fixes found on Microsoft forums and TechNet, what worked for this user was setting up a new profile on the same computer.  Once this was completed, datasheet worked as expected under IE 10 Compatibility Mode and IE 11 Enterprise Mode. So it was likely a registry issue with the user's initial profile.  Go figure.  Luckily this has only happened to a handful of our users as we transitioned away from IE 8. This applied to SharePoint Foundation 2010 and WSS 3.0/SharePoint Server 2007.

    Sunday, February 21, 2016 10:08 PM
  • I tried creating a Datasheet View for the list and it worked for me.

    I had problem only with trial/test environment live/production was working fine for my case.


    Tuesday, September 20, 2016 10:33 AM