none
Authentication in IE but not Edge RRS feed

  • Question

  • I have several intranet sites on my Windows 10 machine.  The sites use integrated authentication to connect to SQL Server, and all of them work in IE, no login prompt.   In the event viewer Security log, I see a "Special Login" event, which shows that the event occurred with the NT Authority/System account.   In SQL Server Profiler I can see that my actual local user account is passed through to the database as expected.

    However, when I attempt to open the sites in Edge, it always prompts for a login, then waits a few seconds and returns this message:  

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Shared Memory Provider, error: 40 - Could not open a connection to SQL Server)

    When using Edge, the event viewer shows that a Special Login event occurred using my actual local account (instead of the System account),  My local account is a Sysadmin in SQL Server.

    What could be preventing Edge from connecting to SQL Server?

    Thursday, March 15, 2018 2:41 PM

All replies

  • Hi George,

    is this your personal computer? or are you using a domain network?

    If you are a developer/tester using localhost, you may need to turn on localhost loopback from the about:flags uri in Edge. In IE11 localhost will default to the Internet Zone. Use the File>Properties menu to confirm which IE security zone localhost is mapped to.

    Managed networks should be using Enterprise Site Mode Lists for backward compatibility with IE11 and GPO settings to control which web browser is used to open intranet sites... there is a GPO settings to "Use Internet Explorer for intranet sites". Edge does not use Security zones and Enterprise ActiveX controls will not run in it.

    From your description it sounds like you don't allow anonymous access in your IIS settings.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions.


    Rob^_^

    Friday, March 16, 2018 12:21 AM
  • Rob,

    Thanks. Yes, I'm on a Windows 10 machine.  Localhost loopback is turned on for Edge, and IE11 is set to the "Local intranet | Protected Mode: Off" Zone.  Anonymous access is turned off for these sites, which all work fine on my client's intranet.  These sites all worked for me here in Edge until a few weeks ago, when I started getting the login prompts.  In any case, the sites opens fine in Edge after I enter my login, it's just that the SQL connection isn't made.  I'm reviewing the group policy settings, but I suspect something else is happening...

    Thanks again. 
    FRed

    Friday, March 16, 2018 12:12 PM
  • usually, you set the SQL server instance (on the HOST) to use a SQL alias so you can use a custom port no. I/o 8080... your local SQL logs should be able to tell you more or (if developing with Visual Studio) you can turn on debugging to show the verbose error messages.

    Regards.


    Rob^_^

    Monday, March 19, 2018 1:20 AM