All software deployment packages fail in Task Sequence as 'disabled'


  • All of our Software deployment packages fail with the error disabled. Here is the error for smsts.log

    We've redistributed the packages, recreated packages, recreated task sequence to no avail. There are no errors site and component status.

    Failed to run the action: Error in the task sequence. The program is disabled. (Error: 87D01004; Source: CCM)    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)MP server Ports 80,443. CRL=false.    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Setting authenticator    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Set authenticator in transport    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Sending StatusMessage    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Setting message signatures.    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Setting the authenticator.    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)CLibSMSMessageWinHttpTransport::Send: URL:  CCM_POST /ccm_system/request    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Request was succesful.    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Set a global environment variable _SMSTSLastActionRetCode=-2016407548    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Set a global environment variable _SMSTSLastActionSucceeded=false    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Clear local default environment    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Let the parent group (Gather Logs and StateStore on Failure) decides whether to continue execution    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)The execution of the group (Gather Logs and StateStore on Failure) has failed and the execution has been aborted. An action failed.Operation aborted (Error: 80004004; Source: Windows)    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)Failed to run the last action: Error in the task sequence. Execution of task sequence failed.The program is disabled. (Error: 87D01004; Source: CCM)    TSManager    11/14/2013 5:41:26 AM    1544 (0x0608)

    Tuesday, November 19, 2013 3:36 PM


All replies

  • Have you checked the properties of the package? Is it disabled?

    Torsten Meringer |

    Tuesday, November 19, 2013 5:04 PM
  • Where exactly do i find this? I've searched all of the tabs on properties of the package and cannot find it.
    Tuesday, November 19, 2013 5:26 PM
  • Found it. It was enabled. i tried disabling it, then enabling it to see if that works. it did not work.
    Tuesday, November 19, 2013 6:11 PM
  • I found the link below which might help..........its worth a shot.!prettyPhoto

    Be kind and Mark as Answer if I helped.

    Tuesday, November 19, 2013 7:09 PM
  • Thanks for taking your time to help. I am in the process of trying this out. i'm testing it out. i think there is an issue with the configmgr client on the deployment as it doesnt have its cert or all of its actions etc. i'm also investigating this.
    Tuesday, November 19, 2013 9:20 PM
  • Chris,

    the following work around resolved my issue with the install software failing during TS. one difference between my sitch and the post is that i'm using pxe not stand alone media. I'm still trying to understand why it stopped working. Once i get some more information, i'll post again. i'll also be sure to mark your post as one of the answers.

    • Add the following Run Command Line step to the task sequence after the Setup Windows  and Configuration Manager step to enable the software distribution agent before  the first Install Package step runs:


    WMIC /namespace:\\root\ccm\policy\machine\requestedconfig path ccm_SoftwareDistributionClientConfig CREATE ComponentName="Enable SWDist", Enabled="true", LockSettings="TRUE", PolicySource="local", PolicyVersion="1.0", SiteSettingsKey="1" /NOINTERACTIVE

    Wednesday, November 20, 2013 2:29 PM
  • Glad it worked.  So as far as I can understand it has to do with the policies that come down for the client.  I assume the client gets installed before you run the software installs?  If so then something MIGHT be wrong with the client install and it probably shows as "unapproved" in CM Console which would explain why the client does not install software.  If you are able to access the "ExecMgr.log" you will probably see policy errors.

    That commandline forces the Software Distribution component and tells it to use the local policy instead of the CM policy which for a disallowed client would probably be False.  

    Be kind and Mark as Answer if I helped.

    Wednesday, November 20, 2013 2:48 PM
  • Here are two lines from logs, one from ccmsetup and the other from execmgr.log

    ccmsetup: Couldn't determine site version for site 'AFS'. Let client deployment continue.    ccmsetup    11/19/2013 2:59:20 PM    1856 (0x0740)

    xecmgr: Software Distribution site settings (CCM_SoftwareDistributionClientConfig) policy does not yet exist on the client.
    If the client is not yet registered, this is expected behavior.    execmgr    11/19/2013 3:03:20 PM    2540 (0x09EC)
    Can not find client site settings    execmgr    11/19/2013 3:03:20 PM    2540 (0x09EC)

    thanks again for your help!


    Wednesday, November 20, 2013 3:00 PM
  • From locationservices log:Failed to resolve 'SMS_SLP' from WINS    LocationServices    11/19/2013 4:01:52 PM    1280 (0x0500)
    LSGetLookupMP: Failed to resolve lookup MP from WINS with 87D00215. Check if it is published    LocationServices    11/19/2013 4:01:52 PM    1280 (0x0500)
    LSIsSiteCompatible : Failed to get Site Version from all directories    LocationServices    11/19/2013 4:01:52 PM    1280 (0x0500)
    Wednesday, November 20, 2013 3:54 PM