none
"http 404 not found" while accesing PWA outside of the server RRS feed

  • Question

  • I have setup a new SharePoint 2010 environment and installed Project Server 2010. Then I created PWA which is working fine when I access it from within the server but gives a "http 404 not found" while accessing PWA outside of the server. What can be the issues and possible resolution?
    Friday, August 19, 2011 1:25 PM

All replies

  • Hi Yousuf,

    How to you access PWA, via the server name or DNS Alias? Cna you access the central admin site outside of the server?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Friday, August 19, 2011 1:28 PM
    Moderator
  • Thanks for the prompt reply Paul.

    Yes, the Central Administration site and the top level site under web application that is hosting PWA is accessible outside the server. Only the problem is for the PWA...


    Friday, August 19, 2011 1:54 PM
  • Hi Yoursuf_Ali,

    it seems that the problem is related on Alternate Access Mapping.

    What do you think about this?

    If you connect on PWA using http://server.DOMAIN/PWA/ , do you get 404?

    I hope this can helps you,

    Best Regards

    Paolo O.

    Friday, August 19, 2011 9:46 PM
  • @Paolo - No its not related to AAM since I have another environment of similar nature and its working so fine.

    If you connect on PWA using http://server.DOMAIN/PWA/ , do you get 404

    Yes its still the same, I have already tried that.


    Friday, August 19, 2011 10:53 PM
  • Any clue guys?
    Friday, August 19, 2011 11:52 PM
  • I will troubleshoot like this. Consider the following

    Server Name: projectserver

    PWA URL in Alternate access mappings : (http://projectserver, http://projectserver.epm.com)

    From Client Box:

    -Since you are able to access the root site, suspecting that the connectivity is there.

    -Isolate whether the issue is due to Sharepoint or project, Try to access as below

    http://servername/pwa/_layouts/settings.aspx

    -Ensure the URL is confirued appropriately in Alternate access mappings

    -Create another site collection in the same web application and try to access


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Saturday, August 20, 2011 2:14 AM
    Moderator
  • Hi Sriram,

    Thanks for your input.

     

    On accessing

    http://servername/pwa/_layouts/settings.aspx

    I got an error;

     

     Error
    File Not Found.

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correlation ID: 96a5eee9-2ebd-488a-be2c-285b36d52f24

    Date and Time: 8/20/2011 3:24:45 PM

     Go back to site

     

    Any clue?

     

    Regards

     

    Saturday, August 20, 2011 1:27 PM
  • In this case, i suspect

    There is a firewall or reverse proxy which is restrcting the sites other then root.

    Did you create normal site collection in the same web? are you able to acces it?

    Or your WFE server doesn't have appropriate binaries.

    Ping your URL. Identify where it is going...Ping the same on the working server. compare both.Troubleshoot on that specific server.

     


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Monday, August 22, 2011 10:35 AM
    Moderator