locked
Outlook Anywhere - Did not find all required authentication methods RRS feed

  • Question

  • Hello,

    I currently have Exchange 2010 set up, with OWA/SSL, Activesync and MAPI working great.
    The issue we have, is when I try to use Outlook to connect to my Exchange server from outside using outlook anywhere I get the Authentication popupt and don´t let me to being able to connect to my Exchange server.
    using www.testexchangeconnectivity.com get error (Http Authentication Test failed)
    Did not find all required authentication methods
    Methods Found: Basic
    Methods Required: NTLM
    using the Powershell to configure the Authentication did not help.
    set-outlookanywhere -Name CASServer -ClientAuthenticationMethod NTLM

    My current setup has:
    1) One forest Windows 2008 R2
    2) 1 Exchange 2010 Rollup 1
    3) ISA 2006 SP2 for Publishing

    Any help is appreciated, Thanks!
    Sunday, January 24, 2010 9:16 PM

Answers

  • I believe u need to use basic auth for outlook anywhere clients on the internet
    • Marked as answer by tarnbg Monday, January 25, 2010 7:12 PM
    Sunday, January 24, 2010 10:48 PM

All replies

  • I believe u need to use basic auth for outlook anywhere clients on the internet
    • Marked as answer by tarnbg Monday, January 25, 2010 7:12 PM
    Sunday, January 24, 2010 10:48 PM
  • Did you have this working under Exchange 2007? or is this your first attempt at it?

    I documented how i got AutoDiscover to work with my Single Forest, single domain, single Exchange 2007 server behind an ISA 2006 SP2 firewall.

    http://itforme.wordpress.com/2009/11/10/discovering-autodiscover-in-exchange-2007/ 

    Sunday, January 24, 2010 11:33 PM
  • Thanks,

    it is working after reconfiguring the exchange 2010 server and ISA Server to use basic auth.
    in deed NTLM was required because we have about 100 users with outlook configured to use NTLM.
    i don´t know if there is any workaround for that?

    Regards.
    Monday, January 25, 2010 7:17 PM

  • tarnbg if u want to use both ntlm and basic auth then set both as allowed auth types on the exchange rpc virtual directory using IIS

    Navigate to:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeServiceHost\RpcHttpConfigurator\PeriodicPollingMinutes regkey. Set the value to 0 to turn off the RpcHttpConfigurator so that the auth settings on the directory don't get overwritten.

    http://msexchangeteam.com/archive/2008/06/20/449053.aspx for more info

    I don't know if this is supported my microsoft though..

    Monday, January 25, 2010 8:00 PM
  • Hi,

     

    I habe the same problem? Did you solved it ?

     

    Thx

    Monday, November 21, 2011 7:36 AM
  • Did anyone actually manage to fix this? This post is just 'noise' otherwise.

    P


    Regards Pete Long http://www.petenetlive.com

    Friday, October 2, 2015 9:34 AM
  • Got stung by this as well

    Not all the required authentication methods were found

    Pete


    Regards Pete Long http://www.petenetlive.com


    Wednesday, May 4, 2016 3:39 PM