none
Project Center keeps loading for new users RRS feed

  • Question

  • When our new users open the Project Center they are stuck on a page which says 'Project Center Loading'.

    My work around used to be log in as a delegate and switch to a different view. Unfortunately that's no longer working. New work around is to make them Site Collection Admin, ask them to open the Project Center and then it opens. After this I can remove the Site Collection Admin rights and it keeps working.

    Main question is who has seen this before and how can this be fixed?


    Thursday, April 18, 2019 9:30 AM

Answers

  • Hi,

    for new users, there is no "last view used". In this case, the default view "Summary" with GUID=63d3499e-df27-401c-af58-ebb9607beae8 is used. If you have changed this view to not be displayed to every user, this may lead to your issue. You can check this specific view by using ".../pwa/_layouts/15/pwa/Admin/ViewsAddMod.aspx?idViewUID=63d3499e-df27-401c-af58-ebb9607beae8". I hope you haven't deleted it but just changed in some way from new users (like removing some or all categories, …)

    Regards
    Barbara

    Thursday, April 18, 2019 10:40 AM
    Moderator

All replies

  • Hi,

    for new users, there is no "last view used". In this case, the default view "Summary" with GUID=63d3499e-df27-401c-af58-ebb9607beae8 is used. If you have changed this view to not be displayed to every user, this may lead to your issue. You can check this specific view by using ".../pwa/_layouts/15/pwa/Admin/ViewsAddMod.aspx?idViewUID=63d3499e-df27-401c-af58-ebb9607beae8". I hope you haven't deleted it but just changed in some way from new users (like removing some or all categories, …)

    Regards
    Barbara

    Thursday, April 18, 2019 10:40 AM
    Moderator
  • Hi,

    Thanks for the information! Really helpful :)

    It appears that the Summary View indeed has been removed unfortunately. Is there a way to fix this, or do we need to contact MS Support for this?

    Thanks, Sander


    • Edited by S.Bots Monday, May 6, 2019 7:50 AM
    Monday, May 6, 2019 7:50 AM
  • Hi,

    As far as I remember, recreating a view named "Summary" should help, even if the UID will be different. 


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    Monday, May 6, 2019 8:10 AM
    Moderator
  • Hi,

    sorry, I don't know how to recreate with this specific guid. And this GUID is hardcoded. If you use F12 in IE to open developer tools, you will find … "DefaultViewUid":{"value":"63d3499e-df27-401c-af58-ebb9607beae8" …

    So you have two options:

    Contact MS Support, what is quite easy using Project Online.

    Or ask someone not being a Site Collection administrator to open a different view in a delegate session as you did earlier. When you wrote "...that's no longer working...", I assume it worked for you when you not had been a Site Collection admin. For Site Collection admins, restrictions on views are not respecting delegate sessions.

    Or give Guillaume suggestion a try.

    Regards
    Barbara


    Monday, May 6, 2019 8:39 AM
    Moderator
  • Unfortunately this didn't help. I will now contact MS Support and see if they can fix this.

    Wednesday, June 26, 2019 7:34 AM