locked
Mail Merge in Word not working RRS feed

  • Question

  • Hi Guys,

    Sorry if I have posted this in the wrong section.

    Right here’s the issue. We are currently having issue where users are not seeing any results in the Mail Merge in Office Word when attempting to get data from Microsoft Access. There is data in the Access database and there are no passwords set on the databases.

    I have created a new user with the same settings and security groups and this user is able to query the database and get data from the database. There are no differences between the new account and the users having the issues.

    Does anyone have any idea what might be causing this issue?  

    • Moved by Santosh Bhandarkar Monday, March 18, 2013 3:40 PM Moved from Server General Forum
    Monday, March 18, 2013 11:53 AM

Answers

  • If the data sources are Access queries that uses wildcard and you are using the default connection method (OLE DB), the wildcards have to be the "ANSI" wildcards % and _ , rather than the "Jet" wildcards * and ?

    If that's the problem, workarounds include

     a. changing the connection type to DDE (not usually the best idea and more problematic if the data source is a .accdb rather than a .mdb

     b. modifying the database itself so that it recognises % and _ and modifying all the queries (not usually practical, and in later versions of Access I am not certain that it can even be done)

     c. duplicating all the queries that use wildcards and modifying the * and ? in the duplicates to % and _, then ensure that all new queries created for use by Mailmerge are also duplicated.



    Peter Jamieson

    • Marked as answer by Rex Zhang Thursday, April 4, 2013 7:56 AM
    Wednesday, March 20, 2013 5:02 PM

All replies

  • Hello,

    for Word please ask in http://support.microsoft.com/gp/gp_newsgroups_master?wa=wsignin1.0


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Monday, March 18, 2013 1:00 PM
  • Hi,

    Do you see any error message?

    Make sure you have followed steps here to mail merge:

    http://support.microsoft.com/kb/888697

    In the situation, I would suggest to restore the Word default settings for the user. You can refer to the following article:

    http://support.microsoft.com/kb/921541

    Best regards,


    Rex Zhang
    TechNet Community Support

    Tuesday, March 19, 2013 6:09 AM
  • If the data sources are Access queries that uses wildcard and you are using the default connection method (OLE DB), the wildcards have to be the "ANSI" wildcards % and _ , rather than the "Jet" wildcards * and ?

    If that's the problem, workarounds include

     a. changing the connection type to DDE (not usually the best idea and more problematic if the data source is a .accdb rather than a .mdb

     b. modifying the database itself so that it recognises % and _ and modifying all the queries (not usually practical, and in later versions of Access I am not certain that it can even be done)

     c. duplicating all the queries that use wildcards and modifying the * and ? in the duplicates to % and _, then ensure that all new queries created for use by Mailmerge are also duplicated.



    Peter Jamieson

    • Marked as answer by Rex Zhang Thursday, April 4, 2013 7:56 AM
    Wednesday, March 20, 2013 5:02 PM