none
Show Lookup table descriptions in Project Center views RRS feed

  • Question

  • Hey,

    I don't understand something about Project Server. We have a custom view in 2010 where we do a group by of projects based on a custom field that uses a lookup table. When viewing the list of projects, I only see a list grouped by the value, not the description. But apparently this behavior is not consistent, and rather on a per-user basis. Some see the description, others see the value of the lookup value.

    How can I make sure that everyone sees the description in the view on Project Center instead of the value ? Is this possible ?

    Thanks,
    Guy

    Friday, October 5, 2012 1:22 PM

All replies

  • Guy:

    Generally Project Server displays the description when one is present, otherwise it uses the value. Are you certai you've populated all of the descriptions?


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Saturday, October 6, 2012 6:26 PM
    Moderator
  • hey Gary,

    The iissue on this was already there on our 2007 nstallation, then we migrated to 2010, but now we still have the issue. Problem is that we don't have the issue in general, but apparently only for some users. I have no clue what is causing this, so any help is welcome. Although all descriptions for all values are there.

    Guy


    Sunday, October 7, 2012 4:35 AM
  • So this is a migrated problem... Is this tied to users or projects? If it's the latter you might try resetting the custom filed values for the projects in question. Change the values to something else, publish, then change back and publish. Frankly, I'm reaching here, but that's what I would try first. 

    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Monday, October 8, 2012 9:27 AM
    Moderator
  • hey Gary,

    Thanks for the advice, but no luck. I tried several things and checked with some end users today. It seems like the issue is there for everyone. This is what I tested :

    • add a new value and description, and apply it on a few projects.
    • change the text of some descriptions.
    • publish some project plans again.
    • add a few new projects
    • add a new lookup table and created a new view grouping projects on the new CF.

    Nothing helped so far. The CF itself has 2 levels, using characters (any), but only filled with numbers. But even when creating a new CF I have the same behavior. So it seems like a solution wide setting that is incorrect ? But frankly, no idea on where to look now. we just did a migration of 2007, and the database counts 150+ projects and 2000+ users. Republishing all projects is not a valid option :-)

    Monday, October 8, 2012 8:12 PM
  • Any further ideas ? I have no clue anymore where else to look.
    Monday, October 15, 2012 7:27 AM
  • Hello,

    I still have this issue where the IDs of lookup values are displayed in my Project Center sheet rather than displaying the descriptions. Any ideas someone ?

    Guy

    Friday, November 16, 2012 12:24 PM
  • Anyone also had this issue ? I still haven't been able to solve this one.
    Wednesday, December 5, 2012 10:31 PM