locked
Mailbox Time Zone issues RRS feed

  • Question

  • Hello ,

    I have installed a fresh exchange 2016 cu9 on server 2012. I have observeed that if i send mail to another mail box user,the time at which the mail was sent is different from the current time. For instance If i!  send the mail today,the time will be reading tomorrow.i have set the timezone for the mailbox user  but still no change. I have checked the system time and its the correct time zone.

    The time zone for my region is west central africa ,gmt +1 or Africa/lagos.

    How do i address this issue ?

    Collins

    Thursday, August 16, 2018 5:47 AM

Answers

  • Three factors affect Time in Microsoft Outlook:

    • The clock setting (time) of the computer.
    • The local time zone setting of the computer.
    • The daylight saving time adjustment setting of the computer.

    This problem might if your Time Zone not same as Exchange server, you can follow this article steps change Time Zone:

    http://office.microsoft.com/en-us/outlook-help/add-remove-or-change-time-zones-HP010356441.aspx?CTT=1

    1. Click the File tab.
    2. Click Options.
    3. Click Calendar.
    4. Under Time Zones, type a name for the current time zone in theLabel box.
    5. In the Time zone list, click the time zone that you want to use.
    6. If you want your computer clock to automatically adjust for daylight saving time (DST) changes, select the Adjust for daylight saving time check box. This option is available only in time zones that use daylight saving time (DST).

    Best regards

    Rafiul
     
    Forum Support
    -----------------------------------------------------------------------------------------
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Collinks2 Thursday, August 23, 2018 12:16 PM
    Thursday, August 16, 2018 6:22 AM
  • Hi Collinks2,

    For a new mailbox which doesn't set -TimeZone before, we should set -Language and -DateFormat for it at the same time, so, we should use command below:

    Set-MailboxRegionalConfiguration user -Language "en-US" -DateFormat "M/d/yyyy" -TimeZone "Pacific Standard Time" -TimeFormat "h:mm tt"

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, August 20, 2018 2:30 AM
  • Hi Collinks2

    You can import mailboxes that you want modify from a .CSV file, then modify properties for them, such as:

    $Mailboxes = Import-Csv c:\temp\1.csv
    foreach($Mailbox in $Mailboxes){
        Set-MailboxRegionalConfiguration $Mailbox.Name -Language "en-US" -DateFormat "M/d/yyyy" -TimeZone "Pacific Standard Time" -TimeFormat "h:mm tt"
    }

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Collinks2 Friday, August 24, 2018 10:44 AM
    Friday, August 24, 2018 1:23 AM
  • Hi Collinks2,

    The "c:\temp\1.csv" is location for my .CSV file.

    You should create a .CSV file like picture below, then script will only modify mailboxes which are in this file:

    You can also use command below to replace it, but it will modify all mailboxes:

    $Mailboxes = Get-Mailbox | where {$_.RecipientTypeDetails -eq "UserMailbox"}

    Regards, 

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Collinks2 Friday, August 24, 2018 10:44 AM
    Friday, August 24, 2018 7:37 AM

All replies

  • Three factors affect Time in Microsoft Outlook:

    • The clock setting (time) of the computer.
    • The local time zone setting of the computer.
    • The daylight saving time adjustment setting of the computer.

    This problem might if your Time Zone not same as Exchange server, you can follow this article steps change Time Zone:

    http://office.microsoft.com/en-us/outlook-help/add-remove-or-change-time-zones-HP010356441.aspx?CTT=1

    1. Click the File tab.
    2. Click Options.
    3. Click Calendar.
    4. Under Time Zones, type a name for the current time zone in theLabel box.
    5. In the Time zone list, click the time zone that you want to use.
    6. If you want your computer clock to automatically adjust for daylight saving time (DST) changes, select the Adjust for daylight saving time check box. This option is available only in time zones that use daylight saving time (DST).

    Best regards

    Rafiul
     
    Forum Support
    -----------------------------------------------------------------------------------------
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Collinks2 Thursday, August 23, 2018 12:16 PM
    Thursday, August 16, 2018 6:22 AM
  • Hello Rafiul,

    Thanks for your prompt response.Following your guidelines, i observed that my computer time was changing each time the server  restarted .In my country we usually use ,"west central africa  " as time  zone..so, if i set the time to be ,2pm ,Thursday 16th using the time zone as west central africa,it will change to 3pm ,friday 17th once the window time is restarted .

    So,i decied to change the time zone to Pacific time (us and canda ).This setting was done on the computer where exchange is installed .When i changed the  time zone of a user' mailbox ,the time synced .

    My colleagus are used to "west central africa time" as the time zone.is there anyway i can fix the timezone on the pc to be west Central africa time so that it does not change. If i am to use "the pacific time" zone ,is there an exchange shell command that can update the time zone for all the mailbox users ?

    Hope to read from you

    Thursday, August 16, 2018 8:57 PM
  • Hi Collinks2,

    You can use command below to modify time zone for all user mailboxes:

    Get-Mailbox | where {$_.RecipientTypeDetails -eq "UserMailbox"} | Set-MailboxRegionalConfiguration -TimeZone "Pacific Standard Time" -TimeFormat "h:mm tt"

    You can get an error like picture below, but it does not affect the modified results.

    You can use command below to check whether those mailboxes are modified successfully:

    Get-Mailbox | where {$_.RecipientTypeDetails -eq "UserMailbox"} | Get-MailboxRegionalConfiguration | fl Iden*,*Time*

    Regards, 

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, August 17, 2018 6:52 AM
  • Hello Kyle,
    Thanks for the update. The command is great! However ,i noticed that it didn't update the time zone for the new users who have not set their timezone for the first time,ie the users who have not signed into their mailbox for the first time.
    Is there a way we can set the time zone for the users who have not set their time zone for the first time?

    Saturday, August 18, 2018 7:43 AM
  • Hi Collinks2,

    For a new mailbox which doesn't set -TimeZone before, we should set -Language and -DateFormat for it at the same time, so, we should use command below:

    Set-MailboxRegionalConfiguration user -Language "en-US" -DateFormat "M/d/yyyy" -TimeZone "Pacific Standard Time" -TimeFormat "h:mm tt"

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, August 20, 2018 2:30 AM
  • Hi Kyle,

    Thanks for the update.I will try it and get back to you. Meanwhile there is another issue i am facing .I dont know if i should create another topic for it.it has to do with the "distribution group mail".

    I have created a distribution group mail known as " itsupport@local.com".i have associated individual email addresses to it. If  a mail is sent to itsupport@local.com,all members will recieve the mail. However, if a menber replies,his email address ,instead of the group email address will be seen by the recipient. I want to achieve a scenario whereby a member of the itsupport@local.com, sends mail ,the recipient will see the email "itsupport@local.com" as the sender's address and not the member's email address.. Can this be achieved in the exchange server 2016?

    Monday, August 20, 2018 6:03 AM
  • Hi Collinks2,

    Based on your description, I think this new issue isn't related with this thread's topic. In order to better solve your problem and to facilitate other users to search, I would suggest you reopen a new thread.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, August 20, 2018 6:16 AM
  • Hi Kyle,

    I have created it. This is the link https://social.technet.microsoft.com/Forums/office/en-US/cdbbfe41-57db-4228-9136-aff4fab66578/group-mail-address-using-distribution-group?forum=Exch2016MFSM

    Collins

    Monday, August 20, 2018 6:34 AM
  • Hi Collinks2,

    We have seen that post and will have an engineer to answer your question.

    By the way,  any update about this thread? If the above suggestion helps, please be free to mark it as answer for helping more people.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, August 20, 2018 6:47 AM
  • Hello Kyle,

    We are observing public holidays on tuesday and Wednesdays. I will try the above command on Thursday whrn i resumme work.if it works ,i mark it as the answer to this thread.


    Collins onyegbado

    Tuesday, August 21, 2018 5:11 PM
  • Hello Kyle,

    The above command did not update the time zone for new users. New users still have the option of selecting timezone which means they can select timezone different from the server time zone.

    The verification command did not also show the timezone for the new users

    I think i am missing something : the "user" in that command should be replaced with the acutall mailbox user.As soon as i changed it,problem got solved .

    I appreciate every one who contributed to this post.

    Microsoft would have enabled the option of ntp server during the installse of exchange server 2016

    Collins


    Collins onyegbado



    • Edited by Collinks2 Thursday, August 23, 2018 12:24 PM problem,resolved
    Thursday, August 23, 2018 11:53 AM
  • Hello Kyle,

    Is there anyway i can run the command for bulk users at the same time ? Ie setting the time zone and language for more than one new user at the same time

    Collins


    Collins onyegbado

    Thursday, August 23, 2018 2:07 PM
  • Hi Collinks2

    You can import mailboxes that you want modify from a .CSV file, then modify properties for them, such as:

    $Mailboxes = Import-Csv c:\temp\1.csv
    foreach($Mailbox in $Mailboxes){
        Set-MailboxRegionalConfiguration $Mailbox.Name -Language "en-US" -DateFormat "M/d/yyyy" -TimeZone "Pacific Standard Time" -TimeFormat "h:mm tt"
    }

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Collinks2 Friday, August 24, 2018 10:44 AM
    Friday, August 24, 2018 1:23 AM
  • Hello Kyle,

    Thank you for your understanding. Do you mean i should create a new .csv file for the mailboxes i want to set their timezone ? Or is there an existing csv file already in temp folder.

    What is the format if i want to create a new csv file ? Or is there an option to export mailboxes from the ECP Admin page ?

    Collins


    Collins onyegbado

    Friday, August 24, 2018 7:27 AM
  • Hi Collinks2,

    The "c:\temp\1.csv" is location for my .CSV file.

    You should create a .CSV file like picture below, then script will only modify mailboxes which are in this file:

    You can also use command below to replace it, but it will modify all mailboxes:

    $Mailboxes = Get-Mailbox | where {$_.RecipientTypeDetails -eq "UserMailbox"}

    Regards, 

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Collinks2 Friday, August 24, 2018 10:44 AM
    Friday, August 24, 2018 7:37 AM
  • Hello Kyle,

    Thank you for your quick response.it's understood now. The $mailbox.name  will reference the users in that csv file .

    I will try it and update you

    Collins


    Collins onyegbado

    Friday, August 24, 2018 7:44 AM
  • Good news! All the user mailboxes have been successfully set to pacific tine zone using the csv file and the cmdlet below

    $Mailboxes = Import-Csv c:\temp\1.csv foreach($Mailbox in $Mailboxes){ Set-MailboxRegionalConfiguration $Mailbox.Name -Language "en-US" -DateFormat "M/d/yyyy" -TimeZone "Pacific Standard Time" -TimeFormat "h:mm tt"}

    In addition,the computer time that hosts exchange was equallt set to pacific time zome.

    thank you so much for your help

    Collins


    Collins onyegbado

    Friday, August 24, 2018 10:50 AM