locked
SfB Hybrid - no incoming call on number RRS feed

  • Question

  • Hi!

    I've been working on setting up our on-premises Skype for Business 2015 server to work in hybrid mode with SfB-online. I've been able to set it up according to the description at https://blogs.technet.microsoft.com/nagshettykadwadi/2017/12/17/configuring-phone-system-cloud-pbx-and-on-premises-pstn-connectivity-for-skype-for-business-online/.

    Obviously all (IM, conference, call in/out) worked fine when my (test)account was hosted on-premises, but now that it's moved to Online, most of the functionality works as expected, but I only have one strange issue.

    I can make phone calls (through on-premises PSTN) out, both to colleagues and to PSTN-numbers, but can't receive incoming calls. To be more precise, I can receive phone calls when they are "Skype calls", but can't receive calls that are directed to my (external) phone number.

    As you can see in below log, when my colleague (Jan) calls me on my Skype-address, the call is, as expected, redirected to sipfed.online.lync.com through edge:

    

    But when he dials my phone number (or extension) instead, the skype-server doesn't seem to know where to direct it:


    Why does our Skype on-premises server not translate the number to my name and forwards it to Skype Online. When my account was still on-premises, I could be reached both by skype-call and by number-call.

    I'm expecting it to be some minor setting that I'm missing, but I seem unable to find out what...

    Any help is very much appreciated!

    Thanks and kind regards,

    Peter


    Wednesday, November 27, 2019 10:31 AM

All replies

  • Hello,

    Your Edge server can resolve and acces correctly the sipfed.online.lync.com ?

    Olivier

    Wednesday, November 27, 2019 10:35 AM
  • Hi Olivier,

    Thanks for your reply. Yes, the edge server can resolve sipfed.online.lync.com. Also, my phone does ring (and it's routed through edge-server / SfB Online) when I'm called by skype-name (emailaddress); it's just that I can't be called when my phone-number is used.


    Kind Regards,

    Petr

    Wednesday, November 27, 2019 10:43 AM
  • Hi,

    Could you test a telnet to port 443 to sipfed?

    and put here (without personnal data) : Get-CsVoiceRoutingPolicy -identity yourroutingpolicy |fl

    and check with online skype for business if
    Get-CsOnlineUser testuser if  EnterpriseVoiceEnabled $True –HostedVoicemail $True

    Olivier

    Wednesday, November 27, 2019 11:00 AM
  • Hi Olivier,

    Thanks again! Here are the screenshots:

    On Edge-server:

    On-Premises:

    And SfB-Online:

    Kind Regards,

    Peter

    Wednesday, November 27, 2019 11:30 AM
  • Hi Peter,

    Do all users have the same problem?

    In my research, some scenarios don’t support PSTN connectivity. The supportability matrix is as below:

    For more details, please refer to:

    https://docs.microsoft.com/en-us/microsoftteams/direct-routing-user-accounts-in-a-hybrid-environment


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, November 28, 2019 6:46 AM
  • Hi Sharon,

    Thanks for your reply. Currently I only moved 1 user from on-premises to Online.

    According to the table above, it looks like our setup should be supported (no 2); the strange thing is that people can call me well, as long as they use my email-address instead of my phone number. The on-premises server seems to be unable to convert my sip:+3xxxxx13 number to sip:peter.schouten@xxxxx.xxx. If it would do that, I would receive the call.

    Kind Regards,

    Peter Schouten

    Thursday, November 28, 2019 12:25 PM
  • Hi Peter,

    I think that you can check the attributes when you synchronized from on-premises to Azure.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.



    Tuesday, December 3, 2019 9:52 AM
  • Hi Peter,

    Is there any update on this case?

    Please feel free to drop us a note if there is any update.

    Have a nice day!


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Wednesday, December 11, 2019 9:21 AM
  • Hi Sharon,

    I think you've been replying in the wrong thread, there's no "Ted Curly" here, but with regards to my original post, no I haven't been able to ever get this working, so something may be incorrectly configured on the on-premises server and it doesn't understand that phone calls directed to my number need to go to me...

    Kind regards,

    Peter

    Wednesday, December 11, 2019 9:25 AM
  • Hi Peter,

    I’m so sorry that I made a mistake.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, December 11, 2019 9:34 AM
  • Haha, no problem at all :)
    Wednesday, December 11, 2019 9:57 AM
  • Hi Peter,

    Do you use Skype for Business Cloud Connector Edition?

    In my research, there is a known issue about incoming call fails when using Skype for Business Cloud Connector Edition.

    For more details, please refer to:

    https://docs.microsoft.com/en-us/skypeforbusiness/troubleshoot/hybrid-phone-system/incoming-call-fails-cloud-connector


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, December 16, 2019 9:22 AM
  • Hi Sharon,

    No, we are using Skype for Business 2015 on premises.

    Kind regards,

    Peter

    Monday, December 16, 2019 9:30 AM
  • Hi Peter,

    Do you try to create a new account in Skype for Business Online and have a try?


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, December 19, 2019 10:29 AM
  • Hi Peter,

    Do you have any further issue on this topic?

    Meanwhile, if there is no issue, please remember to mark helpful reply as answer to close the thread. Your action would be helpful to other users who encounter the same issue and read this thread.

    Thanks for your understanding.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, December 24, 2019 1:51 AM