none
IPAM not showing utilized adresses from excluded DHCP ranges RRS feed

  • Question

  • Hi,

    I'm trying to import my network into IPAM.

    My DHCP is configured to serve 192.168.0.0/24 where 192.168.0.1-10 are excluded from DHCP. For the excluded range I defined reservations to deliver those IPs to servers. So the "wild" DHCP range starts with .11 - now I connected IPAM to the DHCP. The network is imported and also all servers. Thats fine so far. But the Servers defined in the excluded range are not assigned to the network in IPAM. How can I change that? 

    Friday, January 4, 2019 3:42 PM

All replies

  • Hi,

     

    Creating exclusion ranges prevents the DHCP server from assigning a client lease with any address in the exclusion range, thereby protecting it for use as a static IP address.

    Reservations, however, are used to create a permanent IP address lease assignment by the DHCP server.

     

    Although reservations can still be created using IP addresses within an exclusion range, this may cause issues.

     

    IPAM is the administration of DNS and DHCP, while DHCP is actually not responsible for IP addresses in the exclusion range. I suppose that's why the Servers defined in the excluded range are not assigned to the network in IPAM.

    If you would like the servers to have their specific IP addresses, there is no need to create an exclusion range. You may try deleting the range from the address pool and let reservations do the job.

     

    For your reference:

    Exclusion Ranges

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2003/cc784700(v%3dws.10)

    Reservations

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2003/cc737055(v%3dws.10)

     

    Regards,

    Zoe


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.




    Monday, January 7, 2019 7:05 AM
  • Hi,

     

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

     

    Best Regards,

    Zoe


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 9, 2019 6:16 AM
  • Hi Zoe,

    thanks for the information. 

    The provided information doesn't fix my problem. I hoped there is some switch or registry setting that just gets me the importet IPs assigned to the networks. IMHO IPAM shouldn't care if a range is enabled or not. It gets an IP from DHCP and should just assign it to a network. 

    I also did some more research and it seems the Windows IPAM is just to fixed in its workflows to use in real environment. 

    Regards,

    Marcel

    Wednesday, January 9, 2019 10:26 AM
  • Hi,

    The exclusion range is configured when some network devices need a static IP addresses rather than addresses assigned through DHCP. The IP addresses within the exclusion range is not supposed to be managed by DHCP, which means your DHCP server actually believes that it serves the range 192.168.0.11-192.168.0.254.

    If you would like DHCP to manage all the IP addresses you should not configure an exclusion range. All you have to do is simply defining reservations in the range 192.168.0.0/24. DHCP server will make sure that the reserved IP addresses are assigned to the specified clients.

    Regards,

    Zoe


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.




    Thursday, January 10, 2019 2:45 AM
  • Hi Zoe,

    but then I could get "wild" clients in between. 

    I add static leases to my dhcp and don't want some developer deploying somethin in between. This was the logical solution for me. 

    I also tried to remove the exclusion and set dhcp range from .11 to .254 but the same problem with ipam. With that configuration the network even shows as .11 to .254 which is even more bad. 

    I currently thinking of dropping ipam as it's not working as I want. 

    If there is a possible solution to get it working like (I think ;) ) it should, I would be more than happy to hear it.


    Regards

    Marcel

    Thursday, January 10, 2019 3:03 PM
  • Hi Marcel,

    If you would like DHCP to take charge of the IP addresses you can never put them in an exclusion range.

    If you would like a specific client to have a specific IP address, you can configure reservations within the DHCP range. The reserved IP addresses will never be assigned to "wild" clients.

    Reserved IP addresses are managed by DHCP but excluded IP addresses (static addresses) are not.

    Please follow the instructions below:

    1. Remove the exclusion range

    2. Set DHCP range from 192.168.0.1-192.168.0.254

    3. Define reservations to deliver 192.168.0.1-192.168.0.10 to your servers

    Regards,

    Zoe


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, January 11, 2019 2:32 AM
  • Hi,

     

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

     

    Best Regards,

    Zoe


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 14, 2019 2:07 AM
  • No, I will drop Windows IPAM and use a third party tool. 

    Anyway, thanks for trying to help.

    Regards

    Marcel

    • Edited by de.Marcel Monday, January 14, 2019 8:34 AM
    Monday, January 14, 2019 8:34 AM
  • Hi,

     

    If there is anything else we can do for you, please feel free to post in the forum.

     

    Regards,

    Zoe


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 14, 2019 8:44 AM