none
Coping iso file and mounting problem RRS feed

  • Question

  • Hi

    I am using Windows 8.1 Update Enterprise 64 bit and Windows ADK.

    I noticed that, if I select the "Environment of the deployment tools and creations images" and I click on the "Run as Administrator" item of his Pop-Up menu and I mount on a iso image of windows 8.1 Update, when I run the command

    robocopy <Drive_Letter>:\"<Windows_Files_Path>" /e

    to copy all its files in a directory and the command

    dism /Mount-Image /ImageFile:"<Windows_Files_Path>"\install.wim /Index:<Image_Index> /MountDir:"<Mount_Directory_Path>"

    to mount an image volume, this error appears:

    Error: 0xc1510111
    
    Not have permission to mount and modify this image.

    However, if I copy these files through the "file explorer" window, the mounting of this volume image is working properly. How come?

    Thanks

    Bye


    Balubeto

    Monday, September 22, 2014 5:55 PM

All replies

  • Hi

    If you open an elevated command prompt does it still give you that error?


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, September 22, 2014 6:01 PM
  • Try to use the /COPYALL switch.

    By default robocopy will not care about ACL, ownership and auditing info.

    The /SEC switch should be enough already, as it adds the ACL, so /COPYALL might be a bit overkill :)

    • Proposed as answer by oriooff Tuesday, September 23, 2014 5:02 PM
    • Edited by oriooff Thursday, September 25, 2014 9:57 PM
    Monday, September 22, 2014 6:32 PM
  • I tried the COPYALL and SEC switchs but the mounting command still does not work. How come?

    Thanks

    Bye


    Balubeto

    Tuesday, September 23, 2014 7:31 AM
  • I am unable to reproduce the issue above:

    E:\>dism /mount-image /imagefile:e:\release\Captures.001\Win2008R2Sp1.wim /index:1 /mountdir:c:\mount
    
    Deployment Image Servicing and Management tool
    Version: 6.3.9600.17031
    
    Mounting image
    [==========================100.0%==========================]
    The operation completed successfully.
    
    E:\>robocopy e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT e:\mount\test zti*.log /njh /ndl
    
    100%        New File              226728        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIApplications.log
    100%        New File                1228        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIApplyGPOPack.log
    100%        New File               10283        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIAppVerify.log
    100%        New File               29169        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIBackup.log
    100%        New File                2101        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIBDE.log
    100%        New File               36103        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIConfigure.log
    100%        New File               34934        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIDiskpart.log
    100%        New File                1027        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIDomainJoin.log
    100%        New File               41428        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIDrivers.log
    100%        New File               93591        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIGather.log
    100%        New File                2619        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIGroups.log
    100%        New File                2898        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTINextPhase.log
    100%        New File                3875        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIOSRole.log
    100%        New File                 740        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIOSRolePS.log
    100%        New File                2350        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIPatches.log
    100%        New File                4180        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ztiRunCommandHidden.log
    100%        New File                1215        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTITatoo.log
    100%        New File                1855        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIValidate.log
    100%        New File              190933        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIWindowsUpdate.log
    100%        New File                1436        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIWinRE.log
    100%        New File               40631        e:\release\Captures.001\Create\WIN2008R2SP1\MININT-E5LVCNT\ZTIYellowBang.log
    
    ------------------------------------------------------------------------------
    
                   Total    Copied   Skipped  Mismatch    FAILED    Extras
        Dirs :         1         0         0         0         0         0
       Files :        21        21         0         0         0         0
       Bytes :   712.2 k   712.2 k         0         0         0         0
       Times :   0:00:00   0:00:00                       0:00:00   0:00:00
    
    
       Speed :             5209457 Bytes/sec.
       Speed :             298.087 MegaBytes/min.
       Ended : Tuesday, September 23, 2014 11:13:46 AM
    
    
    E:\>dism /unmount-wim /mountdir:c:\mount /commit
    
    Deployment Image Servicing and Management tool
    Version: 6.3.9600.17031
    
    Image File : e:\release\Captures.001\Win2008R2Sp1.wim
    Image Index : 1
    Saving image
    [==========================100.0%==========================]
    Unmounting image
    [==========================100.0%==========================]
    The operation completed successfully.

    Additionally I can see that the original question asked was copied from this post 2 years ago:

    http://www.eightforums.com/installation-setup/54246-coping-iso-file-mounting-problem.html

    is this really your problem?

    Really, this is not a MDT related question. perhaps a general Windows Setup forum would be a better place to ask this question.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Tuesday, September 23, 2014 6:20 PM
    Moderator
  • I wrote to the forum mentioned above.

    Thanks

    Bye


    Balubeto

    Wednesday, September 24, 2014 7:35 AM