locked
Sharepoint 2010 usage reporting on a doc library RRS feed

  • Question

  • I have a user that is showing me reports she made when we were on Sharepoint 2007 - Site usage reports. They are reporting on how many times a record in a library was viewed. She is trying to determine if reports they are posting are really being looked at or is it a waste of time to put them up in Sharepoint.

    We have upgraded to 2010 and the Web Analytic reports are only showing statistics on site and page hits. I cannot find a way to reproduce what she had before. Please let me know if I am missing something.

    Thanks

    Monday, December 12, 2011 9:47 PM

Answers

All replies

  • You can get this information using the auditing capabilities of SharePoint. The following link explains how to set it up and us it:

    http://www.edugeek.net/forums/virtual-learning-platforms/58236-sharepoint-2010-auditing.html


    Kind regards,
    Margriet Bruggeman

    Lois & Clark IT Services
    web site: http://www.loisandclark.eu
    blog: http://www.sharepointdragons.com

    • Proposed as answer by Margriet Bruggeman Tuesday, December 13, 2011 6:03 AM
    • Marked as answer by Wayne Fan Wednesday, December 21, 2011 6:45 AM
    Tuesday, December 13, 2011 6:03 AM
  • Margriet,

    Thank you so much for replying. I am following these steps and it looks like I am getting the reporting I wanted. I really appreciate your help. Merry Christmas

    Tuesday, December 13, 2011 5:47 PM
  • One thing is baffling me here. I have one of the items in a doc library with Event View=5.

    All I do is open the doc in Read only mode and close it back. Then I rerun the audit log reports with custom reports option with the only event I am including is "Opening or downloading documents, viewing items in lists, or viewing item properties ". The number jumps from 5 to 8. It seems like it should just add 1 for because I am just one user reading the doc and closing it back. Will these numbers be misleading? I went back into Site collection audit settings and only picked specify event to audit as "Opening or downloading documents, viewing items in lists, or viewing item properties " - same setting as when I run customer reports.

    I also tried using Content Viewing as a report instead of the Custom reports option but the same thing happens there - I read a doc and it adds 3 everytime.

    Thanks so much for any help.

     

    Tuesday, December 13, 2011 8:51 PM
  • Hi starz_bsi,

    If you have any new question, i suggest you create new thread in the forum. thanks for your understanding.


    Wayne Fan

    TechNet Community Support

    Wednesday, December 21, 2011 6:46 AM