none
Virtual XP Won't Start RRS feed

  • Question

  • I have successfully completed the installations of Windows Virtual PC and Virtual Windows XP. However, on startup on XP it goes into a loop of "initializing the virtual machine" and "starting operating system." Once it hits the "starting operating system" it jumps back to the beginning of the initialization process. I watched it do this for about 30 mins and then I went to lunch and just let it run. When I returned, there was a message saying something like "could not enable integration features." I clicked through to continue without them but XP will not start. It just keeps coming back to the operating system list where I can choose to start normally or use last known configuration, etc.

    I did run the Intel Processor Identification Utility and my processor supports IVT. What else should I try?

    Please let me know if you need more information. Thanks!
    Friday, May 1, 2009 6:06 PM

Answers

  • Hi Joe,
    We have come across various names for DEP setting in BIOS. It can be called as Execute Disable, XD, NX etc. Check for these and please enable it if this is disabled. Let us know if you could boot a VM after turning this setting on.
    Also you can run some tools like securable and check if the DEP is ON or OFF. Let us know your DEP setting.

    Thanks,
    Vikas
    Wednesday, May 13, 2009 2:57 PM

All replies

  • Joe,

    Regarding Virtual Windows XP I assume you went through the setup wizard asking you to make a password, WU settings etc. and after that you saw the behavior described.

    - Can try starting Virtual Windows XP again and after it fails share the logs at %temp%, the files starting with VPC_UI_TRACe*.txt.
    - In Windows Event Viewer, navigate to Applications and Service Logs->Microsoft->Windows->Virtual PC->Admin and around the time of failure see if any error/warning is logged.

    Regards,

    Gaurav
    Friday, May 1, 2009 7:11 PM
    Moderator
  • As log states VM is getting into triple fault and resetting. We need to find what is causing this.
    1. Open settings and clear "Enable at startup" for "Integration features"
    2. Start the VM

    See at which stage machine is resetting, may be it will give us some idea.
    Thanks,
    -Vinod


    Thanks, -Vinod -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Saturday, May 2, 2009 7:25 AM
    Moderator
  • I probably sound like an idiot here but I am unable to clear the "Enable at startup" checkbox. It is always disabled.
    Saturday, May 2, 2009 3:04 PM
  • What's your virtual machine's state? Stopped or something else?
    Saturday, May 2, 2009 3:24 PM
    Moderator
  • Hi Joe,

    In the settings page -> Integration Features -> right pane->bottom , do you see the message that Virtual PC integration features should be installed to enable these settings.

    Thanks
    Vrijesh

    Cheers
    Saturday, May 2, 2009 4:24 PM
    Moderator
  • The virtual machine is either running or hibernating because of the loop that it gets in. When I close the window it goes into hibernating. If I open it back up it just starts the loop again and there is no way to power it down.

    Yes, there is a message at the bottom of the pane about integration features needing to be installed.
    Saturday, May 2, 2009 6:39 PM
  • Can you please press Shift+Esc when you see starting up dialog? This should take you to integration-feature disabled mode and you can see the VM desktop.


    Thanks, -Vinod -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Saturday, May 2, 2009 8:54 PM
    Moderator
  • I had a similar situation with a Windows 2000 VM.
    I ensured that the VM was Turned Off
    I deleted the .vcmx file for the Windows 2000 VM (Click on Start....All Programs...Windows Virtual PC...Virtual Machines)
    I clicked on the Create A Virtual Machine link (just above the Name column)
    And created a new VM, pointing it at the .vhd file when it asked for it.
    The Win2K VM now works perfectly.

    Had similar issues with a Vista VM, but terminated it before I could get all the error messages.
    Used the procedure above and it works fine - but it can't install a VPCBus (a device in Device Manager).

    Windows Server 2003 R2 VM works well this way also and also cannot find the VPCBus.
    All the VM's were copied from my Win7 Beta1 system where they worked fine.
    - John
    Sunday, May 3, 2009 12:59 AM
    Answerer
  • Vinod, I tried pressing Shift + Esc and that allowed me to see the VM desktop as it was trying to start up. I would see the Windows logo and then it would reboot.

    Usasma, I tried what you said which allowed me view the settings of the virtual machine while it was powered down but I still had no luck starting it up or even disabling the integration features.

    One thing that did work for me was creating a virtual machine from scratch and installing XP from the CD. I was able to complete the installation and it seems to run fine. Although, I'm not entirely convinced everything is right because none of the integration features seem to work. I installed the integration components from inside the VM but I can't view any host folders or share the clipboard, etc.

    Sunday, May 3, 2009 3:30 AM
  • Did you install XP SP3 Pro as a guest? IC only supported on XP with SP3.
    Sunday, May 3, 2009 10:37 AM
    Moderator
  • I'm having issues with the integration components in my Vista SP2 VM.

    It won't install because these 2 processes are running:
    vmusrvc.exe
    explorer.exe (interestingly explorer.exe doesn't respawn on it's own)

    I killed them both, then ran setup.exe from the CD drive and get the message that setup was interrupted.
    Can't locate any events that seem to relate to it in Event Viewer.

    Gonna have to try a fresh VM w/Vista SP1 to see if that's the issue.
    - John
    Sunday, May 3, 2009 1:31 PM
    Answerer
  • John,

    Are you installing integration components on top of the VM which has no previous integration components or VM additions from VPC 2007?

    After the setup failure for integration components there will be an install log called VPCICInstallLog.txt that would have got created under %temp% in the VM. Can you share that with us?

    Gaurav
    Sunday, May 3, 2009 2:14 PM
    Moderator
  • FlowMaN, I only had an XP disc with SP2 on it. After I set that up, I downloaded and installed SP3 before installing the integration components.
    Sunday, May 3, 2009 4:26 PM
  • Thanks Gaurav!  I'm not trying to detract from the original poster's efforts here.  Just trying to add additional information that may help them get their VM running.  FYI - I copied my VHD's from VPC07 and am using them in the new Virtual PC in Win7, so the problems may not be the same.  FWIW - my VM's work fine for my purposes - and the XP VM that came with the install works without problems.

    I can't upload the logfile, it's too big.  If you don't think it's relevant to Joe Kanner's issues I won't post it.


    - John
    Sunday, May 3, 2009 8:19 PM
    Answerer
  • I am having the same exact problem as mentioned in the thread.  I installed the new Virtual PC on Windows 7 Ultimate RC and downloaded the exe for Windows XP Mode.  I tried to create the VM but had the same exact looping problem.  It would never get to a VM (and I let it go for like 8 hours!!!).  Then I tried to create a custom VM with Windows XP Pro with SP3.  The install was perfect until I installed the Integrated Components.  It then gets to the Windows XP boot screen and goes into a constant loop.  It never has a chance to enable the components because the OS never loads.  Safe Mode works ok though.

    I did find an update patch on MSDN (KB961742-v3)  I reinstalled XP and put this patch on first before the integrated components.  After I installed the components, it took a little longer to boot, but still looped before ever getting to ths OS.  My event log on the host machine also talks about a fatal processor error.  I have been at this for a few days now and haven't got any farther than that.  Any help would be appreciated.  I am running an Intel i7 920, 6GB DDR3 RAM, Windows 7 Ultimate x64 RC.  Thanks!!
    Sunday, May 3, 2009 10:49 PM
  • I'm also running an i7 processor. Here are my specs:
    i7 CPU 965 @ 3.20GHz
    12.0 GB RAM
    Windows 7 Ultimate x64 RC
    Monday, May 4, 2009 1:02 AM
  • I'm having the same looping problem with the installation of Virtual Windows XP. I'm also running a i7 processor and win7 x64 RC.
    Tuesday, May 5, 2009 5:19 PM
  • It seems to me that Windows VPC has compatibility issues with i7 processors, I'll try to escalate.
    Tuesday, May 5, 2009 5:46 PM
    Moderator
  • someone want to explain to me virtual windows xp please? i went to the web site but i am still confused
    I downloaded and installed windows 7 1so on virtual pc 2007 sp1.  Vista home preimium is the host and windows 7 is the guest (i had windows 7 beta this way and had no problems)

    Since i am on virtual pc 2007 sp1 is it possible inside windows 7 rc to install the virtual xp ?  is this a full copy of xp pro sp3? or do you have to go get a copy of xp pro sp3?
    Do you need to install virtual pc beta first then download and install virtual xp mode?
    I also thought that in the rc it would be included because it says in final it will be so i am totally lost.

    robin


    Tuesday, May 5, 2009 11:10 PM
  • Thanks FlowMaN. I appreciate your time on this.
    Wednesday, May 6, 2009 1:09 AM
  • Hi Joe

    We have recieved this feedback; and are looking into it. Thanks for your time.

    Nitin
    Wednesday, May 6, 2009 1:54 PM
    Moderator
  • Hi Joe

    Can you help us with the logs ?

    Please set the traces on (as below), repro this issue, and send us %temp%\VPC_* files from the host machine .

    Run the following from elevated CMD
    setx VPC_OUTPUT_LEVEL 15 /M

    setx VPC_TRACE_LEVEL 15 /M

    Repro the issue again and send the %temp%\VPC_* files from the host machine

    Thanks
    Nitin

    Wednesday, May 6, 2009 5:15 PM
    Moderator
  • CPU: Intel İ920

    Same problem here too, virtual xp wont start :(
    Thursday, May 7, 2009 8:31 PM
  • We have logged this feedback and are looking into it.

    Thanks
    Nitin
    Friday, May 8, 2009 6:11 PM
    Moderator
  • Is there any progress on this?

    i7 920
    6GB DDR3
    W7 Ultimate x64

    Looping setup. Initializing virtual machine, starting virtual machine - reboot.

    Shift-ESC shows the VM starting and the XP logo for 2 seconds before a reboot. Rather annoying.
    Monday, May 11, 2009 3:10 PM
  • As a workaround, try disabling Intergration Features at startup; To do that open %user profile%\Virtual Machines\. Locate the Virtual Windows XP VM, right click Settings and uncheck the "Enable at Startup" dev box.
    Monday, May 11, 2009 6:09 PM
    Moderator
  • "Enable at startup" is greyed out, when it is hibernated, running or powered down.
    Monday, May 11, 2009 7:00 PM
  • "Enable at startup" will be enabled when vm is powered down. So you should be able to uncheck it.
    Thanks, Rashmi U.R
    Monday, May 11, 2009 7:30 PM
  • Hey all,

    I've tried installing the XP mode for Windows 7 RC on my computer and have not had any luck - it just keeps restarting over and over again and will not stay on.

    I tried making a new one like was suggested in another thread, but no luck there either.

    No bootable media is in there either.

    Please help!  Found someone else with the core i7 920 with similiar problems, so I don't know if it is a bios setting for that that I need to change?

    Thanks

    windows 7 RC
    Intel Core I7 920
    MSI x58
    Tuesday, May 12, 2009 12:00 AM
  • Hey All

    Can you please send your machine details (msinfo32) to wcvdata@microsoft.com ?
    Can you please try the below and see if the issue is going away -
    1. Click on Start....All Programs...Windows Virtual PC...Virtual Machines
    2. Select Virtual Windows XP, right-click -> go to Settings.
    3. Go to Close (right pane - last option) -> Select "Prompt for Action" radio button.
    4. Start Virtual Windows XP, and then close the window. A prompt pops up -> select Turn Off.
    5. Repeat Steps 1 and 2.
    6. In the settings page -> Integration Features (right pane->bottom) -> Clear the "Enable at StartUp" check box.
    7. Start the VM.

    If you still get the issue, please perform the following -
    1. Start the Virtual XP in safe mode. You can do this by pressing F8 and selecting the Safe Mode option.
    2. Go to Add/Remove Programs, and uninstall Virtual PC Integration Components.
    3. Reboot the virtual machine in normal mode.

    Please let us know your experience. This will help us in narrowing down the problem.

    We really appreciate your time on this.

    Thanks
    Nitin
    Tuesday, May 12, 2009 7:42 AM
    Moderator
  • I am unable to start Virtual XP in safe mode. Message is:

    "Windows XP Setup cannot run under Safemode. Setup will restart now."
    Tuesday, May 12, 2009 6:04 PM
  • hi,

    Did you by any chance change the BIOS settings on the machine where you are hitting this issue to disable DEP? If so, can you please enable the same in BIOS and reply if you are still able to see the issue while starting the VM [after installing Integration components]

    thank you

    Kiran [msft]

    Tuesday, May 12, 2009 6:24 PM
  • I did not change the DEP setting. In fact, I rebooted my computer to check that setting and I couldn't even find it in the BIOS.
    Tuesday, May 12, 2009 7:08 PM
  • Hi Joe,
    We have come across various names for DEP setting in BIOS. It can be called as Execute Disable, XD, NX etc. Check for these and please enable it if this is disabled. Let us know if you could boot a VM after turning this setting on.
    Also you can run some tools like securable and check if the DEP is ON or OFF. Let us know your DEP setting.

    Thanks,
    Vikas
    Wednesday, May 13, 2009 2:57 PM
  • Vikas,

    Thanks for the tip.
    I am an i7 920 user, with the Win7 RC x64 ultimate, and was having the same problem as in this thread.
    When I enabled DEP in my BIOS (I believe it was called XD, and was in the overclocking settings), my virtual machine managed to boot up fine.

    I haven't attempted any of the integration features yet, but I thought the other i7 users should know.

    Tiberias
    Wednesday, May 13, 2009 3:46 PM
  • Thanks Tiberias.
    Wednesday, May 13, 2009 4:03 PM
    Moderator
  • This also worked for me!

    Enabled XD or "Execute Disable Bit" in the BIOS and it booted right into the setup instead of looping.

    i920
    6GB DDR3
    Wednesday, May 13, 2009 5:40 PM
  • Thanks for the additional direction. I found the setting in the BIOS and after enabling it the VM booted up just fine. Problem solved.

    Thank you so much for your help.
    Wednesday, May 13, 2009 10:54 PM
  • This also worked for me.  Setting in my BIOS is called Extreme Bit Support.  By default, this is disabled.  Enabling it allowed XP to boot in Virtual PC.

    Thanks so much for working this out.

    Bryan

    Running Windows 7 Ultimate RC Build 7100
    MSI X58 Pro
    Intel i7 920
    6 GB RAM

    Thursday, May 14, 2009 2:03 AM
  • Thank you very much. The setting in my BIOS (MB MSI X58 Pro-E, i7-920 2,66GHz processor) is called Execute Bit Support and by default is disabled too.

    Thursday, June 18, 2009 7:34 AM
  • Enabling "execute bit support" in BIOS seemed to have worked for some people. However, for me this solution is not working, no matter if the virtual machine components installation were done with "execute bit support" turned on or off . Virtual machine gets stuck both on shutting down and start up/loading of integration features. Virtual machine start from hibernation takes forever and ends up with integration features loading failure. Continuing without them gives me only a black screen in virtual machine where I can't do anything except hibernate again. Reinstalled everything in home OS (Win 7 Ultimate x86) on numerous occasions. Downloaded the latest updates. Nothing seems to help.
    The issues hasn't been resolved I think.
    Saturday, December 5, 2009 6:31 PM
  • I was having the same as described here.  I have a i7 - 975 @ 3.33Ghz / 12 GB RAM Windows 7 x64.  Tried to start the XP Virtual PC and it just hung with a black screen with a blinking cursor.  I check the event logs (noted above by MSFT Tech) and no errors were found. 

     

    Solution - So I made a copy of the vhd file.  These files are located at "C:\Users\%user name here%\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines" and then created a new virtual machine that pointed to the newly copied vhd.  Then launched the new machine and it works fine. 

    I'm gonna have to make sure to backup everything on my Virtual PC before I close down.

    Monday, May 24, 2010 12:36 PM
  • I have a system in which an XP VM operated fine for about 18 mos.  Yesterday I ran a PC cleaning software.  Now it will not start--reporting Windows does not know what program to use to open Windows XP Mode.vmcx.  I do not know what to associate with a .vcmx.  This is bad cause my time and billing prgm is in the XP VM.  Yuch.

    Toshiba lappie with AMD Vision CPU, Win 7x64 Pro. 4GB RAM with about 1.8 GB free, 320GB HDD, about 170GB free.

    Thanks anyone

    Friday, June 15, 2012 10:04 PM
  • Do you have a backup from before running the system cleaning software? 
    You could also try a system restore from before the time the pc
    cleaning app ran.
     
    Whatever cleaning app you used might have an undo function of some kind
    too.
     

    Bob Comer - Microsoft MVP Virtual Machine
    Friday, June 15, 2012 11:07 PM
  • Bob,

    Thanks for your reply.  I did try the registry restore, which is supposedly from before the cleanup by SpeedyPC Pro.  No joy.  Windows claims gthere are no system restore points.  The c: drive is said to be protected but not the System.  Say what?

    So, any other ideas?  Create a new VM? Do I need a disk to do this b/c I installed the VM from downloads.  And would a new VM contain the installation of my billing software?  Or is that a meaningful question?

    Phil


    /PLM/

    Saturday, June 16, 2012 12:03 AM
  • Hi Vikas,

    I was able to clear the 'Enable at Startup' box and get into the BIOS.

    Unfortunately I couldnt find the XD. As a matter of fact there are no many things to do in the BIOS.

    This error started to show after a sudden turn off of the computer (caused by a power failure due to a storm) 

    Then when I don't enter the Bios I get the following windows

    It goes from left to right and none of the options I select works.

    The VM was working okay before the power failure and I had just installed it. Still I wouldnt want to have to install it every single time a power failure occurs.

    Any thoughts?

    Thanks a lot

    Xavier


    Vru


    • Edited by vruatsa Tuesday, October 16, 2012 9:49 PM
    Tuesday, October 16, 2012 9:49 PM
  • The BIOS you need to look in is on the host PC, not in the VM. 
    Tuesday, October 16, 2012 11:09 PM