none
Proxy Authentication RRS feed

  • Question

  • Hi,

    I'm hoping someone can help me with a problem I'm having.  I am deploying a new proxy server which uses NTLM to authentication users.  A small portion of users log into a shared PC with a generic domain user account that is not authorised to access the Internet.  For these users, I would like for them to be prompted to enter their AD credentials but the behaviour of Internet Explorer seems to be to authenticate to the proxy automatically with the account that is logged into the workstation.  Is there a way to change this behaviour in IE so that the users are prompted to enter credentials when authenticating to the proxy server?  Firefox seems to have this as a configurable option ( setting network.automatic-ntlm-auth.allow-proxies to false invokes the behaviour I"m after )

     

    Thanks,

     

    Ben.

    Friday, September 9, 2011 12:18 AM

Answers

  • بسم الله الرحمن الرحيم

    Allow Anonymous Users to Provide Credentials

    Problem: When users that do not belong to a user group try to access the Internet through ISA Server, they do not get prompted for credentials.

    Cause: There may be specific circumstances in which you want to allow users who do not belong to a user group to input credentials. With Windows Integrated (NTLM) authentication enabled, users are not prompted for credentials.

    Solution: To provide such users with the opportunity to input credentials, do any of the following:

    • Choose both Integrated and Basic on the Web Proxy tab of the network properties on which such requests are received.
    • Launch Internet Explorer using the RunAs command to provide credentials.
    • Log on to the computer temporarily using an account with permissions to access the Internet.

    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator Abdul Samad Al Qurashi Co.
    • Marked as answer by B_Bry Sunday, September 11, 2011 10:19 PM
    Saturday, September 10, 2011 7:44 AM

All replies

  • بسم الله الرحمن الرحيم

    Allow Anonymous Users to Provide Credentials

    Problem: When users that do not belong to a user group try to access the Internet through ISA Server, they do not get prompted for credentials.

    Cause: There may be specific circumstances in which you want to allow users who do not belong to a user group to input credentials. With Windows Integrated (NTLM) authentication enabled, users are not prompted for credentials.

    Solution: To provide such users with the opportunity to input credentials, do any of the following:

    • Choose both Integrated and Basic on the Web Proxy tab of the network properties on which such requests are received.
    • Launch Internet Explorer using the RunAs command to provide credentials.
    • Log on to the computer temporarily using an account with permissions to access the Internet.

    Mohamed Abd Elhamid Abd Elaziz Microsoft System Administrator Abdul Samad Al Qurashi Co.
    • Marked as answer by B_Bry Sunday, September 11, 2011 10:19 PM
    Saturday, September 10, 2011 7:44 AM
  • Hi, another option might be, on that single PC, adjust the IE settings to disable Integrated Authentication.

    e.g. Options, Security, InternetZone, CustomLevel, UserAuthentication, PromptForUserNameAndPassword


    Don
    Sunday, September 11, 2011 2:11 AM
  • Thanks for the response ... I ended up using RunAs and it seems to work as required.  Came back to post the answer and saw your response which mentions this.
    Sunday, September 11, 2011 10:20 PM