none
Software center not showing applications as installed when installed as a dependency

    Question

  • Hi

    In our setup we have some applications that are both published individually in Software center and installed as a dependency when installing other applications. When installed as a dependency Software Center still publishes the application as available and not as "installed". If you run the "missing" application separately after this it will just detect it without launching the installer. 

    The application is correctly detected as installed in AppDiscovery.log it's just Software Center that is not updating correctly. 

    We'r running agent version 5.0.8577.1108

    Any ideas on what could be the problem?

    Tuesday, February 20, 2018 10:31 AM

All replies

  • When you run an application deployment evaluation cycle does software center update to show the correct status of each application?

    The main application that has the dependency set is a required deployment?

    Does it have the auto install checkbox enabled for it's dependencys? 


    Richard Knight | Collection Refresh Manager | Twitter


    Tuesday, February 20, 2018 10:57 AM
  • The main applications is published as available so you have to manually click install on that one. the auto install checkbox is enabled and the dependencies install correctly when doing this. But software center only shows the main application as installed not the dependencies.

    Running the Application deployment evel does not update software center but the application is detected as installed in appdiscovery.log

    Tuesday, February 20, 2018 11:14 AM
  • Dependency applications are not listed in software center unless they are also deployed individually.

    As your main application is deployed available then what you are seeing is expected behaviour.

     If you install the main application, then wait for the machine to do an app deployment evaluation cycle it will probably update software center to reflect the current state.

    Richard Knight | Collection Refresh Manager | Twitter


    Tuesday, February 20, 2018 11:22 AM
  • The dependencies applications are published individually as well, waiting for the app deployment evaluation cycle does not work.

    It's been over a week on some computers since the application was installed and it still doesn't show in SC. I'm thinking the problem started when i upgraded to 1710 as it was working on earlier versions of software center. But I have no exact date when it stopped working. 


    Tuesday, February 20, 2018 11:32 AM
  • Just about to test an application that has a dependency in the lab. Will check out the scenario.

    Richard Knight | Collection Refresh Manager | Twitter

    Tuesday, February 20, 2018 11:45 AM
  • Hi,

    I tested on the previous version of the client and 1710.

    Installing the available application from software centre on 10 devices causes the dependency application to vanish from the available software tab, they all showed in the installation status \ installed software tab.

    No machine policy update or app deployment evaluation cycle was required, it auto updated within a minute or 2.

    Try a full uninstall \ reinstall of the Configuration Manager client on a device with all pre-reqs.

    rule out things like AV \ group policy interfering.


    Richard Knight | Collection Refresh Manager | Twitter



    Tuesday, February 20, 2018 2:03 PM
  • Hi,

    If you update the dependent application after the primary application has been deployed, any new content for the dependency will not be automatically distributed.

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 21, 2018 8:27 AM
  • Same behavior here but not with dependencies.

    Think about a KeePass application including a working detection method. Click "install" in Software Center, it installs and gets detected correctly.

    Now think about a user who manually installed the same KeePass version. The application is deployed to "any machine" as "available". So, this user get's it as well. But it never shows up as installed in Software Center unless I click one time on "install". Even running the "Application Deployment Evaluation Cycle" does not change the button to "uninstall" or list it as installed in "Installation Status". AppDiscovery.log shows the DeploymentType_blabla as "discovered".

    We're using SCCM 1802 with all 3 hotfixes and Agent 5.00.8634.1814.

    This once worked before, so seems to be a bug :-(


    Monday, October 1, 2018 12:41 PM
  • Maybe not a bug, but a possible design short-coming. Although, based on my knowledge, this is correct. The client agent won't and doesn't evaluate the compliance status of available deployments (and never has) until the user initiates the installation.

    Have you reported your desired change to Microsoft using a frown in the console (1806+) or UserVoice?


    Jason | https://home.configmgrftw.com | @jasonsandys

    Monday, October 1, 2018 3:51 PM
  • New idea posted:

    https://configurationmanager.uservoice.com/forums/300492-ideas/suggestions/35629099-deployment-evaluation-cycle-detects-manually-insta

    I was sure this worked once, but I could be wrong. I may have clicked on the install button once when I observed the "supposedly correct" behavior that time. I was just installing and uninstalling the application for testing purposes (manually and through SCCM) and ran the evaluation cycle in between to verify the detection method.

    Thursday, October 4, 2018 9:28 AM